1 Reply Latest reply on Dec 16, 2010 4:23 PM by

    CANNOT INSTALL INTEL AHCI DRIVERS WITH H55 chipset (WINXP)

      Can anyone see what I am doing wrong?

       

      I have just upgraded a PC to use a Gigabyte GA-H55M-UD2H Rev1.3 motherboard with an Intel Core i3-540 processor, 4 GB memory and using the onboard i5 graphics.

       

      Everything works fine, until I try to enable AHCI during a Windows XP (32 bit) installation using the “F6” driver installation technique (something I've been able to do fine on ASUS motherboards in the past - different chipset, though).

       

      This motherboard uses the Intel H55 chipset, which provides SATA and AHCI support, and the reason I want to install the AHCI SATA drivers is that I want to be able to hot-swap eSATA drives.  We use eSATA extensively for backup, and bought this motherboard on the presumption that the eSATA connector could be made to work.

       

      The Intel web site is clear that in order to be able to hot-plug eSATA you need the latest (AHCI) Intel drivers.

       

      But whatever I do, I always get the “Blue screen of death” (Error code STOP: 0x0000007B  (0xetc…) when AHCI is enabled in the BIOS, which means that Windows cannot load a driver successfully.

       

      1. I downloaded the AHCI drivers for the Rev 1.3 GA-H55M-UD2H from the Gigabyte support site at http://www.gigabyte.com/products/product-page.aspx?pid=3503#ov and installed all the driver files onto a floppy as instructed. The driver file downloaded is at version 9.5.0.1037 (2010/03/03). Filename is “motherboard_driver_intel_sata_irst_32.exe".
      2. I then set the BIOS to run in AHCI mode
      3. I then put the appropriate drivers onto a floppy and start to install Windows XP.
      4. I carefully follow the instructions available in many places, for example this clearly written set:
        http://www.intel.com/support/chipsets/imsm/sb/cs-021736.htm
      5. I hit F6 in response to the message “Press F6 if you need to install a third party SCSI or RAID driver” and when requested insert the floppy. The      floppy is read, and you are then given four different options to choose from:

      a)  Intel(R) ICH7R/DH SATA RAID Controller

      b)  Intel(R) ICH7MDH SATA RAID Controller

      c)  Intel(R) ICH8R/ICH9R/ICH10R/DO/5 Series/3480 Series SATA RAID Controller  ß This seems the more likely

      d)  Intel(R) ICH8M-E/ICH9M-E/5 Series SATA RAID Controller  ß This is selected by default

      1. Once the drivers are copied across from the floppy I can continue the Windows XP installation, but a minute or so later I get a Hard stop with Error  0x0000007B. In fact I get this hard stop in AHCI BIOS mode whether or not I install any drivers and regardless of which driver I try to install.
      2. I’ve tried all four options, one after the other, but all of them fail. Options c and d I’ve tried twice each.
      3. If I install Windows XP without the AHCI drivers (with AHCI disabled in the BIOS) the installation works fine. I can then look at Device Manager with      says that the SATA controllers are:
        1. Inter(R)  5 Series /3400 Series Chipset Family 2 port Serial ATA controller – 3B26
        2. Inter(R)  5 Series /3400 Series Chipset Family 4 port Serial ATA controller – 3B20
      4. These description do not tie up with the descriptions built into the Intel drivers (see item 5) but option (3) appears the best fit.  In the end I tried all four options, just repeating the attempted installation over and over.  None of the drivers work.
      5. I’ve even tried running the installation with AHCI disabled, but loading the      AHCI drivers in the hope they can work in either mode, but no, I still get   the BSOD.

       

      So that’s as far as I’ve been able to get.  I can’t believe Intel haven’t thoroughly tested their drivers with Windows XP, so I must be doing something wrong.

        • 1. Re: CANNOT INSTALL INTEL AHCI DRIVERS WITH H55 chipset (WINXP)

          Solved!  No one has replied, I will answer my own question.

           

          The answer is simple - it turns out that there are many more driver options on the floppy than show, and you just use the arrow keys to move up and down the list.

           

          Once I found the right driver the problem went away.  The selection is still not intuitive - for the Gigabyte GA-H55M-UD2H you need to select

            Intel(R) 5 Series/3400 Series SATA AHCI controller  

          - this for a Motherboard whose spec. say it has a H55 chipset. How you are supposed to know to select this option and not the 5 Series 6 Port SATA AHCI controller or several other options that sound equally correct, I'm not sure!

           

          Anyway, I felt somewhat stupid to miss the up/down arrow key point, as the Intel instructions clearly say that the arrow keys can be used in this way, but I'm glad to say I'm not the first to have this problem. (I too have not had more than 4 options to choose from before!)

           

          In this post http://news.softpedia.com/news/Install-Windows-XP-On-SATA-Without-a-Floppy-F6-47807.shtml you find this experience:

           

          "F6 (Intel Matrix SATA drivers) XP Install Floppy Disk - - SCROLL UP with the Arrow keys on the keyboard!

           

          I fought with this for hours when installing xp pro a couple of weeks ago on an HP dc7900 mini convertible desktop tower pc. The problem is the updated driver by intel that came out in dec 2009 contains 17 choices!!!

           

          The windows xp press F6 during install ONLY has room to display 4 driver choices (with one highlighted) and if the disk contains more that 4, you must SCROLL to see them - BUT - there is no scroll bar in this part of the install which is still DOS based, so there is nothing visually on the screen to let you know you must scroll - I found it by accident! In all my years of installing drivers with F6 I can't remember a disk containing more than 4 choices!

           

          This solves the great mystery .... etc.

           

          Anyway - I hope this helps someone else to waste less time!