3 Replies Latest reply on Feb 16, 2012 10:24 AM by edwardzh

    My issues when upgrading MFSYS25 firmware from 5.5 to 6.6


      I've experienced issues with my last two upgrades that I'm sharing for the benefit of others who may also be planning an upgrade. The first issue was when I upgraded an MFSYS25 from firmware 2.7 to 5.5. After the upgrade completed, all of the virtual drive to server mappings had been removed. The virtual drives were still in tact, but no drives were mapped to any servers. Fortunately we had documented all of the mappings so we just re-mapped them and all was ok.


      Last night we performed an upgrade from 5.5 to 6.6 on the same MFSYS25. This unit contains 6 MFS5000SI modules, 14 drives, a single SCM and a single switch. Once the CMM had rebooted and we were able to logon to the web interface again, I was no longer able to logon.


      I had renamed the default 'admin' username to a different username. The upgrade process renamed the account back to 'admin' and also cleared the email notification settings associated with the account, too. The password remained the same as what I had last changed it to. Maybe this was just a fluke on our system, but I'm sharing just in case someone else runs into this.


      The second issue I had on the 5.5 to 6.6 upgrade is that one of the six compute modules would not boot after the upgrade. I tried swapping slots and still no luck. I ended up having to clear the CMOS (removed the CMOS battery for 20 seconds) and then powered it back on and it completed the BIOS upgrade with no issue.


      Hopefully this may prove useful to anyone else who encounters these issues. I'm also curious whether anyone else encountered this.



        • 1. Re: My issues when upgrading MFSYS25 firmware from 5.5 to 6.6

          I haven't done that big of a jump in updates on the modular server, but I've seen similar issues doing big jumps on other motherboards.


          I have had to clear the CMOS on the compute modules before they would finish the update.

          • 2. Re: My issues when upgrading MFSYS25 firmware from 5.5 to 6.6

            Hi, I just wanted to chime in on this.  I did a firmware update this past weekend and ran into the issues, and I couldn't find a whole lot of relevant information except for this post.


            My company inherited support of a MFSYS25 with 4 compute modules.  Firmware was at 2.7.  We had an issue a while back of the thing locking up when we attempted to power on the compute modules through the management interface, and Intel's suggestion was to update the firmware.  I updated it to 6.8, which although it's a big jump, it was documented as an okay path to go, and support assured me it was good.  I opted to not do 6.9 since I had already been looking into 6.8 for a bit.


            Basically, things were going pretty smoothly until the BIOS updates to the compute modules was the next step, and all four of them would post.  Just like the OP, I was able to get two of them going after simply using the jumper on board to reset the CMOS.  The other two, I'm honestly not sure what it was that fixed them.  I reset the CMOS a few times, and tried another jumper for the recovery BIOS, to no avail.  I tried different combinations of pushing the power button and powering on through the interface as well.  After a couple hours of trying, I had another person remote in to look at it.  He simply clicked the link to reset one, and it did the BIOS updated and then booted up.  The other, which was powered off, he clicked the link to power on, and this one too then went flawlessly.  These were steps I had already tried, so I'm not sure what it was that caused it to work that time (perhaps letting them sit for a while did it?). 


            I write this just incase any others run into problems and happen across this.

            • 3. Re: My issues when upgrading MFSYS25 firmware from 5.5 to 6.6

              The compute modules need to boot to EFI shell to complete the BIOS update. If EFI shell is disabled in BIOS Boot Options, the update may fail. The best way is to attach a monitor to the compute module and see if there are any errors on the screen.