10 Replies Latest reply on Dec 13, 2011 2:34 PM by goneballistic

    SS4200-e failed raid


      I have an ss4200-e which has marked all 4 drives as non-raid members with data requesting to be over written. Tech support was no help. wipe out the drives and restore from backup.


      I have seen posts with this same issue, and that access is possibel and the data is OK.


      So what is involved. I do not have an operational linux system but I can build one.  Ubuntu seems to be the most discussed.


      I have seen this type of issue with RAID sets on other controllers in the past and the trick was to define the array but not initialize. This is what I am hoping to do.


      I like this post which implies that I should be able to possibly access the existing linux on the flash card.




      If so and I can find the correct commands I should beablt to telnet into the system define the array and without initializing the array see if the data comes up accessable. I know th board is using an ICH7 controller.


      Any help on the linux specifics would be appreciated. My last major unix work was in the late 80's and early 90's. the last was an ocassional use of a SCO box a few years ago.



        • 1. Re: SS4200-e failed raid

          Did you already try the

          >mount.nfs   /192.168.1.x/mnt/soho_storage/samba/shares/your_shared_folder_name     /your_mount_point

          command that oeatekoeatek mentioned?

          • 2. Re: SS4200-e failed raid

            Thanks, As I stated earlier I do not have a Ubuntu system so I have not tried the mount command. How ever I have connected to the system via the serialport on the MB. However when trying to login the web interface username and password are not working. The system identifies itself as an EMC SOHO envireonment, and I can see all the drives correctly identified during the loading of the environment. where can I find the login and then the commands to look at the raid environment?



            • 3. Re: SS4200-e failed raid

              OK Wish I had found this sooner.Since changing the drives one at a time with a new never been used drive made no difference, I was looking for other options to Identify the origins of the problem, Many of the options given in other discussions faild with the error of being unavailble due to no storage volume being mounted..etc... No Joy In Mudville


              So trying to get a logdump i find there are other utilities available by going to the settings tab, and then editing the web address replacing storage with support. so in my test environ this is which becomes, and what do you find a recover disks option. Upon beginning recovery the entry from the serial terminal access described here http://ss4200.pbworks.com/w/page/5122741/Console-Access-via-RS232 is:


              storage login: md: md0 stopped.
              md: bind<dm-1>
              md: bind<dm-2>
              md: bind<dm-3>
              md: bind<dm-0>
              raid5: device dm-0 operational as raid disk 1
              raid5: device dm-2 operational as raid disk 3
              raid5: device dm-1 operational as raid disk 2
              raid5: allocated 4203kB for md0
              raid5: raid level 5 set md0 active with 3 out of 4 devices, algorithm 0
              RAID5 conf printout:
              --- rd:4 wd:3
              disk 1, o:1, dev:dm-0
              disk 2, o:1, dev:dm-1
              disk 3, o:1, dev:dm-2
              RAID5 conf printout:
              --- rd:4 wd:3
              disk 0, o:1, dev:dm-3
              disk 1, o:1, dev:dm-0
              disk 2, o:1, dev:dm-1
              disk 3, o:1, dev:dm-2
              md: recovery of RAID array md0
              md: minimum _guaranteed_  speed: 1000 KB/sec/disk.
              md: using maximum available idle IO bandwidth (but not more than 200000 KB/sec) for recovery.
              md: using 128k window, over a total of 976759936 blocks.
              kjournald starting.  Commit interval 5 seconds
              EXT3 FS on dm-5, internal journal
              EXT3-fs: mounted filesystem with ordered data mode.


              So now I can see disk 4 was the culprit and during the rebuild I can see errors on the drive


              ata3.00: exception Emask 0x0 SAct 0x7 SErr 0x0 action 0x0
              ata3.00: (irq_stat 0x40000001)
              ata3.00: tag 0 cmd 0x60 Emask 0x9 stat 0x41 err 0x40 (media error)
              ata3: EH complete
              SCSI device sdc: 1953525168 512-byte hdwr sectors (1000205 MB)
              sdc: Write Protect is off
              SCSI device sdc: drive cache: write through


              The rebuild took about 10hrs. Now I have access to the files I can copy those and then replace the bad drive with a replacement rebuild fo another 10 hrs and breath again.
              I am most annoyed that intel support seems oblivious to the functions existience.
              • 4. Re: SS4200-e failed raid

                Here's my problem: I have a SS4200-E system and recently had a power failure which messed the system up.  When I turn it on the LED lights are amber, meaning bad disk. I have searched the forums and onlline support and came across this post which seems like what I am looking for.  However, I am new to this system and need some clarification.  After several attempts, restarting and pushing the reset button (all suggestions of other posts), I am still getting the amber LED lights.  I am able to log in using the Intel Entry Storage web interface.  I navigated to the support.html page and have the following options; support access, dump files, recover disks, and reset data protection.  I tried to dump files but got a message that says "Unable to gather system state because the storage volume is not up."  I'm not exactly sure what that means.  I'm guessing it can't reach the drives.  I want to try the recover disks option but I'm not sure what it will do.  I don't want it to wipe out the data.  I would like to retrieve the data from these drives.  So my question is what does the "Recover Disks" option and the "Reset Data Protection" option do?


                Thanks for any help/suggestions you can provide.

                • 6. Re: SS4200-e failed raid

                  I have tried to get to the diagnostic logs but got a message that says "Unable to gather system state because the storage volume is not up."  I was going to try the recover disks but I would like to know what it is going to do.  I don't want it to wipe everything on the disks.  Do you know if 'recover disks' is going to wipe the disks or restore what is on them?



                  • 7. Re: SS4200-e failed raid



                    Recover Disks will attempt to recreate the array on the existing drives preserving user data.  It requires all the original drive to be present and functional.  Reset Data Protection will clean the drives and rebuild the array, destroying any existing data on the drives.




                    • 8. Re: SS4200-e failed raid

                      John S,


                      when I look at my support page, there are only two options,  there is no "recover disks" option.  When I look at settings > disks,  all four disks actually show upand look like the right size, so I think they are all on.


                      any ideas why that page isn't showing up?



                      • 9. Re: SS4200-e failed raid



                        It may be a firmware version thing. What version do you have installed on your SS4200? The latest is



                        • 10. Re: SS4200-e failed raid

                          I did do a system reset to it's back to whatever the shipping version is,  I can't seem to upgrade the bios,  when I do it says due to the state of the disks it's not available.

                          • 11. Re: SS4200-e failed raid
                            Your reply was rejected by a moderator. Please edit your reply and resubmit it for approval.


                            JflTtq  英超积分榜[/url] XgrHjx  新浪NBA直播吧[/url] WnfMxx  NBA直播热火[/url] TeoNef  博彩通[/url] PzxRyo  TT娱乐城[/url] OcqYck  芝加哥娱乐城[/url] FzmBdg  百家乐[/url] LaqLhp  百家乐[/url]

                            CjnQef  新全讯网[/url] BxzOwz  全讯网新2[/url] EftKca  全讯网新2[/url] DcqFsj  百家乐[/url] ImoQwh  TT娱乐城[/url] MvsScp  全讯网[/url] RzsNfb  全讯网新2[/url] DhbVlb  太阳城[/url] TisLjm  全讯网新2[/url] PagLfo  TT娱乐城[/url]



                            KmnRye  NBA直播视频直播[/url] DhbEgn  吻球网足球直播[/url] AcdTyn  英超赛程表[/url] WfuGgw  吻球网足球直播[/url] MveGgd  腾讯NBA直播[/url] YruFaj  吻球网足球直播[/url] VquXis  英超赛程表[/url] EweQvc  英超直播[/url]

                            JjtBxu  英超直播[/url] JncXfy  腾讯NBA直播视频[/url] XegCpz  NBA直播[/url] BulTfk  新浪NBA直播[/url] QuaEuk  英超宝贝[/url] JnaZeu  新浪体育NBA直播[/url] OghNmr  英超联赛[/url] RpfAih  NBA直播热火[/url]


                            KtgUhw  NBA直播[/url] XtgQuj  天下足球直播[/url] EqsMfd  NBA直播吧[/url] DypOkz  NBA直播视频直播[/url] ZbzRrt  腾讯NBA直播[/url] TozZfn  天下足球直播[/url] QswEuf  NBA直播湖人[/url] UccWzt  英超直播[/url]



                            YhiJil  英超积分榜[/url]BkrCpn  英超赛程表[/url]GtlZns  天下足球直播[/url]OacHkw  新浪NBA直播吧[/url]FroGgl  NBA直播吧[/url]RbtFzj  风云足球直播[/url]IouWuu  英超积分榜[/url]LnvMpf  英超赛程表[/url]



                            VkiTjp 德州扑克[/url] BjdXue 英超赛程[/url] NrhIky 英超积分榜[/url] PkzQwl 足球直播吧[/url] KoxLeu 天下足球直播[/url] HptYwi NBA直播湖人[/url] NBA直播吧[/url] NfuPwz 新浪NBA直播[/url] EqmUrq 太阳城[/url] QjlJfa 五湖四海全讯网[/url] KvaLbu 百家乐[/url] VzzJnk TT娱乐城[/url] CvuWlg 88娱乐城[/url] FkoGvq 博彩网[/url] XllYpx 全讯网[/url]  OybMbk 百家乐[/url] ZmaRbg 博彩网[/url] WmiXet 太阳城娱乐城[/url] WnhOvf 百家乐[/url] 博彩通[/url]