8 Replies Latest reply on Nov 23, 2010 5:14 PM by Domain

    New BIOS release for Intel DX58SO

    Shirke
        • 1. Re: New BIOS release for Intel DX58SO
          Domain

          So being the brave soul I am (or perhaps brave isn't the right word), I attempted this update hoping at long last it might resolve the lingering issues that have kept me back at BIOS 4405.

           

          As standard procedure, I flashed/loaded defaults/reconfigured/rebooted.

           

          UEFI input issue is resolved (this was broken sometime after BIOS 5200)

          LAN failure after S3 (this was broken sometime around BIOS 5390, and the later fixed in BIOS 5456) appears to still be resolved.

          RAID failure after BIOS 5456 is applied (where volume will immediately degrade) appears to be resolved.... or so I thought.

           

          Everything looked good until the second reboot... thats when things started going downhill.  RAID controller immediately marked the disk in Port 3 as "failed", and marked volume as degraded.  RST refused to do anything with the "failed" disk, so I rebooted, pulled the disk out of the array, and immediately ran the manufacturers disk diagnostics tool... tool reports disk as perfectly fine, all SMART parameters are perfect as well.

           

          So... for now I would warn anyone using RAID configuration on this board to be careful of this BIOS (or BIOS 5456 as well).... if you are feeling brave, at the very least make sure you have a full backup (I created one prior to this attempt).

           

          For now I am going to try to re-add the disk back to volume, and rebuild.  However, if BIOS 5456 has taught us anything, I suspect I will have to revert back to BIOS 4405 to completely resolve the issue.

          • 2. Re: New BIOS release for Intel DX58SO
            Dogwood

            Thanks for the report. You're a brave soul, Mr. Domain!

             

            Here's the link to the earlier thread I started about how the previous BIOS update, 5456 (8/30/10), was a RAID-killer: http://communities.intel.com/message/101699. The follow-up from others confirmed that mine was not an isolated experience.

             

            I was surprised that there wasn't a quicker response from Intel. Sounds like this latest update, almost 3 months later, still hasn't fixed the problem. This is a pretty serious screw-up. I chose the Intel board over others specifically because I was playing it safe. Intel's boards are reputed to deliver reliability and stability and support. And the DX58SO had served well until 5456. Completely solid for me (except for some issues with the E-SATA ports, and I'll allow for the possibilitity that this isn't the fault of the raw board).

             

            I still haven't seen any word that Intel is aware of this problem and has attempted to address it. Do the developers get reports from this forum? The release notes for 5506 show a new RAID BIOS revision, but there are no details.

             

            I guess I'm sticking with 5417 (7/27/10).

            • 3. Re: New BIOS release for Intel DX58SO
              Domain

              The behavior this time seems a little different then when I tried BIOS 5456, but right now it is too early to be sure.  After running and extended diagnostic on the "failed" drive, I rebooted and put the disk back into the array without issue.  Right now it is doing a rebuild (this is a 3 drive RAID 5 volume), so in a few hours I will try another reboot and see how it goes.

               

              Since I am so brave (read: daft in the head) if I end up with another failure/degrade, I will go so far as to break the RAID, re-create it, re-initialize it, and post the results here.  I was already going to have to do a great deal of work anyway (I'm switching to SSDs in the next few days) so since I have a fresh backup, might as well prove without a doubt that the BIOS is/isn't completely broken.

               

              Also interesting that they went to 10.0.0.1046, since the RST drivers for this version have yet to be "officially" released (they are available if you go looking for them though).

              • 4. Re: New BIOS release for Intel DX58SO
                16floz470ml

                I just updated to the new bios.  So far no problems with my raid setup.  I had raid on 5456 also with no issues.  Two X25-M 80gb drives.  The only problem that I keep seeing is the v droop setting in the bios is opposite.

                • 5. Re: New BIOS release for Intel DX58SO
                  Domain

                  Indeed... rebuilt RAID, rebooted... everything fine.  Tried a number of reboots/shutdowns/sleep cycles, everything still fine.  At first I thought it was just perhaps a fluke... then I remember I had been poking around with EFI setting to see if keyboard issue had been fixed.  So, turned UEFI boot back on, same drive went back into "failed" status, and RAID is back in degraded.

                   

                  So, had to do the same procedure, remove drive from RAID, add it back, and start rebuild all over again.  So, based on that, seems like this release may be "safe" if you dont' mess around with the UEFI boot option.

                  • 6. Re: New BIOS release for Intel DX58SO
                    Dogwood

                    Domain, I might have expected the low-level RAID handling to be substantially self-contained (the RAID ROM even has its own version number), and thus relatively isolated from other features. Should I be surprised that it somehow ends up linked to your tweaking UEFI in pursuit of keyboard support? It's good that your system now seems stable, but your experience doesn't exactly inspire confidence. I figure I'd better avoid this update unless I find I really need it for something. My general approach has usually been that the latest and greatest is probably a good idea, in that it might avoid pitfalls that I didn't know were there. But sometimes the downside risk outweighs the theoretical benefit.

                    • 7. Re: New BIOS release for Intel DX58SO

                      hola. he instalado el bios version 5506 de la placa dx58so y el problema que tengo es que no arranca el ordenador, la pantalla está negra y con una raya blanca parpadeando. He comprobado que desconectando mi lector de tarjetas externa usb, si arranca el ordenador después de volverlo a encender. ¿Alguien sabe a que es debido?. Con anteriores versiones de la bio no me ha pasado esto nunca. Gracias

                       

                      hello. I installed the version 5506 bios on the motherboard DX58SO and the problem I have is that the computer will not boot, the screen is black and a white streak flashing. I found that disconnecting my external usb card reader, if you boot the computer after turning it back on. Does anyone know who is that?. With previous versions of the bios I had this happen before. Thanks
                      • 8. Re: New BIOS release for Intel DX58SO
                        Domain

                        Dogwood, things get even more strange   I decided to waste a great deal of time last night, and really validate what was going on... basically my findings were:

                         

                        UEFI Boot Disabled:

                         

                             Raid 0 (2 Drive/3 Drive) = OK.

                             Raid 5 (3 Drive) = OK

                         

                        UEFI Boot Enabled:

                         

                             Rad 0 (2 Drive/3 Drive) = OK.

                             Raid 5 (3 Drive) =  FAIL

                         

                        So essentially when UEFI boot is enabled, RAID 5 will fail... you can sucessfully create a volume, and it will show as a OK, so long as you never get to the point the system tries to boot to a drive (i.e. you can reset during POST, and it will still be okay).  It isn't just a degrade however, the first time you reach the critical point in boot, the next time you restart you drives will actually be marked as failed, an the only action is to mark them as non-RAID.  Sometimes it was 2 drives marked as failed, sometimes only 1... but it always occured.

                         

                        I did not testing Raid 1, as well... after 6 volume builds I was very tired.

                         

                        I also noted that when UEFI boot is enabled, and you do a fresh install of Windows 7, the Desktop Control Center along with Desktop Utilities do not function (the services crash on start, or hang indefinately), however they work fine without UEFI.

                         

                        Suffice to say, it is probably best just to leave UEFI off on this board.... permanently.

                         

                        Otherwise, so long as you leave the switch off, the other nagging problems I have had are mostly gone, so I may try to stay on this revision for some time to see how things go.