4 Replies Latest reply on Mar 24, 2011 10:03 AM by

    S5520HCV Fans issue FRU doesn't update


      Hi guys,


      Things I've done:


      1) Added the extra drive to SW RAID

      2) Added the second CPU

      3) Upgraded memory

      4) Added PCIE NIC

      5) Loaded new firmware package (v54) and updated FRU - ok


      System worked for two days and everything was ok. Though


      1) System saw the extra drive I was going to use as the host for another VM as the global spare and there was no way I could change it

      2) Put PCIE Adaptec RAID card and moved the new drive to that controller


      Found, that after moving that drive I no longer had access to the secondary Volume (virtual Drive)!!!!!!!!!!! It's gone.....

      First question:where has the entire partition gone??


      I disconnected the second and forth drive from the mirror. Started the system and after 20 seconds system fans's gone crazy.

      I thought this is because the system detected both drives in degraded state. Though, even after resetting discs to Non Raid fans were still blowing and full speed.


      BIOS shows error: BMC controller failed


      When updating BIOS it goes through updating all of the components and doesn't show any errors. When I try to update FRU and SDR repository, I get the message FRU header invalid.

      Front plane temperature sensor doesn't exist, without it fan control won't work correctly.


      Could you tell me what went wrong and whether I should shop for a new board (while this one is getting replaced??)?


      Thank you,


      PS When log in to RMM3 and try to access FRU info, I get the error message that in cannot be accessed.........................................

        • 1. Re: S5520HCV Fans issue FRU doesn't update

          It seems we have several different issues here:


          1. New drive always marked as hot spare. This could be resolved by installing latest RAID driver and RWC2.

          2. Missing VD. May need more information on your RAID configuration. What do you see in RAID Web Console 2? Do you still see the physical drives?

          3. BMC failed. This doesn't look good... Did you try to unplug the power cord from the system to reset the BMC? Can you try a BMC firmware update and see if there is any errors?

          • 2. Re: S5520HCV Fans issue FRU doesn't update

            Yes, I thought it was a corrupted BMC. Tried forced update etc  - nothing worked. Replaced with Advanced replacement. Already installed and it works perfectly.


            In regards to the RAID issue.


            Yes, I'm aware that new drive become a hot spare and Intel Embended RAID doesn't support JBOD.

            The issue was that after disconnecting hot spare virtual drive became unreadable. Though, I could still see it as the Virtual Drive with two physical discs, I could access the info on it. After disconnecting both of the physical drives from the system, I couldn't find ANYTHING on both drives.



            • 3. Re: S5520HCV Fans issue FRU doesn't update

              Could you provide more details on your RAID configuration - how many PDs, how many VDs, RAID level, etc., and which VD becomes unreadable? Do you see the VD in device manager? Is there partition on it?


              A screenshot of RWC2 might help. Also try to capture the RAID log from RWC2 and post here.

              • 4. Re: S5520HCV Fans issue FRU doesn't update

                Solved by replacing the board. Corrupted BMC.

                I guess RAID error was partially due to the same reason