1 Reply Latest reply: Nov 21, 2010 2:10 PM by meilon RSS

    IAStorDataSvc Process consumes 100% of a CPU

    meilon

      Hi there!

       

      I got an ASUS P5K Premium Motherboard with an Q6700 on it. A while ago I started to notice that process explorer from sysinternals was giving my constant 30% cpu usage readings. I looked closer and found out that the IAStorDataSvc.exe process consumes about 25% CPU all the time.I/O is normal, when the system idles it idles, too.

      With Process Monitor I could only see that the PID opens und closes a Thread about every 10 seconds.

      When I try to open the IAStorUI, UAC asks for permission. After granting, it takes about 10 seconds and I get an error report from windows (sorry, it's german):

       

      Beschreibung:
        Stopped working

       

      Problemsignatur:
        Problemereignisname:    CLR20r3
        Problemsignatur 01:    iastorui.exe
        Problemsignatur 02:    9.6.0.1014
        Problemsignatur 03:    4b8f2447
        Problemsignatur 04:    PresentationFramework
        Problemsignatur 05:    3.0.0.0
        Problemsignatur 06:    4b595113
        Problemsignatur 07:    756
        Problemsignatur 08:    57
        Problemsignatur 09:    System.InvalidOperationException
        Betriebsystemversion:    6.1.7600.2.0.0.768.3
        Gebietsschema-ID:    1031

       

      When I try to install the latest rapid storage driver (which is installed) the installer tells me that my system doesn't match the minimum criteria.

       

      Any ideas how to fix this?

        • 1. Re: IAStorDataSvc Process consumes 100% of a CPU
          meilon

          Found the solution: Due to a hang I pressed the reset button. This caused the BIOS think something with overclocking went wrong and set everything back to default. This also has set the SATA interfaces back to IDE emulation. Switching back to AHCI brought back the IAStoreDataSvc to normal and the UI also works. I could reinstall RST now. Between this BIOS reset and me detecting the problem a few days passed so I didn't made that connection.

           

          It would've been nice if the setup or the app would've told me, that there was no AHCI enabled port!