4 Replies Latest reply on Aug 4, 2011 9:12 AM by santu.chat

    Bios upgrade questions

    deangram

      Hello,

           I was getting Windows errors after crashes suggesting the bios needed upgrading. I downloaded and installed the new bios, and now the mouse doesn't work. Will the bios recovery restore the old bios? Or is that just to recover the most recent bios that has been installed.

       

      Details, Old computer: Board is D845GVS1  Bios was : VA84510A.864.0030.P10 Upgrade Bios installed is VA84510A.864.0056.P20

      The mouse is a microsoft USB optical mouse (the light does not come on now, tried different USB ports) I didn't find the exact board in the list, the board ID I found was D845GVSR I used that download and bios install. The install worked, I figured if it was for a different CPU the install would have an error message. Windows XPpro, the rest of the computer seems to be working fine. Navigating without the mouse is very difficult though. The computer is networked and the internet connection is working. I have a separate laptop that is functional so I can write this. :-)

       

      I'd like to solve the USB mouse problem and keep the new bios, but restoring the old bios would be ok too, just to get back to functional, and ignore the upgrade. Any suggestions?

       

      Edit: I plugged in an old PS2 mouse and that works fine so the problem is just with the USB mouse.

       

      Message was edited by: deangram

        • 1. Re: Bios upgrade questions
          Doc_SilverCreek

          pretty big jump.

           

          Try booting into bios set-up and load the defaults. (make sure you know any thing you have set that is not default first)

           

          After loading defaults then set every thing back the way you need it to be,

           

          (loading defaults clears the cmos tables and if they added anything new, resets them)

           

          You may also want to enable legacy USB. 

          • 2. Re: Bios upgrade questions
            deangram

            Ok, That fixed it! Restoring defaults then putting back in all the settings I wrote down worked. I noticed that the USB page was completely blank after doing the upgrade. I checked all the settings but on that page they were gone. Should have been a clue. After restoring defaults the settings list showed up. Legacy USB was and is still enabled.

                 The systems seems to be working fine now. Thanks Doc!!

            • 3. Re: Bios upgrade questions
              santu.chat

              Hi,

               

              Even i'm experiencing the same problwm after the BIOS upgrade with the same motherboard.

               

              USB screen window has no USB information and it is blank.

               

              Need help with this. Does anyone have old BIOS, i wanna restore back to old one.

               

              I did search for the BIOS in intel.com for D845GVS1 motherboard, but no luck.

               

              Regards,

              Santu.

              • 4. Re: Bios upgrade questions
                Smiler.

                I have updated the BIOS to try & clear a RAID driver issue & something has gone horribly wrong.  I used the Intel Deployment Assistant.

                 

                I have an S5520SC & it downloaded the march 2011 BIOS.

                 

                Boot screen order has changed (was Intel Raid, then Adaptect Raid) - now reversed & it then wants to boot from LAN.  If I cancel that, the OS loads & if I can login before it locks, the resolution has changed & then it locks.  It's a mess.

                 

                What the hell do I do now?