5 Replies Latest reply on Oct 29, 2010 7:25 AM by Phrozt

    Cannot utilize N / slow / disconnects (Intel 6200, Intel WiFi Link 4965AGN, Linksys WRT150N)

    Phrozt

      Sorry for the odd title... I was trying to grab every buzz word I could for searches because I've seen a lot of these type of threads floating around the internet.  This thread was originally posted in a different forum, but I'm trying to get more visibility for it.

       

      **PLEASE READ THE WHOLE POST BEFORE COMMENTING!!!**

       

      I've gone through a gauntlet of trials among 3 different computers and multiple networks, so I'm guessing I've already tried the majority of what would be recommended out of the box.

       

      Previous research:
      - (6200 N) http://slickdeals.net/forums/showthread.php?t=2322493
      - (4965AGN) http://slickdeals.net/forums/showthread.php?sduid=325585&t=2169734

       


      ** Symptoms ******************************

       

      Affected cards:
      Intel Wireless WiFi Link 4965AGN in Vista business 32x (in a Dell 1720 Inspiron [old lappy])
      Intel Centrino Advanced-N 6200 in Windows 7 Home Prem 64x (in a Dell 1747 Studio [new lappy])

       

      On ANY NETWORK, when N is enabled, these cards operate cripplingly slow (0.5-0.7 Mb/s down on speedtest.net).  This causes extremely slow streaming (youtube, mp3s, poor bitrate when streaming movies to peripherals like xbox or ps3), and can cause disconnects/timeouts in games (League of Legends would always disconnect from pvp.net, persistent games would timeout and drop me).

       

      Unfortunately I have not cataloged the routers of all the networks I've been on, but I have played around a lot with my Linksys WRT150N.

       

      ** Temporary Solution ************************

       

      Disable N

       

      I don't like this as a solution, but it's the only thing that I've seen work.  If the router is in Mixed mode (N is enabled) and the lappy in question is in 802.11n mode, it will be crippled. If EITHER the router is in G, or 802.11n mode is disabled, it will operate great at G speeds (10 - 13 Mb/s on speedtest.net).  If the router is turned to N, the lappy will simply not connect.

       

      ALL OTHER TWEAKS have had marginal success/failure.  Nothing else effects the speed difference like taking N out of the equation.

       

      Other notes:

       

      Router:
      - PSK2 Personal/AES security
      - Beacon Interval to 75
      - Thresholds @ 2304

       

      NIC:
      - Power management - Do not allow device to turn off
      - 2.4ghz  - Auto
      - 5.2ghz - Auto
      - Ad Hoc Channel - 1
      - Ad Hoc QoS - WMM Disabled
      - Fat Channel Intolerant - Disabled
      - Mixed Mode Protection - CTS-to-self
      - Roaming Aggressiveness - medium
      - Transmit Power - Highest
      - Wireless mode - a/b/g

       

      ** Options Tried ****************************

       

      Testing
      - speedtest.net
      - Set up iperf on a working machine as server, client on the 6200 N machine to monitor network.
      - Checked packet delivery times in HttpFox
      - Monitored connections to games/media (League of Legends, Alien Swarm, Borderlands, facebook game load times, youtube downloads)
      - Monitored Link Speed - 54Mbps in G, 1-270 changing at an extremely volatile rate in N

       

      Settings:
      NIC:
      - 802.11n mode disabled (NIC) - WORKS
      - Messing w/any of the other NIC settings - Minimal/no difference unless Router is in G
      - netsh int tcp set global autoconfig=disabled
      - Updated to 13.3.0.24 64-Bit

       

      Router:
      - In G - WORKS
      - In Mixed B/G - WORKS
      - N - DOES NOT CONNECT
      - Mixed, 40mhz wide, different channels - Fails/slow unless 802.11n is disabled.
      - Mixed, 20mhz, different channels - Fails/slow unless 802.11n is disabled.
      - Mixed, auto/auto - Fails/slow unless 802.11n is disabled.
      - Mixed, Disabled wireless security - Fails/slow unless 802.11n is disabled.
      - Checked DHCP Client tables to make SURE only the one testing device was connected to the network (eliminate a/b/g crosstalk problems).
      - Updated firmware to 1.01.9 1. Updated to Draft 802.11n version 2.0.

       

      Physical:
      - Moved closer to router
      - Moved router antennae around

       

      I'm sure there are other things I've tried, but I can't remember them off the top of my head ATM.

       

      *****************************************

       

      I will keep this thread updated so that hopefully anyone who has this problem has a good, central place to come to.