13 Replies Latest reply on Jun 24, 2012 6:51 AM by vashtilinux

    ICH9R Offline Member


      I have a RAID 5 that lost a disk.  I have replaced the disk with a brand new identical disk.  On boot the Ctrl-I option shows the two old drives as "OFFLINE MEMBER" in red while the new disk is "NON-MEMBER".  Once the OS starts up (WIN7 64) Rapid Storage Technology recognizes the disks, but they are listed as Usage: Unknown with the only option being "clear and reset disk".


      How do I get the RAID 5 to start the rebuild? The included help files say the volumes are in an unexpected state with the solution being to delete the volume.  Won’t that destroy my data?


      There is more to the story (my mistakes), but I'm hoping I can tell the RST to include the two old disks and the new in a RAID 5.

        • 1. Re: ICH9R Offline Member

          Use RAID to RAID and see if you can recover your files but you will not be able to recover the array.



          If this does not see your array there is a way that can rebuild RAID info but not the partition which is enough for RAID to RAID to work with by deleting the RAID Volume from the Intel RAID boot ROM and then recreate the RAID Volume with the same strip size & size of the array you had before as it only deletes the boot info for the RAID and partition not the data if you do this.


          All the above is at your own risk.

          • 2. Re: ICH9R Offline Member

            Raid-to-raid could not find it.  I tried some other tips I found on line.  nothing worked.  lost the data, but it was my own fault.

            • 3. Re: ICH9R Offline Member

              I don't really have a solution to fixing "Offline Member", but can share my experiences.


              Purchased GA-EX58-UD3R MB December 22, 2009. I installed 3 new Western Digital hard drives when I built this system. I configured the drives as an Intel RAID5 array using the ICH10R controller. System was working fine until several days ago I did a normal shutdown. When I powered up the system the next day, the system reported that there were no defined arrays and all 3 hard drives were listed as "Offline Memeber". At this point I was worried that I had lost all of my files because none of the 4 menu options under the Intel Matrix Storage Manager screen seemed to fit my needs. Without much hope of file recovery, I CD booted into the Linux distribution called Ubuntu. Surpisingly, I was able to acces my RAID5 array and make a copy of my files to an external drive. I then warm rebooted my machine to begin the process of trying to repair/understand my Raid issues. When I rebooted my machine, my Raid array was back and all of the member drives were listed as normal and Windows 7 was able to boot without issues. I then did a normal shutdown and started the system up. Again the Raid array was missing and the drives were listed as "Offline Members". Long story short, whenever I cold boot my computer, the Raid array is missing. I must boot into Ubuntu then warm boot the machine to get my Raid array to be recognised by the Intel Matrix Storage Manager. The Manager continues to recognise the array on all subsequent warm I have since experiencing this problem found a message forum where at least one other person has experienced this same scenario.


              Intel, what are your suggestions on fixing this issue.


              Intel needs to seriously consider bringing some of the Ubuntu designers on board.


              Ubuntu 2.pngUbuntu 1.png

              • 4. Re: ICH9R Offline Member

                Intel, what are your suggestions on fixing this issue.


                Intel needs to seriously consider bringing some of the Ubuntu designers on board.

                Its not a Intel problem you really do need to understand this and because you have said that I will no doubt have to explain.


                So you got a ICH10R chip made be Intel, the RAID software made by Intel, which Matrix Storage Manager is now replaced by Rapid Storage Technology and is newer by the way and we have the RAID ROM code done by Intel but is coded into and is part of the BIOS which is done by the motherboard maker. So your thinking the problem happens in RAID ROM code for the drives to show Offline Member on a cold boot….well if thats the case I think a number of people would be having this problem don't you think? So it can be down to any number of things thats likely not down to Intel unless you can proof it and understand how you proofed it to be a problem and yes that can be hard to do and get right. So what could it be:


                How the motherboard maker implements the RAID ROM code into their BIOS code for the board is one.

                Overclocking stable or not it is a reason and if motherboard maker test their BIOS they likely do it at stock.

                Drives not spinning up in time and causes the RAID to see them as Offline Member


                Anyway here is RST likely will not fix your problem because this is happening at boot.


                • 5. Re: ICH9R Offline Member

                  Thanks PeterUK for the link. I downloaded the program and used it. Interestingly, the drives were listed as not being initialized. I initialized them, didn't fix the issue though. I tried using an old Intel program  that I was hoping would allow me to force the member disks to normal but it was for PCI based controllers. Do you know of a newer program that would run at boot up that would allow me to set the members to normal or rename the raid name and members? I guess that is my main reason for being critical previously that there is not a utility that can fix this issue. The array is perfectly healthy I believe it just suffered some type of glitch, lost the volume name, etc. Researching online gave me the impression that many people have lost valuable data due to similar reasons and there does not seem to be any avenues of correction except starting over. I think most people are led to believe that a RAID array offers a pretty high level of data recovery functionality but this seemingly small unfixable hiccup makes me reconsider using standard IDE configuration and SyncToy or the like for redundancy. No middle man in the system.


                  Thanks again for your previous response. Have a good holiday.




                  P.S. I am by no means an expert with RAID,  just thought it was worth exploring when building my new system. Have learned alot in the last few weeks though hehe.

                  • 6. Re: ICH9R Offline Member

                    Mr. PeterUK,

                    In order at your line 'number of people would having this problem' i advise you to search eg. Google w/ topic 'offline member'.
                    You will be surprised how many hits will show up with this particular problem. All kind of users, using different hardware, however
                    their all using Intel's RAID, having this problem: Their Array suddenly got vanished!

                    My non-OC system was running for over two years error free until suddenly... thus this had nothing to do with the used hardware!
                    Besides, more important issue is  how to recover from t! Imagine, many people lost very important data due this issue.
                    Therefore we love to hear the answer to this.

                    • 7. Re: ICH9R Offline Member

                      As I said its “how the motherboard maker implements the RAID ROM code into their BIOS code for the board is one” or “Drives not spinning up in time and causes the RAID to see them as Offline Member”.

                      • 8. Re: ICH9R Offline Member

                        That's fingerpointing and not very helpful at all...

                        • 9. Re: ICH9R Offline Member

                          So why don't I have any of these problems with my two RAID 5 arrays?


                          Theirs also bad cables and PSU with Staggered spin-up support that could cause these problems.

                          • 10. Re: ICH9R Offline Member

                            Got the same problem 5 minutes ago...


                            one disk was reporting an error. looked into rst and saw "clear and reset disk" - so i clicked on it.... no reaction. so i thought i'd start my second system to check if its a problem with the system. during startup i saw the message of the raid manager, that all my raid disks are "offline member" in the system now at every hdd stands "clear and reset disk"


                            raid 2 raid, doesn't even recognise my hdds that are connected to the raid.


                            so similar problem.


                            gotta say that the raid was running now roundabout one year without an problem. got 5 drives in a raid 5.


                            so similar problem.... any ideas? and what can happen, if i click on clear and reset disk? <- i know it erases the metadata, but shall i click on it, at every disk?








                            raid 5 with 5 hdds, system on a separate hdd connected to the ich10


                            mb: asus rampage 2 extreme.


                            Os: Win 7 64 bit

                            • 11. Re: ICH9R Offline Member

                              I have seen this issue before on one of my systems.


                              I resolved it by turning off the system.

                              Removed one disk, turned the system on and then entered the RAID OROM.

                              If the volume didn't show up (with a Degraded state) then I shutdown the system, put the disk back and tried removing a different disk.

                              I continued this until I found the offending disk. 


                              Then I attached the offending disk by itself and "Reset disk to non-RAID" in the RAID OROM.


                              Then I attached all the disks back together again and entered the RAID OROM.


                              At this point the RAID OROM had a pop-up window that said the disk can be used to rebuild to, so I selected it and the volume went into a Rebuilding state.


                              That seemed to work for me.  However, I do not know how it ever got into this state.

                              • 12. Re: ICH9R Offline Member

                                hey man thx, after making images of every hdd, i disconnected the disk that was originally making problems. after that i set the disk with the RST to normal mode with "clear and reset disk". the disk was then set as spare and now voila. raid is rebuilding.




                                thx for the advice.




                                it is strange that false metadata on one disk can compromise the whole raid...

                                • 13. Re: ICH9R Offline Member

                                  Thx taraan (and millersh) !   Your advice was spot on!


                                  Lost my Raid 1 array due to a bad Seagate 1TB hdd.  Didn't have much luck with the Storage Manager options, in-fact it made it worse by marking both disks as 'offline members'.

                                  Ended up doing what you said and powering up the server with each hdd separately. This got the good hdd online/degraded.     After making an hdd image bkp (thx for the tip!) I reverted it to a non-raid.  After much intrepidation the conversion was successful..... and I can now boot !! :-D


                                  Thanks guys for posting !!!