9 Replies Latest reply on Dec 14, 2010 4:51 AM by

    DP45SG Gives blank screen after successful POST

    Tormad

      Hey Everyone. Ive had this system for almost 2 years now and Ive run into a big problem, Ive posted on several forums but so far I havent found a solution so here I am. Here are my system specs:

       

      Intel DP45SG mobo
      Core 2 Quad 9300
      8gb Corsair XMS DDR3 1333
      EVGA GeForce 260 GTX
      Intel 80gb SSD
      500gb Seagate Sata HD
      850w PC Power and Cooling PSU
      Windows 7 Ultimate

       

      And here is my  problem:

       

      This system has run great since I built it in January 09. I bought an SSD in January of this year which made it run even more ridiculously fast. I had no issues adding the SSD and I dont even think I've had any errors (other than your occasional software crash) in a long long time. However, from the day I built the system I never could get the memory to run at 1333, it always defaulted to 1066. Manually setting the memory timings and speed resulted in bluescreen so I just left it at default all this time. A few days ago, I was updating my onboard sound drivers when I noticed that there had been several bios updates for the motherboard since I got it. After reading through the updates, it showed that some memory issues had been resolved, so I decided to update the bios. I've done bios updates before so I wasnt expecting to run into trouble. I did the bios update using the ISO onto a CD, I used the latest bios which was version 125. The bios updated successfuly and I confirmed it had been updated in the bios menu.

       

      After updating the bios and confirming, I rebooted and thats when what im going to call World War 3 began. The PC turned on, POSTed fine, beeps once (just like it always has after post completes) then immediately went to a blank screen with a flashing keyboard cursor. I let it sit for a while and then decided that it had hung long enough, so I rebooted. Same thing happened again. I double checked all my bios settings, everything was correct. The Bios recognized my drives, the event log had no errors, etc.

       

      After trying to get into it several times, I decided I better backup whats on my drives that I need cuz I was going to reinstall windows. I backed everything up on the PC using some boot software I have, everything went fine. Got all the files I needed off of it. Then I reinstalled windows. Booted from my windows disc just fine, went through the full install, pc restarted. Post, then it went into the windows setup running from the hard drive. Everything there went fine too, set my username, configured, etc. Computer restarts, posts and then back to the blank screen with the blinking cursor.

       

      So here I am 3  days later, I've tried 4 different bios, Ive reset the CMOS 3 times,  Ive unplugged every device from the PC, I've tried just 1 hard drive,  Ive tried another hard drive. Ive tried every which way to boot by  selecting the drive manually, swaping sata ports, disabling all the  onboard devices (lan, sound, esata, etc). None of this has worked.

       

      At  one point I actually did get into windows, but only once and it was  extremely weird the way that it happened. After installing windows to  one of the hard drives, and getting the same result, I hooked up another  hard drive and installed windows to it. After the initial setup of  windows, after rebooted and after post, I got a windows boot screen that  asked which installed windows I wanted to boot to. I chose the one I  had previously installed on the other hard drive and it actually booted  up fully into windows with no problems. Thinking it was a fluke, I  decided not to start reinstalling all my software and I restarted the PC  to make sure. Sure enough, blank screen with blinking cursor again.

       

      Currently, I've been unsuccessful. I've repaired many computers, I even worked in a shop for several years and never came upon anything like this, although hardware was never my specialty. A friend of mine who is still in computer repair says that maybe the BIOS i originally updated to might have had a firmware update for the sata controller and it may have corrupted somehow or is incompatible, and is causing it to not give over control to the windows install. He thinks this because even though the setup loads multiple times, its different than when windows actually loads because it uses a different kind of boot to ensure that the setup runs on the next boot, after installing windows. Which I can see the logic there.

       

      The other thing is, I am not able to go back to the original bios this board came with, which is version 088. Its not available on the intel website and I cant find it on the web either. The closest one I could go to that was after my original was 093, and that one I couldnt get the dvd drive to load a disc, it kept giving an error that no disc was present.

       

      Does anyone have any idea on something I can try to fix this? I am desperate to get this thing working again. This is my main PC that I do all of my gaming and everything else on. Im currently posting from my other system that's just an older PC I use as a file host.

       

      If anyone out there can help, please dont hesitate!

        • 1. Re: DP45SG Gives blank screen after successful POST
          craley1

          Tormad, I'd like to share my experience with this mobo as well. I am extremely surprised to see that someone is having an exact same problem as I am and trying to rectify it around the same time. I usually see posts from months/years ago (sidebar, sorry).

           

          I am on my second DP45SG. My first one: I disabled the USB in BIOS (in an attempt do something else) like an idiot. I didn't realize that at that time that there was only USB inputs for keyboard and mouse so now I couldn't use a USB keyboard or mouse in Windows and couldn't get back into BIOS with my USB keyboard. Smooth move, ex-lax. I tried clearing CMOS by pulling the battery. I tried updating/resetting BIOS to no avail. The solution was that Intel sent me a new mobo. Problem solved.

           

          So for this one (my second), I have done exactly what you did. I updated BIOS to 0125. Blinking cursor, no boot. I am currently trying to reinstall Windows but if this doesn't work, I will be ordering a new NON-INTEL mobo and installing that. In my opinion, there is something fundamentally wrong with the motherboard and the BIOS and Intel doesn't care to fix it. Playing devil's advocate, I am surprised that there wasn't some type of recall or notice if this type of problem keeps happening.

           

          The morale of my story is that the solution to this problem appears to be get a new motherboard, I'm sorry to say. I realize this isn't a solution but I thought I would share this with you.

           

          Edit: Also, not sure if you've noticed, but the startup beeps are different. If I remember correctly, there used to be a short beep followed by a longer beep. Now, all I get is a short beep followed by an identical short beep. Are you getting the same?

          • 2. Re: DP45SG Gives blank screen after successful POST
            Tormad

            I actually solved my problem yesterday.

             

            The issue is that the bios update caused the boot sectors on both hard drives to become corrupt. And the fix was pretty simple, I got to a command prompt and did "bootrec.exe /fixboot".

             

            Im now back up and running again. You should try it as well.

            • 3. Re: DP45SG Gives blank screen after successful POST
              craley1

              Crap dog. If only you had posted it earlier. I already ordered another mobo. Maybe that will be the first piece of my next system.

               

              Can you give me some direction on how to get to a command prompt?

              • 4. Re: DP45SG Gives blank screen after successful POST
                Tormad

                You need to boot into either windows recovery/repair or find some sort of bootable disc that will get you into a command prompt. If you are running windows vista or 7, its easier. Xp, not so much I think.

                • 5. Re: DP45SG Gives blank screen after successful POST
                  topgeardo

                  I have the same MOBO and the same problems with memory frequency. The modules I have are supposed to run 1333 but I have to leave them run in default 1066 few times It boot on 1333 its a problematic MOBO. I just downloaded 125 BIOS but I decided to search the web before Installing it, and I came across your problems, though I see you solve it, I have to ask you a CRUCIAL question, the windows you have boot might be activated by side means? I had the same problems on a Intel DG45ID when "activating" windows vista, so I bought this, and stored the DG45ID.

                  • 6. Re: DP45SG Gives blank screen after successful POST
                    Tormad

                    Well the windows 7 I have is a full version, however, it is not a retail version. Its a "Not For Resale" I got with the motherboard/cpu combo I bought directly through intel.

                    • 7. Re: DP45SG Gives blank screen after successful POST
                      topgeardo

                      Thanks for the answer.

                      I have Dual channel OCZ memories 4gb and I have the problem that it doesnt work in 1333Mhz only on default settings 1066. Does the BIOS upgrade solved the issue with your memories?. (8gb Corsair XMS DDR3 1333)

                      • 8. Re: DP45SG Gives blank screen after successful POST

                        Hey hows it going? i see there is a lot of issue with this board (dp45sg) rebooting on it's own and not booting at all.i bought this board about 2 years ago and suddenly as of 12/8/2010 it keeps freezing and rebooting on it's own.

                        my specs are :

                        intel dp45sg motherboard

                        core 2 extreme q9650 cpu running 3ghz with 1333 fsb

                        corsair xms3 ddr3 running 1333mhz 9-9-9-24 timing

                        corsair p128 ssd

                        his 4890 oc edition 900/1000

                        silverstone 1000w power supply

                        antec 1200 case

                        zalman 9700nt cpu cooler

                        antec side fan for the vga cooling

                        antec inside case fan for ram cooling

                         

                        my system never runs over 28c and thats cool as hell but like i said after 2 years all of a sudden it keeps rebooting and there is a lot of discussion on intel about this board.your memory is not getting 1333mhz due to the timing of the ram bacause i had the same problem when i used the ocz 1333mhx with the 7-7-7-24 i keep getting 1066 mhz which made me very frustrated so try a different ram with the 9-9-9-24 timing..this board is very sensitive so be patient..as for me today i am going to use a different cpu q9400 to boot my system and hope its not my cpu and it's the motherboard problem so i can get my warranty for another board..to be honest i went thru alot with this board and it will be my last intel board..good luck

                        • 9. Re: DP45SG Gives blank screen after successful POST

                          Hi, yes indeed this MOBO is a pain, but as I´m going to build a new RIG I dont care anymore, and I also will never buy a INTEL Board againg, not after all the problems I´ve run Into with this.