1 2 Previous Next 17 Replies Latest reply on Mar 14, 2011 3:36 PM by Curious592

    DX58SO boot problem

    galbicka

      Wondering if anyone can help me make sense of this problem before I restore from a good full cloned disk (bootable) with Acronis TIH 11. I am running Vista Home Premium X64 in a raid 1 mirror configuration using the onboard raid of this mobo which is running version 5200 BIOS. Absolutely nothing important has changed on the system since my last backup on 9/4/10 before I went on a two week vacation. Returned last week and only used the machine to watch TV and movie content via Boxee during the week. Today I decided to run another full clone then perhaps consider doing an upgrade to Windows 7 Ultimate or Pro. I followed my normal procedure. I did a full shut down including a power off. Then I booted back into Vista as normal and waited for everything to load and calm down. I always do this to make sure my clone is of a clean boot. I inserted my TIH boot cd and did a restart and booted from the cd into TIH. When I got to the select source disk screen I noticed it showed 3 scsi drives instead of 1 scsi and 1 raid mirror as it normally does. I decided to exit TIH and boot back into Vista and it hung with a black screen which told me that it could not boot as there was a  problem associated with the "File \ Boot \ BCD" and reveals a  staus of 0xc000000e.   Post  reveals my raid array is in order with both drives showing a normal status.  This same  screen suggested that I insert my Vista Installation disk to boot from  and after entering the language options to then press "Next" and select  "Repair" - I did this but the repair section did not reveal any OS’s to  repair - probably because of the raid array. I booted from my external scsi clone and the Intel software shows the array intact with no errors. I examined the \Boot folder on the array drive and found the BCD file renamed BCD.backup.0001. I tried replacing it and the bcd.log file from my backup but still get the same error when trying to boot from the raid array. I decided to do some research before tackling the problem and started with this post. If you have seen this behavior before with Intel onboard raid I would be interested in your feedback.

        • 1. Re: DX58SO boot problem
          Curious592

          You may have a problem with your TV tuner installation.  I'm not familiar with Boxee but from what I've seen of Win 7, I'm not eager to use RAID and TV together.  Monitor your system reserved partition for sure to see where it is.  I've had good luck with system backup in Vista, provided the image is of a good partition.

          • 2. Re: DX58SO boot problem
            galbicka

            No TV tuner installed. Video is 2 X HD4850 in Crossfire mode. All content I watch through Boxee is internet streamed.

            • 3. Re: DX58SO boot problem
              Curious592

              Then the TV might only affect your ability to Sleep the computer.  I can only use hibernate with a TV tuner, which is fine with fast Vista or Win7.

              • 4. Re: DX58SO boot problem
                galbicka

                Thanks for your replies Curious592 but they really don't answer any of the questions that come to my mind concerning the issue. Also after reading my original post I want to point out that where I mentioned "scsi" it should have been "sata". Must have been brain dead - scsi is not used in this system. My specific questions would be:

                 

                1) What caused the problem? There were no changes, no improper shutdowns, no surges, no nothing. No reason for any file corruption whatsoever so no reason to suspect Windows as the culprit.

                 

                2) Could the onboard raid be the cause? If so why does all status appear normal in Post and Intel software?

                 

                3) Is onboard Intel raid a solid solution to rely on for real time data protection from hard drive failure? Some googling might lead one to believe it isn't.

                • 5. Re: DX58SO boot problem
                  galbicka

                  Disappointed to not get any feedback to my questions but I understand it might not be a common problem. I am going to first see if the Vista recovery environment tools could help fix it but I have to figure out how to get the raid drivers loaded. Driver downloads for the board link to this:

                  http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=15251&lang=eng

                  I assume I need to download the driver STOR_allOS_9.6.0.1014_PV.exe and STOR_all64_f6flpy_9.6.0.1014_PV.zip F6 driver diskette for Windows Vista (64-bit editions) and extract them and burn to a CD then load them in the PE environment. Anything else?

                  • 6. Re: DX58SO boot problem
                    galbicka

                    I burned the F6 drivers to a cd but still couldn't get the PE environment to recognize them. After browsing to and choosing iastor I got an error that there was no information for the device there. That was all the time I really wanted to spend trying to figure out if I could fix the problem manually. I deleted the raid 1 volume and then recreated it in the boot console then booted into Vista with my external backup drive and let the Intel Matrix Storage Manager software initialize the array completely. Then I booted from my TIH cd and cloned my backup to the array and was back in business in about 20 minutes. I will update to the latest RST version now and just wait and see if the problem occurs again. If it does I will probably go to a full hardware raid solution.

                    • 7. Re: DX58SO boot problem
                      galbicka

                      Just had a thought. I tried using the latest F6 drivers in the Vista PE environment without luck but my array was configured with much older drivers. Could that be why they didn't work? Not completely backward compatible?

                      • 8. Re: DX58SO boot problem
                        Curious592

                        My two cents worth.  I backup an image to one drive and backup files to another, then disable them.  That is as green as it gets.  Minimal voltage to disabled drives but they should survive a system crash that corrupts boot drive.  It sounds like your boot drive is the external one, perhaps that would be fixed by new drivers but I know little about PXE.  If you do not record from the Boxee then I don't see a conflict now.  Would not recommend changing connections however.

                        • 9. Re: DX58SO boot problem
                          galbicka

                          Actually the internal raid 1 array is my normal boot drive. I have been booting from my external e-sata docked clone drive while trying to fix the array. My backup procedure is to boot from Acronis TIH 11 boot CD and do a full clone of the array to two different sata drives in the external e-sata dock and then take one drive offsite and leave one onsite.

                          • 10. Re: DX58SO boot problem
                            Curious592

                            That's clearer.  So the RAID can't be fixed in Safe Mode?  Setting BIOS to default or removing CMOS battery, then restoring settings doesn't seem viable to restore detection when using RAID.  Win 7 handles failures a little differently from what I've seen, unless I haven't been paying enough attention to Disk Management.

                            • 11. Re: DX58SO boot problem
                              galbicka

                              How would you fix it in Safe Mode? As far as the Matrix Storage Management software was concerned the array status was fine and the raid boot console showed it fine as well. But Acronis showed it broken and Vista wouldn't boot from it with \Boot\BCD errors.

                              • 12. Re: DX58SO boot problem
                                Curious592

                                Safe Mode for me is mostly confirmation of device detection before all drivers are installed.  I believe BCDEdit and another tool are for such repairs.

                                • 13. Re: DX58SO boot problem
                                  galbicka

                                  My thought about the F6 drivers didn't prove out. After restoring from clone to a new array and installing the latest version of rst I rebooted from the Vista CD into the PE environment and it found the vista install on the array fine without loading any drivers so the only reason it didn't see it before was due to the bcd problem and not raid driver problems. I also noted that the rst upgrade doesn't upgrade the raid option rom version which I guess only gets upgraded through firmware upgrades.

                                  • 14. Re: DX58SO boot problem
                                    Curious592

                                    A BIOS update would accomadate new drivers described in the new INF.  The Windows updates would provide any new drivers for the controller.  So you're right that firmware update would be required for a substantive change in hardware.  I'm not clear on the software raid issue yet since I've only used AHCI.  Intel recommends RAID setup for AHCI to avoid having to reinstall if switching to RAID from AHCI.

                                    1 2 Previous Next