6 Replies Latest reply: Oct 3, 2010 10:24 PM by judgej RSS

SASUC8I: Setting up RAID 1 with existing drives

judgej Community Member
Currently Being Moderated

I have installed a SASUC8I card in a small server as a replacement for some cheap RAID card that was starting to fail. I have two problems - one appears software related and one I simply cannot see for looking in the documentation.

 

Firstly the RAID monitoring and setup utlility software does not let me log in. It recognises the RAID card on the local machine, and prompts for a name and password when I try to select "full control". When I enter the name and password for a Windows (XP) admininistrator, the software tells me that the user is not an administrator and so will not give me access. That kind of scuppers setting up any RAID on the machine. I don't know what the utility is called ("ir3_Windows_RWC2_v6.90-04.zip" is the download name). The drivers and software all seemed to install okay, but I just cannot lot into it.

 

Secondly, I cannot see in the documentation whether it is possible to set up RAID 1 or 1E on the existing drive, bringing in a second disk, without formatting that drive. The documentation implies that an "initialisation" is required, and after muchg digging it seems that "initialisation" is another word for "format". Is that correct? I have a SATA drive on channel 0 that is the main disk, and another on channel 1 that I would like to mirror the first disk.

 

Thanks,

 

-- Jason

  • 1. Re: SASUC8I: Setting up RAID 1 with existing drives
    judgej Community Member
    Currently Being Moderated

    The software is "RAID Web Console 2". I simply cannot log in with "Full Access" - it tells me "this user does not have administrator right for this system". The user *does* have admin privileges.

     

    I am running this software on the same server as the RAID card, running under XP Pro SP3. I have tried users with and without passwords, as well as tried loging in using "username" and "machine/username". Both give the same error. This is before I even work out how to set up RAID1 or 1E using the existing disk. At the moment both drives are seen as independant drives (I have removed the drive letter from the second drive so it does not get mounted).

  • 2. Re: SASUC8I: Setting up RAID 1 with existing drives
    edwardzh Community Member
    Currently Being Moderated

    I believe you'll first need to create an IM volume using the LSI MPT* SAS BIOS Configuration Utility by pressing Ctrl-C during POST. For more details, see the Intel® IT/IR RAID software user's guide, page 11~13: "Creating IM and IME Volumes". Note in step 6:

     

    Press <M> to keep the existing data on the first disk or press <D> to overwrite it.

    If you keep the existing data, this is called a data migration. The first disk will be

    mirrored onto the second disk, so any data you want to keep must be on the first

    disk selected for the volume. Data on the second disk is overwritten. The first disk

    must have 512 KB available for metadata after the last partition.

     

    I highly recommend you backup all your data before the data migration.

  • 3. Re: SASUC8I: Setting up RAID 1 with existing drives
    judgej Community Member
    Currently Being Moderated

    Thank you - that is exactly what I wanted to hear. The main disk has a spare partition on the end, so will be easy enough to delete and recreate as a smaller size to leave room for the metadata.

     

    Backup the disk first? Sure! With destruction of the disk only a key press away, and assuming the hard drive SATA cables have been numbered correctly, it is not possible to be too safe.

     

    On the question of logging in to the monitoring software, is that an easy one to solve too? Would it be better to raise that as a separate question and close this one, since your answer is exactly what I needed.

     

    -- Jason

  • 4. Re: SASUC8I: Setting up RAID 1 with existing drives
    edwardzh Community Member
    Currently Being Moderated

    As for the RWC2, I haven't seen this login issue before - can you try to launch it by right click it, choose "Run as..." and select an administrator account?

  • 5. Re: SASUC8I: Setting up RAID 1 with existing drives
    judgej Community Member
    Currently Being Moderated

    Trying "Run As" did not directly solve the problem, but it did highlight what the problem was: Windows hidden accounts.

     

    The administrator user I log in as was called "recep". Looking deeper I realised that this user was actually "admin" with a different front-end name. To add to this and throw me further, the test user I set up (that did not work) was called "admin". I didn't realise that Windows actually created this user as "admin_2" behind the scenes.

     

    If I try loggining into the RAID Monitor as "admin_2" then it all works :-)

     

    Is is strange how even after using Windows for half my life (yeah, since version 2) there are still things that surprise me.

     

    I'll be following the other instructions for setting up RAID1 this afternoon, after a good backup, naturally.

     

    -- Jason

  • 6. Re: SASUC8I: Setting up RAID 1 with existing drives
    judgej Community Member
    Currently Being Moderated

    Thank you all for your help. My RAID1 is up and running and synchronising nicely. When that is complete I'll add in a hot standby (with the feature the leave it spun down until needed - very nice).

     

    I can't seem to get the email alerts to work (telling me the SMTP settings are not correct, when I am sure they are), but I'll leave this for another thread.

     

    Jason

More Like This

  • Retrieving data ...