8 Replies Latest reply on Sep 27, 2010 3:13 AM by mini

    IPMI v2.0 on intel S5000PAL

    mini

      Hi all,

       

      I'm working on a monitoring system of a few servers in the company. Now i got some intel servers (S5000PAL series) with RMM2 module on it. And i searched and saw that i can use ipmitool (IPMI) for monitoring some sensors. ( I used the tool before on other servers and is works great, and i made my own script and want to use that one also for the intel servers). So this was a bit a summary what i want to do.

       

      Now i was reading some pdf of the RMM2 module and saw that you have a IPMI tab on the RMM2 web interface. so i set the IPMI configurations like in the pdf. Now if i use the ipmitool command i get some errors, i searched a while for it but not quitley find a solution that works.

       

      Command i send:

      $ ipmitool -I lanplus -o intelplus -H 10.10.10.231 -U "admin" -P "password" sensor

      > ERROR: Unable to establish IPMI v2 / RMCP+ session (*)

      > Get Device ID command failed

      > Unable to open SDR for reading

       

       

      (*) for this error  i found on https://twiki.cern.ch/twiki/bin/view/FIOgroup/IpmiPrb the solution of -o intelplus ( but it seems it does not work because i still get the error)

       

       

      Command i send:

      $ ipmitool -I lan -o intelplus -H 10.10.10.231 -U "admin" -P "password" sensor

      > ERROR: Unable to establish LAN session

      > Get Device ID command failed

      > Unable to open SDR for reading

       

       

      So i did a ipmiping to the server and get a Time out.

       

       

      I've been looking further and i was looking wich ports are open on the intel RMM2 module and is only saw the telnet en ssh port, NOT 623 , this is the port that ipmi uses not?

       

      So i've been looking for a while for solutions but never solved the problem.

       

      If anyone can help me of give some more info over IPMI on RMM2 it would be great!!

       

      Regard mini

        • 1. Re: IPMI v2.0 on intel S5000PAL
          edwardzh

          You'll need to enable the BMC account and RMM2 LAN channel first. For more details, please see the following document, section 2.2.9:

           

          http://www.intel.com/support/motherboards/server/sb/CS-030462.htm

          • 2. Re: IPMI v2.0 on intel S5000PAL
            mini

            I readed that pdf before and i saw that chapter to. But I have a great ? with the syscfg tool?

             

            I don't know it , and don't now how you can add those commands.

             

            I read you can start it in dos mode but that all, i can be wrong but it's new for me.

             

            But otherwise beside de syscf commands everything is done (IPMI settings)

            • 3. Re: IPMI v2.0 on intel S5000PAL
              Jason Tan

              Would this guide help ? http://www.intel.com/support/motherboards/server/sb/CS-022714.htm , Syscfg User Guide

              1 of 1 people found this helpful
              • 4. Re: IPMI v2.0 on intel S5000PAL
                edwardzh
                1 of 1 people found this helpful
                • 5. Re: IPMI v2.0 on intel S5000PAL
                  mini

                  Oké

                   

                  Thank you both for the link.  I'm going to try it now, i give a feedback if it's complete.

                  • 6. Re: IPMI v2.0 on intel S5000PAL
                    mini
                    Oké i tested it and seems it did not work for me.

                     

                    I followed the steps from the pdf you added here in the topic:

                     

                    > syscfg /u 3 admin password      # configure user 3’s user name and password
                    > syscfg /ue 3 enable 3           # enable user 3 on LAN channel 3
                    > syscfg /up 3 3 admin            # assign user 3 with admin privilege on LAN channel 3
                    > syscfg /c 3 7 always            # configure LAN channel 3 access mode to “Always”

                     

                    I give some details of the BCM that i configured.

                     

                     

                    C:\syscfg\SysCfgRelease>syscfg /d channel 3
                    Channel Configuration Settings
                    -------------------------------
                    Channel Selected: 3
                    Channel Type: LAN
                    Features Supported: Basic Lan & SMTP

                    Authentication Types:
                    ----------------------
                    Callback: [Not Configured]
                    User: [Not Configured]
                    Operator: [Not Configured]
                    Administrator: None MD5 Straight

                    Per Message Authentication: Enabled
                    User Level Authentication: Enabled
                    Access Mode: Always
                    Privilege Level: Admin
                    PEF status: Disabled

                    C:\syscfg\SysCfgRelease>syscfg /d lan 3
                    LAN Configuration Settings:
                    ----------------------------
                    LAN Channel Selected: 3
                    LAN Alert Destination Index Selected: None. LAN Alert Configuration will not be
                    displayed.

                    IP Address Source: Static
                    BMC Host IP Address: 10.10.10.232
                    Subnet Mask: 255.255.255.0
                    Gateway IP Address: 10.10.10.1
                    Gateway MAC Address: 00-00-00-00-00-00
                    Backup Gateway IP Address: 0.0.0.0
                    Backup Gateway MAC Address: 00-00-00-00-00-00
                    Community String:
                    Gratuitous ARP Enable: Disabled
                    Gratuitous ARP Interval (milliseconds): 2000
                    BMC ARP Response Enable: Disabled

                    C:\syscfg\SysCfgRelease>syscfg /d user 3 3
                    User Configuration Settings:
                    -----------------------------
                    User ID Selected: 3
                    Channel Selected: 3

                    User Name: admin
                    User Status: Enabled
                    Privilege Level Limit: Admin

                    SOL Enable: Enabled

                     

                     

                    So it seems oké not? or did i missed something?

                     

                    After this i tested a few things.

                    If i use ipmiutil local, i wil get the sensor list, what is normal i think

                     

                    If i remote test ipmitool i still got the same errors as in the first post also with the ipmiping i get a time out, but with normal ping i get replies.

                     

                    Strange things going on here. I don't got an explanation for it.

                     

                    So i try a lot, but still no succes.

                     

                    Thank you for the replies anyway.

                     

                    Greets

                    • 7. Re: IPMI v2.0 on intel S5000PAL
                      mini

                      oké guys, it works.

                       

                      After 10 - 15 minutes it showed me the sensors i wanted.

                      I think I need to be more patient with reseting a server before I see some effects .

                       

                      So i will thank you guys for the advice and the link for the syscfg download!!!!

                      • 8. Re: IPMI v2.0 on intel S5000PAL
                        mini

                        I'm back with some problems.

                         

                        Before the weekend everything was working fine, even my script worked and i could monitor the sensors.

                        After the weekend my monitoring failed, i looked to my script but nothing is wrong so i've been looking to the system health in the RMM 2 webinterface.

                         

                        And there it was: no sensors found.

                        So i went looking at the IPMI device settings and i get this error:

                        Error: Failed to query IPMI Channel 3 Forwarding Parameters.


                        So  there is something wrong with the BMC module.

                        I did some syscfg /d command but didn't get information. First i get this error:

                        an error occurred while getting SOL configurations from the system

                        then i get an error that he doesn't know /u or /d channel 3 and so on.

                        After this i downloaded the kiratool and did a test ( test ipmb all)
                        >ipmb bmc: failed

                        Another test: ipmiutil cmd 00 20 18 01
                        >icmd Unspecified error

                        So my conclusion is that the BMC doesn't react anymore, i don't know why or how.

                        I can see that you can reset it with kiratool. I didn't do this now because i don't know if it remember all my setting like IP and login password and username and other settings.

                         

                        But i don't know any other solutions to get back my ipmi information. No reaction on reset from the webinterface, no reaction on the syscfg tool.

                         

                        Any one has this problem before?

                         

                        greetings