4 Replies Latest reply: Sep 16, 2010 6:14 AM by lightmgl RSS

800 GB jump in host writes overnight?

lightmgl Community Member
Currently Being Moderated

I just recently made the plunge into the SSD world and purchased an X25-M drive to run my OS and applications of off. I've heard all the stuff about media wearout and how much data the drives can take but I thought I would keep an eye on my usage just to see how many writes I was actually making to the drive. The drive is about 10 days old and everything was working great, all the necessary things in the OS were set to keep as much large data off the drive as possible and I loaded the drive up with everything I planned on putting on it.

 

Now it seems that overnight my Host Writes figure has jumped 800 gigabytes, 10 times the size of the drive, and I have no idea why. If it keeps happening this is will wear the drive out incredibly quickly and I can't possibly imagine what would cause such a drastic jump in writes when I was below 20 gb/day before and that was while I was still putting programs on the drive. Is there anyone who has any ideas as to what might have caused this so I can kill it before it starts killing my drive?

  • 1. Re: 800 GB jump in host writes overnight?
    NandFlashGuy Community Member
    Currently Being Moderated

    That sounds like very strange behavior.

     

    If the problem continues, you can investigate using some sort of monitoring software.  Maybe start with Microsoft's Process Monitor:

    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

  • 2. Re: 800 GB jump in host writes overnight?
    lightmgl Community Member
    Currently Being Moderated

    Thanks, yeah I ended up getting a private message suggesting something similar and ended up using process monitor to watch Write Bytes. The culprit ended up being Kaspersky Internet Security which no matter how much I tweaked Windows 7 and Kaspersky to put stuff on the HDD through the registry and symbolic links it still ended up doing this. Must be something sandbox related, but I was forced to remove it and replace it with Microsoft Security Essentials which has solved the problem.

     

    Its amazing how an automated overnight virus scan led to nearly a TB of writes on the drive, that sort of behavior is not cool :/. Well at least now heres a heads up to anyone using Kaspersky, be wary of how much it is writing to your SSD when it scans large files.

  • 3. Re: 800 GB jump in host writes overnight?
    Ozz Community Member
    Currently Being Moderated

    The only thing I can think of is because you have an absolute truckload of data on a non-ssd drive, either compressed or in containers. During the scan, it is unpacking to temp folders (SSD) causing the writes.

     

    Can you please elaborate on which version of Kaspersky (right down to the build # if possible) that you were using? was it a recent KIS 2010 (9.0.0.736) or KIS 2011 (11.0.1.400)?

     

    I just ran a quick test by scanning my (paltry) 290GB of data on a mechanical drive and it has gone from 1.09 to 1.11TB - so that's ~20GB of data. This to me is perfectly normal in terms of the operation of an antivirus scanning packed data but i can see this easily becoming an issue if you have lots of stuff!

  • 4. Re: 800 GB jump in host writes overnight?
    lightmgl Community Member
    Currently Being Moderated

    It is 11.0.1.400 and as far as I know there are no large amounts of compressed data on the HDDs. Just about 800 GB of my music, television, and ripped roms since alot of my older games are in storage. Its also no coincidence that the amount of writes added was pretty close to equal to the amount of data scanned that night. I did not realize it ran an auto-scan at first since I usually have them disabled but I had not yet configured Kaspersky since setting everything up on the SSD.

     

    I also noticed similar behavior when downloading large files in chrome (1gb + exes) resulting in Kaspersky adding the same amount of data in Host Writes as the file finished and it scanned. I even tried reinstalling Kaspersky both on the SSD and on the HDD and redirecting my ProgramData folder using a Symbolic Link just in case it was writing temp data there.... but the problem persisted. I'm clueless too as to why, I thought it might be doing some of it's scanning in a protected location and it seems like that might not be it. It was definitely the problem I was having though.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points