12 Replies Latest reply on Sep 16, 2010 2:05 PM by michael.riepen

    PCIe driver not found

    parlab-support

      I'm trying to follow the How to Install Ubuntu and sccKit directions, but when I try to run the SIF training using "sccBmc -i" it appears to fail to find (load?) the driver for the OSS PCIe card:

       

      > # sccBmc -i

      > INFO: Packet tracing is disabled...

      > INFO: Opened "/tmp/sccKit_root/trace.log" for writing...

      > INFO: openBMCConnection(192.168.2.127:5010): You are participant #1

      > INFO: Initializing System Interface (SCEMI setup)....

      > ERROR: initializeSysIF(): Failed to open PCIe driver device. Driver

      > devices not installed/available...

      > ERROR: Unable to connect to PCIe driver...

      >        Make sure that PCIe driver is installed and

      >        not in use by someone else... Aborting!

       

      Suggestions?

        • 1. Re: PCIe driver not found
          parlab-support

          After a "power on" on the BMC and rebooting the MCPC, I notice that the crbif driver is not loaded on the MCPC.  I tried both a plain "modprobe crbif" and a "modprobe -C modules.conf crbif" using the supplied modules.conf file that holds the following:

           

              options crbif subnetsize=1 txBasAddress=8256487424

           

          Neither seems to prevent the error, although both load the crbif driver without complaint.

          • 2. Re: PCIe driver not found
            parlab-support

            Checking /var/log/messages as per another thread shows multiplle complaints:

             

            mcedev: driver unregistered

            mcedev: Id: $ID mcedev_main. 16541 2010-06-03 07:55:03Z jbrummer

            • 3. Re: PCIe driver not found
              parlab-support

              Attempts to load mcedev result in a fatal error:

               

              # modprobe mcedev

              FATAL: Module mcedev not found.

              • 4. Re: PCIe driver not found
                tedk

                It sounds as if you have your own MCPC/Rocky Lake system. I think your problem was due to following an out-of-date instruction guide. I deleted that guide from the site. Please look at the guide called How to Set Up Your MCPC in the subcommunity Your MCPC. Do you get an error message when you issue the install.csh? Note that the latest sccKit is 1.3.0.

                 

                If things do lock up on you or start acting strangely, try powercycling. Please look at the document called How to Powercycle Rocky Lake, also in the subcommunity Your MCPC.

                1 of 1 people found this helpful
                • 5. Re: PCIe driver not found
                  parlab-support

                  I'll try the newer directions and let you know.  Thanks.

                  • 6. Re: PCIe driver not found
                    JanArneSobania

                    We have the same problem. Our current MCPC candidate does not recognize the SCC (the device does not show up in lspci's output), so sccBmc fails with the same error message you get. This is the second PC we tried the installation on; the first one seems to recognize the board, but it does not boot at all if the SCC is powered on. I'm going to collect different PC models today, hoping at least one can support the board.

                     

                    Do you see the SCC device in the BIOS' or lspci's device listing (if I remember the post in the top-level discussion forum correctly, it is an "Intel memory controller" with a device ID of c148)? If not, you are having a problem with your PCIe connection or BIOS/mainboard. If it does show up, your driver installation may be faulty.

                     

                    By the way: did you place the PCIe card into a PEG slot (PCIe-x16, as usually used for graphics cards) or into a regular x4 one? It seems some BIOSes do not support anything but graphics cards in a PEG slot; they will either act strangely, or fail to recognize the card at all. If you can, try to use the card in another slot, preferrably an x4 one as x8 may present other problems for x4 devices.

                    • 7. Re: PCIe driver not found
                      tedk

                      We'll look into this issue in more detail ... but I did a lspci -vvv on one of our working systems and attached its output.

                      • 8. Re: PCIe driver not found
                        parlab-support

                        I do get an error message when running ./install.csh:

                         

                        # ./install.csh
                        Sending reset to FPGA & SCC...
                        No driver loaded...
                        Installing driver package using dkms...
                        (Reading database ... 168547 files and directories currently installed.)
                        Preparing to replace crbif-dkms 1.1.0-0ubuntu1~ppa1l (using .../crbif-dkms_1.1.0.deb) ...
                        Unpacking replacement crbif-dkms ...
                        Removing old module source...
                        Setting up crbif-dkms (1.1.0-0ubuntu1~ppa1l) ...
                        Loading new crbif-dkms-1.1.0 DKMS files...

                         

                        Error! Could not find module source directory.
                        Directory: /usr/src/crbif-dkms-1.1.0 does not exist.
                        dpkg: error processing crbif-dkms (--install):
                        subprocess installed post-installation script returned error exit status 2
                        Processing triggers for man-db ...
                        Errors were encountered while processing:
                        crbif-dkms
                        Driver is installed and will be loaded during reboot...

                         

                        ...

                        • 9. Re: PCIe driver not found
                          parlab-support

                          If I run dpkg directly I can seemingly configure the kernel module:

                           

                          dpkg --configure crbif-dkms

                          • 10. Re: PCIe driver not found
                            parlab-support

                            However when I reboot, the crbif driver is not loaded.  Running sccPowercycle loads it, but then running `sccBmc -i` still throws the same error.

                            • 11. Re: PCIe driver not found
                              michael.riepen

                              It seems that the first attempt of the driver installation failed for some reasons. From that moment in time, future attempts of driver installation will fail until you uninstall the fragments of the first try. To do so, please type:

                              sudo apt-get remove crbif-dkms

                              Then re-try to install the dkms driver package... Please let us know if this worked out. Thanks!

                              • 12. Re: PCIe driver not found
                                parlab-support

                                It helped the ./install.csh procedure to run without errors and build the driver.  After rebuilding the driver, reseating the connectors, rebooting both systems, and making the appropriate prayers, signs, and incantations... it now works.

                                 

                                Thanks ever so much.