4 Replies Latest reply on Sep 14, 2010 8:35 AM by Drithius

    Current Firmware Version for X-25m?

    Drithius

      Hi,

       

      I got a batch of Event ID: 11 Windows errors the other night (The driver detected a controller error on \Device\Ide\IdePort0) and am trying to determine whether or not I have the latest firmware revision for the x-25m SSD.  As shown by the Toolbox, my current firmware and drive model are: Firmware Version, 2CV102HD, Model Number, INTEL SSDSA2M080G2GC.

       

      I have been hesitant to run the Firmware update tool because this is my boot drive and it's set for AHCI. I am unsure whether a (temporary) change to IDE and the subsequent firmware update would cause issues with Windows,,,?

        • 1. Re: Current Firmware Version for X-25m?
          Ozz

          Your firmware is current. Are you saying you did run the firmware update tool?

           

          The change from AHCI to IDE then back to AHCI for the firmware upgrade isn't technically an issue provided you didn't try to boot into windows whilst it was set to IDE.

           

          as to the errors, which Windows version, and subsequent storage drivers are you using?

          • 2. Re: Current Firmware Version for X-25m?
            Drithius

            Hey there, thank you for the response.  I did not run the update tool - I was leery of doing so with my OS (Windows 7 x64) already installed on the drive.

             

            I have an Asus AMD board with the sb750 chipset and have download and installed every Catalyst driver I can.  Oddly though, although the southbridge/northbridge driver was explicit in its install, the AHCI and RAID drivers were not listed as an option for installation when I ran the respective Catalyst packages.

             

            I have a suspicion this may be tied to me using both IDE and AHCI within the BIOS.  I have both loaded because my old Raptor gets intermittent pauses if I run it in AHCI.

            • 3. Re: Current Firmware Version for X-25m?
              Ozz

              The firmware update is implemented without destroying any user data,  however, there's no guarantees so they recommend that you back up  before updating. That said, youv'e got the latest so there's no need to worry.

               

              Ah, sb750. Unfortunately I have no experience with SSDs and AMD chipsets so I can't offer any real advice. Do you mean you have two controllers on that board? i.e. one running IDE (raptor attached) and one in ACHI (the sb750) with the SSD?

               

              About the catalysts, I'm not sure as I've only had to run it once before - i remember the AHCI/RAID drivers were in a totally different package (or is this what you had tried running/were referring to?). So at the moment, you're running the Microsoft AHCI driver?

               

              Basically the original error message you posted is typical of a cable or driver error. Given your config, I'd probably lean towards the latter.

               

              How are read/write speeds? have you benchmarked at all? Perhaps post a screenshot of AS SSD (http://www.alex-is.de/PHP/fusion/downloads.php?cat_id=4) which you can compare to others (also it will show your driver used). If speeds are good, and you're not gettings any other symptoms, it may be  something to keep in mind rather than something to actually fix.

              1 of 1 people found this helpful
              • 4. Re: Current Firmware Version for X-25m?
                Drithius

                My drive is performing within specs, I'll upload a screenshot of crystaldisk momentarily to check.  I'm not really sure what controller the Raptor is on - the documentation for this motherboard (m4a79t Deluxe) is incredibly vague when it comes to the specifics.  But, yes, the sb750 controller should be dealing with the Raptor since it's on one of the four ports said to be used in a RAID setup.

                 

                The error in Event Viewer is pretty rare, so I might have to throw up my hands on this one - I don't know how to proceed.

                 

                Here is that benchmark - I'm pretty sure the results are standard. http://img338.imageshack.us/img338/4158/captureqb.jpg

                And, forgot to say, you are correct in your Catalyst assumption.  There are different packages: Video driver, south/northbridge, AHCI, RAID, etc.  I installed all four of these but only the first two gave me explicit options to install their respective drivers.  Both the AHCI and RAID packages offered me no choice to update the drivers.  So, yes, I am running with "Standard AHCI 1.0 Serial ATA Controller" at the moment - which bugs me to no end