13 Replies Latest reply on May 27, 2012 12:54 PM by Recep

    DX58SO: BIOS Update 5456 broke my RAID!


      For my DX58SO, I've kept up with BIOS updates, but this latest 5456 (8/30/10) is a bad one. It's also the first change in the RAID ROM in a while...the RAID ROM version hadn't changed from for quite a while, but here it jumped to


      Presumably a contributing factor is my RAID configuration is slightly complicated. Presumably this works properly for a simpler RAID setup. If it blatantly failed for all RAIDs, then it probably wouldn't have been released.


      Here's the allocation of my SATA ports:


      0 and 1 are optical media.

      2,3,4,5 are hard disks, all identical 1 gigabyte.

      2 and 3 are paired for RAID 1 (mirror)

      4 and 5 are paired for RAID 1 (mirror)


      Boot structure is the 4/5 pair (which is the second structure in the "natural" order, following the 2/3 pair)


      I'm running the latest Intel Rapid Storage Technology Driver, but this isn't relevant, in that the failure is a BIOS problem.


      This has worked perfectly with every new update installed, until I performed the 5456 update. Here's what happened:


      When I attempted the reboot after the 5456 update, the boot structure went missing, and BIOS gave me an error reading the boot device (error state: 0xC000000E). I reset the system a couple of times, and it found the boot structure again, although it had marked it as "degraded". But at least it would now boot, and the Intel Rapid Storage Technology Driver then went to work to restore the "degraded" structure. This took a couple hours, and it finally finished and said the system was normal. So I gave the command to restart to see whether the problem was gone -- and the reboot brought me right back to that "no boot" error 0xC000000E. I did the resets again, and got back to the BIOS informing me of the "degraded" boot structure. At this point, I re-installed the previous version of the BIOS, 5417 (7/27/10). I then rebooted, and again the system rebuilt the degraded structure. When the rebuild was finished, I once again rebooted, and now the reboot was fine. No more degraded structures.


      My conclusion is that there is something about the 5456 BIOS that breaks my RAID 1 boot structure upon startup.


      By the way, the non-boot RAID 1, with the disks on SATA ports 2 and 3, did not degrade.


      So the BIOS downgrade has apparently solved my problem. And there's no pressing need for the upgrade, so I can presumably just leave this in place as my work-around. But it seems clear to me that something is seriously wrong with the new BIOS RAID ROM.


      Has anybody else encountered any similar problems? Does Intel have any information about this?

        • 1. Re: DX58SO: BIOS Update 5456 broke my RAID!

          This BIOS upgrade to 5456 also affect my systems RAID settings.   It is a simple one  - two 500GB Western Digital  HDDs running RAID-0  on ports 1 and 3. The RAID controller  now reports that the the drive on port 3 is a non-RAID.Consequently, the server cannot boot the OS - Vista 64-bit.


          I have not had any issues with the RAID settings or these drives since assembling the system a year ago. The BIOS was update several times since.  I updated the BIOS ( coincidentally about  the time you were posting your note )  from version 5390 after running into the no LAN service problem.


          What I cannot seem to do now is the execute BIOS Recovery . The basic instructions to remove the BIOS configuration jumper do not see the BIOS loading.   If anyone has a suggestion about how to go back to the previous  BIOS release please feel free to post.

          • 2. Re: DX58SO: BIOS Update 5456 broke my RAID!

            Responding to andyvi's question about downgrading the BIOS...I didn't attempt the recovery technique. Instead, I merely downloaded the earlier BIOS from Intel and re-installed it using the F7 on boot-up with a USB key supplying the .bio file, just as I'd installed the update. The "downgrade" BIOS installed without any trouble. (I didn't try the recovery sequence because, although that would seem to be the right thing to do, I'd never done it before, so I figured I'd do the familiar re-install instead and hope that the bad update hadn't done anything irreversible to the configuration.)

            • 3. Re: DX58SO: BIOS Update 5456 broke my RAID!

              I would say its down to a coding problem with this BIOS update for the Intel board.


              Here with a Gigabyte board I have the Intel RAID ROM working fine with 2 x 3 disks in RAID 5 arrays.

              • 4. Re: DX58SO: BIOS Update 5456 broke my RAID!

                Success! In a fashion... 


                I completely missed the "F7" option to update the BIOS Readme file   I was able to restore the BIOS back to  version 5390  using the  USB flash drive and F7.    The RAID version also reverted to**


                What is  surprising is  that my RAID-0 array configuration recovered.   On the first boot after the 'update', the  system did not find a bootable disk.   I manually rebooted  the system and used the'Ctrl-I' command to enter the RAID menu. Looked about, but changed nothing.   It did list the array as 'Normal and  with a 'Yes'  as to being bootable. Exited and the system  warm booted again.  This time the boot disk volume was found and Vista 64 loaded normally.

                Fortunately,  I had  limited my BIOS settings investigation from earlier in the day by only enabling the USB drive boot option. Attempted to use a bootable flash drive earlier, but that went nowhere. For now  I can live with the LAN wake issue for a bit longer.


                Thank You for the quick response and guidance, Dogwood!

                • 5. Re: DX58SO: BIOS Update 5456 broke my RAID!

                  I just experienced the same problem. My raid 1 set "degraded" when I booted up with the 5456 bios. After rebuilding the set and rebooting it degraded again. I went back to the 5200 bios but still seem to have an issue with not being able to set my boot order in the bios. I assume there is some code left over from the 5456 bios that's causing the problem.  This is definitely a 5456 bios issue.

                  • 6. Re: DX58SO: BIOS Update 5456 broke my RAID!

                    Techie wrote:


                    still seem to have an issue with not being able to set my boot order in the bios.



                    We had the problem with raid not showing up in boot order, but was because volume was 4TB, the IHC10 doesn't support booting from larger than 2TB.

                    • 7. Re: DX58SO: BIOS Update 5456 broke my RAID!

                      So has anyone successfully updated to this bios using raid 1 without any problems? If you had problems did you try deleting and recreating the raid 1 array then restoring from a backup to see if that fixed the problem? If so I am interested in your experience as I use raid 1 on two internal 650 GB WD drives on sata ports 3 and 4 and would like to try this firmware myself just to get any benefits that may be available.

                      • 8. Re: DX58SO: BIOS Update 5456 broke my RAID!

                        Don't waste your time with r5456. This board's BIOS (especially with respect to BIOS raid) is buggy as hell. After it became clear that r5456 is hosed, I rolled back to r5417 disabled the BIOS raid and installed on a Linux software raid. That was about 3 weeks ago and so far it's worked out wonderfully.

                        • 9. Re: DX58SO: BIOS Update 5456 broke my RAID!

                          I had 2 RAID 0 in my computer. After upgrading the BIOS only one of them become faulty...Lucky me it wasn't the one with the operating system.

                          Hope Intel will fix this BIOS.

                          • 10. Re: DX58SO: BIOS Update 5456 broke my RAID!

                            The same problem I've got here. After BIOS updated software RAID BIOS can't see one of my HDDs, so the array is marked degraded (4x WDC Black 640 GB).

                            • 11. Re: DX58SO: BIOS Update 5456 broke my RAID!

                              I had the same problem. I have 2 raid 0 sets. All four drives are under 1 TB and the one of the raid 0 sets (The non OS set thank God) failed immediately after this bios update. I knew it had was related to the update as I have never had issues with these drives before. I installed the SOX5810J.86A.4158.EB bios and all was well. It would have been nice if the intel driver page would have posted a warning about the unstable buggy nature of this bios version or removed it as it seems that quite a few people are having this issue. It almost ruined my weekend... I am just glad it was fine once I restored the old version of the bios!


                              Stay away from this one...

                              • 12. Re: DX58SO: BIOS Update 5456 broke my RAID!

                                I've had the same problem with the 5456 BIOS.  My RAID 0 array was broken, and only one of my drives was recognized as raid capable. This left me stuck at BIOS as windows could not load.  Rolling back to the old BIOS (5417) works.   I hope they fix this in the next update as I still occasionally have LAN problems with the old one.  Have to say, as an amateur computer builder I picked intel mainly due to its reputation for producing reliable motherboards.  Not sure I'd give this so much weight next time.

                                • 13. Re: DX58SO: BIOS Update 5456 broke my RAID!

                                  I have had the same problem with an X79 Sabertooth motherboard. BIOS update broke my raid and I thought I lost 2.7 TB of data. But after some research, I have recovered all of them.


                                  I have created a guide out of this:


                                  Technopat Forum