0 Replies Latest reply on Aug 28, 2010 11:53 AM by ElecCham

    D510MO - RAM timings/POST?

      Yesterday I received a shiny new D510MO board, with a couple of G.SKILL RAM sticks rated for 5-5-5-15 timing.  I went into the BIOS and configured the RAM timing via "manual"... and lo and behold, the system no longer POSTs.  The board powers up immediately when I apply power to the board, and the (PS/2)  keyboard LEDs flash, but I get no display, and neither the power button  nor the reset button appear to do anything.  There are no other peripherals connected.  After reading some other forum posts, I tried connecting headphones to see if I got a POST error beep - but no, I get absolutely nothing.

       

      I have tried three or four different power supplies, including two in  working machines, and I also tried putting in some DDR2 533Mhz RAM from a  working machine; still nothing.  I've tried all three positions of the BIOS jumper (with a BIOS upgrade on an attached USB key); I've tried pulling the battery overnight... and, no dice.


      Does anyone have any suggestions for things that I should try, or should I consider this a DO-nearly-A, and ship it back to New Egg?

       

      TIA...