1 Reply Latest reply on Aug 22, 2010 5:22 AM by Hobbe51

    G35 graphics plus ATI Radeon 4800 stopped working

    Hobbe51

      Hi!

      I have been using an ATI Radeon 4800 with my P5E-V HDMI motherboard for a year or two, and it has worked ok.

      ATI primary digital -> my main display.

      G35 primary analog -> my secondary display.

      G35 secondary HDMI -> my television set.

      Then I got some problem with Internet Explorer 8 (which cannot be uninstalled) and while solving that I ended up with a total restore of my computer.

      I installed it the same way as before, using the downloaded latest drivers I have saved, same as before, no difference that I can remember.

      Now, I cannot activate the G35 devices. When I try extending my desktop to the secondary display (G35 primary) or the television set (G35 secondary, HDMI) Windows simply removes the checkmark for extended desktop.

      I have the latest drivers and all, just as before reinstallation.

      It has worked before. Only problem has been that it did not work if both secondary display and TV (both G35 devices) were off att PC power on, but they are on now.

      Now Windows refuse to use them.

      If I set bios to use the G35 primary as startup device, with ATI primary as secondary choice, it all comes up on the ATI anyway, from POST an on. Nothing on the G35 devices.

      If I set bios to use only G35 HDMI output as startup device, it all comes up on the television set, as it should, and I can extend the desktop from there. I cannot however, set my ATI display to be the primary display, so I have restored the setting to default (PEG/IGD).

      I have verified that my secondary monitor works ok, so that's not it.

      I just cannot figure out what I am missing here.

      Can anybody give me a hint?

        • 1. Re: G35 graphics plus ATI Radeon 4800 stopped working
          Hobbe51

          Hi again!

          I found that there is an 'information' in the system event log: "\SystemRoot\System32\igxpdx32.DLL failed to load". Microsoft had no information on that. Well, i'd say that's an error. I googled on that error message, and fond an answer.

          http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_23482714.html

          That person, Argorian, obviously knows more than Intel and Micorsoft together...

          Anyway, the solution is to increase the session image size to 0x20. It is in the registry, so just run regedit andfind: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SessionImageSize. On my computer it was 0x10, so I changed it to 0x20 as advised, and rebooted. Voila! Both the television set and my secondary monitor sprung to life, even without me changing the display properties! Windows probably remembered my setting without showing it.