11 Replies Latest reply on Aug 20, 2010 10:44 PM by igm

    DG45ID, black screen with blinking cursor after BIOS update, workaround found

    igm

      Original setup: DG45ID, original BIOS 0117, working Windows 7 Ultimate 32bit.

      I've upgraded BIOS to 0131. Since then, I could not boot into Windows. In fact, I could not boot from HDD. After POST, I got blank screen with blinking cursor in LT corner. If waiting enough, eventually some messages appeared on the 1st line (like Press any key to continue, etc.). Nevertheless, I could not boot into (previously working) Win7.

      I cleared CMOS, reflashed 0131, took another blank HDD and tried to install both Win7/32 and Win7/64. Every install went ok up to the point where I had the OS running and was installing drivers (chipset, video, you know the drill). After that, I was stuck again with black screen and the cursor.

       

      To make the long story short, I have found two workarounds.

      [1] Downgrade BIOS to 0117 or earlier. This issue started to appear with 0127.

      -or-

      [2] Set SATA mode to Legacy.

      Well, I know this is not an ideal solution, but for me it worked. It might for you, too.

       

      PS: While looking for any reasonable solution, I have come across many threads describing similar situations -- black screen with blinking cursor after POST but before OS boots. Mostly they occured after a BIOS upgrade. The workaround described (Legacy SATA mode) might work on other boards, too. I am aware that this is not a solution, but in the meantime while Intel addresses the issue, it helps.