2 Replies Latest reply on Aug 23, 2010 2:18 AM by lankes

    Problems, by booting an own kernel

    lankes

      Hi,

       

      I want to port one of our OS kernels to the SCC. Currently, I try to start a kernel which switches only to the "protected mode" and writes in an endless loop messages in a large ring buffer. With your tool "bin2obj" I converted my kernel to a hex based text file. In the map file I specified the same address than I used by linking the kernel (in my case 0x10000). Afterwards I tried to upload my kernel to the SCC and got no error message. Finally, I searched for the message buffer in memory of the SCC. I used "sccDump -c" to determine the first entry of the LUT. In my opinion, in this memory region is the kernel located. I got the 0x05 as destId and 0xcd as upper 10 bits of the new memory address. After that I started to look in the memory at the address 0xCD000000 and scan with a script the whole memory region (16MB) for my ring buffer. I found neither my ring buffer nor the constant string pool of my kernel. Where does my mistake in reasoning lie?

       

      By the way, I tried to load my kernel via sccGui as custom linux kernel and also via sccBoot with the flag "-g". In this case, I created an obj directory with sccMerge -m 8 -n 12 kernel.obj. In both cases, I did not find the ring buffer.

       

      Stefan