13 Replies Latest reply on Aug 24, 2010 6:28 PM by marvelkiller1

    Intel DP45SG Bios recovery fails, no USB or CD function anymore

    fbungarz

      Hi,

      I just came back from vacation reconnected my PC to its power source, started it up. Won't boot. Screen stays black. USB Mouse and Keyboard have power.

      1) So, I try the usual routines:

      Power off, remove memory, wait. Remove CMOS battery, remove jumper. Put all back in. Power on. No success, repeat it a couple of times, Intel Bios comes on, then the RAID Bios, telling me both primary and raid recovery drive are fine, then I get the Intel Bios Screen again and think now it will go to boot up windows as usual, but, no, PC resets, again the same repeating BIOS screens.

      So, I no think, I have to reset something in the BIOS, try to get into it via F2. Alas - keybord no longer recognized. Then black screen again. I try the remove CMOS battery, jumper off - jumper on routines a few times and a few more times get the BIOS screens, but never manage to get into the BIOS because keyboard no longer is recognized.

       

      2) I decide to try BIOS recovery:

      --- Download the most recent *.BIO file, copy it to an empty (non-bootable) USB. Nothing, USB not recognized. Screen stays black. Try another USB. Download HP utility to make USB stick bootable and then copy the *.BIO. Nothing! Screen stays black, keyboard and mouse not recognized, no beeps upon startup.

      -- Burn ISO Bios recovery image onto CD and insert into CD drive. Drive spins, light blinks a few times. Light dies, drive stops spinning. CD not recognized.

       

      Some Backup Info:

       

      This PC was running well before. I once experienced the BIOS failure when it was disconnected for some time from power. Then again with another power failure where it told me to replace the CMOS battery, which I did.

      I live in Ecuador where power failures are pretty common, so I do have the PC always connected to a UPS (Universal Power Supply Battery). All power failures that I experienced the computer was shut down properly while still connected. But of course during longer blackouts at some point the bateries are empty and so, as a precaution, I always turn off the chassis switch when that happens. That is also the reason why, during vacation, I left the PC disconnected for several weeks.

      Now, it seems that this board cannot live without power for extended periods. It also seems that the BIOS is now permanently corrupted.

       

      The only other trouble I had with this board was with a NVIDIA video card. The board had always real hard times booting up this card recognizing the correct drivers. It would work only with some of the older drivers, not the most recent one. I contacted NVIDIA, apparently that is a common problem with them. They gave me detailed instructions how to try different drivers and I kept the one that worked. But now the BIOS won't even come on, the keyboard is not recognized, the USB Bios recovery and the CD Bios recovery failed.

       

      I bought this board in Germany hoping for some decent quality, not the junk they usually sell in Ecuador, but I must say I am really, really disappointed. It now looks that I can trash this board barely after a year!!!

       

      This board is just the worst one EVER!!!

       

      But perhaps anyone has ANY idea? Replacement is a joke, how am I supposed to return this board from Ecuador to Germany???

      So, unless there is ANY other way to still recover the BIOS, I can just throw this one in the bin :-(

        • 1. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
          mechbob

          Tell us about the rest of your SYS such as what PSU what CPU what ram , and how old ??

          • 2. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
            fbungarz

            Hi Robert,

            the PC is 1 1/2 years old and like I said it worked fine all that time (appart from the driver issue with the video card that got resolved). I did not change ANY parts, just turned the PC on again. Therefore I am not really sure why it would make any difference to know all the spare parts, but here it comes:

             

            Power Supply: Chieftec Green Angel CTP-450-12G 450 Watt

             

            Processor: Intel Core 2, the exact make I don't remember, it happily sits below its fan on the mainboard and I don't want to remove it just to check out its specifications. Since the PC does not start I have no other way of checking it...

             

            Memory: Kit of 2x 2 GB RAM Kingston KVR 1333D3N9K2 4GB total.

             

            Graphics Card: ASUS V702

             

            2 Harddisks 500GB Western Digital configured as Intel Recovery RAID

             

            Peripherals:

            keyboard, mouse, Samsung SyncMaster 172N

             

            Add-on cards:

            Internal Express card reader with 1 USB, SD/MMC, MS, CF/MD, SM/XD slots connected to mainboard, eSata port connected to PXI-X RAID 5 SATA II Controler/JOBD

            PCI-Express E-Sata Multiplier (Adonics) for an external SATA HD Box with 4 Harddrives

             

            For your information: I removed all add-ons and tried to get into BIOS with the essentials only (processor, RAM, graphics card, keyboard) - no luck either!

             

            Help appreciated.

             

            Thanks,

            Frank

            • 3. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
              mechbob

              Rather than tring to update the BIOS see if you can do a BIOS recovery so you can get back in the old BIOS reset everything to defaults and put jumper back in place and try to restart ,see what happens . If you can get back up and running than update BIOS. Also it's a good idea if you have a volt meter do some basic checks 12 volts 5 volts 3.3 volts and grounds .

              • 4. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                fbungarz

                Hi Robert,

                no offense, but did you even the title of this post let alone my description of what I did?

                 

                I did NOT ever attempt to update the BIOS. I tried several times to recover the BIOS by clearing the CMOS moving the jumper, then flash with USB and with CD. There are no beeps, the USB and CD is not recognized, removing CMOS and jumper does nothing!

                 

                Well, thanks for the attempt to help anyways. I am pretty sure the BIOS of the board is just irretrivably corrupted. $%$#@

                 

                Frank

                • 5. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                  mechbob

                  Miacopa , Try removing all the ram and see if you get 3 beeps at least that will tell you weather the board is alive ??

                  • 6. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                    fbungarz

                    Hi Robert,

                    citing what I wrote in my first post:

                    "Nothing! Screen stays black, keyboard and mouse not recognized, no beeps  upon startup."

                    I also mentioned that I tried various things including taking out the memory.

                     

                    However, the board is not "dead". The LED lights up, all the fans start spinning, the CD drive spins when inserying a CD, front light briefly blinking, but does not read, USB Sticks also briefly blink, but then do not read, to sum it up, there is activity, but to no avail. Guess you could call it "brain dead", all its organs are alive but it still doesn't start "thinking", being entirely unaware of what its body parts are for...

                     

                    One question you might be able to help me with: given that the board BIOS apparently is irrecoverably damaged what are the chances that the processor is still intact? I tried the RAM in another machine, where it works fine. Now I am thinking, if the processor is still intact perhaps getting the board replaced with an identical one might be an option. That way I would at least not have to re-install everything and could save quite a bit of money not having to buy a new processor and RAM.

                     

                    However, if the processor is likely to be beyond help too it might be better to get a whole new PC. Also I am not really keen to buy such a crappy Intel board ever again...

                    This is the first Intel board I ever got. Before I always went for AMD building my PCs and those always worked flawless for years. Never experienced a situation where the Bios got corrupted without being able to flush it.

                     

                    Cheers,

                    Frank

                    • 7. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                      mechbob

                      I don't think a corrupted Bios would hurt the CPU , When you tried the recovery with the USB drive did you have it pluged in the MOMBO or the front of the computer ?? Grasping for straws here just tring to help .

                      • 8. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                        fbungarz

                        Hi Robert,

                        thanks for the continued advice. I tried all different USB ports, the ones directly on the mother-board and all the others. No difference. Tried various USB sticks, different brands, both bootable and non-bootable. Nothing!

                        Stick goes in, light blinks one time, then nothing....

                        CD goes in, light blinks about 5 times, stops spinning, nothing...

                        Plug in mouse, scanning LED blinks very briefly (less then a second), nothing...

                        Plug in keyboard, keybord LED blinks very briefly (less then a second), nothing...


                        Screen always remains dark, all fans keep running, if connected harddrives keep spinning, nothing...

                         

                        On RAM chip inserted, two RAM chip inserted, changing RAM positions, nothing...

                         

                        Turn off PC, take out CMOS battery, take off jumper, leave >1 hour, afterwards the same!

                         

                        In the meantime I have looked a bit around for reviews of this particular board and it seems it is a very common complaint that the BIOS of the DP45SG crashes irrecoverably. It seems that the board is really just faulty, that it was poorly made or never really tested well. You wouldn't think that a large, well known company like Intel would sell you junk, but it just looks like that that is what it is. Very disappointing...

                         

                        I am really not sure what to do now. It would be easiest just to buy the same new board and since you are saying it is unlikely the processor has been damaged it might be worth the try. On the other hand, I am really not keen to try that same kind of crappy board again. Switching tgo another, non-Intel board probably means I also need to get a new processor, video card, memory that fits with that one or I am stuck with having to find a board that is sure to work with what I have. Difficult decision...

                         

                        Frank

                        • 9. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                          mechbob

                          yea I know what you mean the board was a problem board the day they released it , I am currently using a DX48BT2 , which is the best 775 Board that Intel ever bulit No bugs no BIOS problems and all the parts on the DP45SG will work on the DX48BT2 , But the only place you can get them is on ebay , new about $220.00, refurb. $175.00, But it is a great board.

                          • 10. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                            fbungarz

                            Hi Robert,

                            I looked around a bit and think I'll get the ASUS P5Q Pro Turbo Core. It got really good reviews, no DDR3, but DDR2, but apparently very stable and a lot more to offer that the crappy piece of junk I am not getting to work right now. I have really had it with Intel and I just looked at Amazon where they sell the board you are recommending and there is one review out of three also saying it has BIOS problems. No more Intel boards for me!

                            Thanks,

                            Frank


                            • 11. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                              mechbob

                              Well I hate to see you be so distrought with Intel some of their boards are realy good and last for years when set up right, As far as the DX48BT2 , I had mine running for over a year no problems , not even with BIOS up dates has always worked like a charm , good overclocker, I am using a QX9650 c1 step, running at 3.8 at 45c , Like I said no problems , I think anyone that says that the DX48BT2 has problems , just doesn't know how to set it up. But if you most go to ASUS at least get a DDR3 Board , Good luck , If you don't want the DP45SG anymore maybe you could mail it to me and I'll have a go at getting , No I got too many Old boards in my shop now .

                              • 12. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                                mechbob

                                I used the ASUS P5QC to builld my Grandson's computer ,it's a pretty good board and uses DDR-2 and DDR-3 Both Well you have to use one or the other you can't use both at the same time. But it's a good stable, had a little prob. getting some of the windows 7 64 bit , drivers , but it all worked out great in the end.

                                • 13. Re: Intel DP45SG Bios recovery fails, no USB or CD function anymore
                                  marvelkiller1

                                  what revision board do you have, is it revision 405?

                                  I had a revision 403 dp45sg that failed on me and sent it in for replacement and got 2 rev 405 and both were a piece of crap, both had issues with the usb ports, wouldnt read my usb keyboard at start up, and intel's customer service being a piece of sh*t for customer service just kept giving me the run arounds as to saying that it wasnt the board that was bad as the odds of having 2 board with the same issues was just impossible. so went ahead and trashed that board and got a evga board and havent had a problem since.

                                  swap out boards and save yourself the trouble.