5 Replies Latest reply on Aug 17, 2010 2:59 PM by redux

    Slow X-25M G2

    Smal

      Intel X-25M G2 with firmware 02HA. The computer is a Dell XPS720 with nVidia 680i chipset. W7 x64 on the SSD. Also Vista on Raid 0 on the computer.

      Originally I found out the SSD would not run acceptable on this motherboard//in conjunction with Raid 0, so I installed a U3S6 PCI-e x 4 controller card with SATA 6 GB/s and USB III in a PCI-e x 16 slot, and connected the SSD to that one. That worked better and the Intel Toolbox was able to run. I have never been too impressed by performance but have not had any real problem and have not bothered to benchmark. Now I replaced Photoshop CS4 by CS5 and found the program very slow. Also had reasons to copy a larger PS Lightroom db from my Vista disk to the SSD and this was slow.

       

      Run a benchmark with quite a disappointing result. Would appreciate suggestions for where to start looking for the root cause of this.

      IntelX25_AS SSD Benchmark 20100816-2_R-W.JPG

        • 1. Re: Slow X-25M G2
          redux

          I’ve tried out the U3S6 with an X25-M and whilst it did not perform as well as ICH9 or 10 it performed better than your results. Looking at your 4K-64Thrd result I’d say you are running in IDE mode. Switch to AHCI mode and you will see a huge difference. Before you switch over to AHCI mode you need to change a registry setting or you will not be able to boot. There have been a few posts on this forum on how to do that or you could search with Google.

          1 of 1 people found this helpful
          • 2. Re: Slow X-25M G2
            Smal

            Thanks! I have seen how to switch to AHCI mode in mobo Bios. In my case the mobo and its Bios does not support AHCI. This, and because I could not run the Toolbox (said it was in Raid), is why I installed the controller card. This one supports AHCI and runs on its own Bios. Since installing it, I have an AHCI controller in the Device Manager and Toolbox works. Maybe the mobo still stands in the way. I have no clue on how to get it into AHCI mode with my config. The registry entry is set to "0".

            • 3. Re: Slow X-25M G2
              redux

              The U3S6 uses a Marvell 9123 controller. It’s been a while since I tried the U3S6 but it defiantly allows you to run in AHCI mode. When you boot up select the bios options for the card and see if it is set to AHCI.

              There are some benchmarks using the U3S6, which can be found in the link below. As you will see the 4K-64Thrd results are significantly different to yours, but all the other results are similar. 4K-64Thrd results improve in AHCI mode because it enables NCQ.

              http://communities.intel.com/message/85255

              • 4. Re: Slow X-25M G2
                Smal

                There is no way I can find to get into the Bios of the adapter and there is no way to set AHCI in mobo Bios, I am afraid. At the same time, to me as a layman, it appears OK in the Device Manager, see picture. Could it still run in IDE mode? Could there be anything else to look at? Thanks for the help so far, much appreciated.

                DeviceManager20100817.JPG

                • 5. Re: Slow X-25M G2
                  redux

                  Whoops, it looks like AHCI is the default setting. I’ve just popped my U3S6 back in and this is what I get with the latest drivers from ASUS (on an ASUS mobo with an ICH9 Intel chipset). Note that the controller states “mv91xx”. Your benchmark shows the default MS AHCI driver, which I should have picked up earlier. Sorry about that. Try updating to the latest ASUS driver and see what happens.

                   

                  AS SSD Benchmark 1.5.3784.37609

                  ------------------------------

                  Name: INTEL SS DSA2M160G2GC SCSI Disk Device

                  Firmware: 2CV1

                  Controller: mv91xx

                  Offset: 1024 K - OK

                  Size: 149.05 GB

                  Date: 17/08/2010 23:43:08

                  ------------------------------

                  Sequential:

                  ------------------------------

                  Read: 250.10 MB/s

                  Write: 101.07 MB/s

                  ------------------------------

                  4K:

                  ------------------------------

                  Read: 23.27 MB/s

                  Write: 47.42 MB/s

                  ------------------------------

                  4K-64Threads:

                  ------------------------------

                  Read: 125.85 MB/s

                  Write: 62.62 MB/s

                  ------------------------------

                  Access Times:

                  ------------------------------

                  Read: 0.083 ms

                  Write: 0.092 ms

                  ------------------------------

                  Score:

                  ------------------------------

                  Read: 174

                  Write: 120

                  Total: 386

                  ------------------------------