0 Replies Latest reply on Aug 15, 2010 11:31 PM by ronnycook

    Intel Pro/1000 PT Quad Port not responding

    ronnycook

      We have three ASUS based servers running as virtualisation platforms under Centos Linux (kernel 2.6.18). A couple of weeks ago after a system update the twin Intel Pro/100 PT quad port low profile adapters in the unit stopped responding. They are not recognised by the BIOS, "lspci" shows the cards as completely absent. However when connected they do show lights on the back ports.

       

      I tried booting a recent Knoppix CD and it also cannot see them, I tried removing all other PCIE cards from the system with no effect. Moving the cards to different PCIE slots also has no effect. Reordering cards has no effect (although the other PCIE cards in use recognise the other two PCIE cards I'm using, a RocketRAID RAID adapter and a QLogix 4062C iSCSI adapter.) The internal twin gigabit adapter is unaffected.

       

      It sounds a bit like the issue with the kernel 2.6.24 beta which wiped the card BIOS, but I would expect that in that instance the cards would at least show up (and we've never used that kernel revision.)

       

      Two identical systems located adjacent to the problem system went through exactly the same update with no ill effect.

       

      The cards had been operating flawlessly in deployment for about 5 months before failure.

       

      From one of the working servers: chipset used in the server is Intel based:

       

      00:02.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 2 (rev 13) (prog-if 00 [Normal decode])
              Flags: bus master, fast devsel, latency 0
              Bus: primary=00, secondary=17, subordinate=17, sec-latency=0
              Capabilities: [40] #0d [0000]
              Capabilities: [60] Message Signalled Interrupts: 64bit- Queue=0/1 Enable+
              Capabilities: [90] Express Root Port (Slot+) IRQ 0
              Capabilities: [e0] Power Management version 3
              Capabilities: [100] Advanced Error Reporting
              Capabilities: [150] Unknown (13)

       

      and the ethernet port looks like this:

      10:00.0 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (Copper) (rev 06)
              Subsystem: Intel Corporation PRO/1000 PT Quad Port LP Server Adapter
              Flags: bus master, fast devsel, latency 0, IRQ 116
              Memory at fbb80000 (32-bit, non-prefetchable) [size=128K]
              Memory at fbb60000 (32-bit, non-prefetchable) [size=128K]
              I/O ports at b880 [size=32]
              Expansion ROM at fbb40000 [disabled] [size=128K]
              Capabilities: [c8] Power Management version 2
              Capabilities: [d0] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable+
              Capabilities: [e0] Express Endpoint IRQ 0
              Capabilities: [100] Advanced Error Reporting
              Capabilities: [140] Device Serial Number 82-6e-d3-ff-ff-17-15-00

       

      Environment between the systems is basically identical - same power feeds, same switches etc. The only difference I can think of is that the faulty server was turned off manually (by holding down the power button for 4 seconds) when it was hanging on system shutdown. The others rebooted cleanly.

       

      Any suggestions or hints as to what might be happening? Or requests for further data?