7 Replies Latest reply on Aug 10, 2010 9:09 AM by jugator

    How to disable onboard video in a D945GSEJT

    jugator

      I have a D945GSEJT, and I need it to work with 4 monitors, so I installed a Matrox G450x4 MMS.

       

      When I turn on the computer, the bios screen appears in the output 2 of the Matrox card, and after the bios screen, the system hangs. The Matrox G450x4 MMS manual says that in systems with onboard video, this must be disabled, but in the bios settings there are no option to disable it.

       

      Is there any way to disable it? May be another bios version or something? I have the latest bios version(5/19/2010 0045)

       

      Thanks for any response.

        • 1. Re: How to disable onboard video in a D945GSEJT
          Cpt.Dogfruit

          Nope sorry... my only thoughts were by putting a GPU in it would switch but i had doubvts which u have confirmed, i don't know for what cards they put the slot on there for but it's  not ur normal GPU therefore i didn't think it would switch the onboard graphics automatically

          • 2. Re: How to disable onboard video in a D945GSEJT
            deio

            Ok, so every Intel Desktop Board with Gxxx chipset has automatic switchable graphics that turns itself off when Ext. PCI-E card is detected (Asrock or Asus still uses the internal one even if offboard card is detected, for example). So there's no interference from onboard GPU, you can use your Matrox without problem, even Device Manager won't show it in Windows. The hang is probably from a defective memory module, or other hardware problem, please test your RAM with a free program like Memtest and see if errors are found.

            • 3. Re: How to disable onboard video in a D945GSEJT
              jugator

              Thanks for the replies.

               

              The card is actually a PCI, not a PCI-e. I will do the memory test, I will post the results.

               

              Thank you

              • 4. Re: How to disable onboard video in a D945GSEJT
                Cpt.Dogfruit

                i think the issue will be exactly that it is not a PCI-e, therefore in a way not expected to have a gpu!

                • 5. Re: How to disable onboard video in a D945GSEJT
                  deio

                  Possibly because PCI is not used anymore as primary VGA adapter, and has been overtaken by PCI-E, so the PCI is for legacy adapters only

                  And then the onboard VGA does not disable itself because the chipset doesn't detect anything on PCI-E, so it remains active....

                  • 7. Re: How to disable onboard video in a D945GSEJT
                    jugator

                    So... the video on board cannot be disabled, not manually or automatically.

                     

                    Anyway, more info, just in case the problem is other.

                     

                    I boot the computer with a kubuntu 9.10 live cd, one monitor conected to the VGA on board, and another monitor conected to the output #2 of the Matrox card. This is whats happens, in order:

                    - The bios screen appears on the monitor conected to the matrox card.

                    - Both monitors in black.

                    - Monitor connected to the onboard VGA shows lines without sense, but repeated periodically (I think that this is when the kubuntu live cd menu appears, I press Enter two times, one for language and the second for boot with kubuntu).

                    - Then, the monitor connected to the onboard VGA maintains the lines, and the monitor connected to the Matrox card shows kubuntu correctly, without any problem.

                    - If I leave kubuntu, the screens in command mode (kill processes and the line that want's you to press intro after quit the cd) doesn't show in any monitor, but it works normally, ejecting the cd, and shutting down the computer after press enter.

                     

                    I don't know if this can help in any way.

                     

                    Thank you all.