7 Replies Latest reply on Dec 21, 2011 4:56 PM by zgr

    Intel PM55 chipset and X25-E SSD Very low 4K random reads/writes Alienware M17x -R2

    stamatisx

      I am trying to figure out if there is something wrong with the PM55 chipset from Intel

       

      This is a screenshot taken from my Alienware M17x - R1 with an NVIDIA chipset (open the pictures on a new tab or window to see them)

       

      This is from my Alienware M17x - R2 with Intel Chipset using Dell's drivers chipset drivers and the Microsoft's default drivers for storage.

       

      This is after a clean Windows installation with only the Dell chipset drivers and for storage the latest RST drivers from Intel

       

      This is in safe mode

       

      I have tested the SSD and it's fine and I  have also performed a  secure erase to the disk before each clean Windows  installation to make  sure the SSD's performance is set back to factory  defaults (8 secure  erases and 8 clean Windows installations so far).

      I have also  tried every possible driver combination (Matrix Storage  drivers from  both Intel and Dell, RST, chipset drivers from both  Intel  and Dell)  and I haven't managed to get the performance close to half of  what it  was with my R1.

       

      Note,  the mode is set to AHCI from inside BIOS, I get the exact same  performance when Windows are installed with the RAID option instead of  AHCI.

       

      The same behavior is noticed among other manufacturers like Asus, Dell, Lenovo, HP

      http://forum.notebookreview.com/6399977-post2096.html

      http://forum.notebookreview.com/5519041-post2424.html

      http://www.ocztechnologyforum.com/forum/showthread.php?69573-OCZ-Vertex-120GB-Slow-4K-Read-Results-on-Asus-G51J-Notebook

      http://thenextbench.net/t5/HP-Envy-Notebooks/Poor-SSD-Performance-in-Envy-4k-Read-Write-Times/m-p/55680

       

      Is this by any chance the reason for this problem?

      http://hardforum.com/showthread.php?p=1035010918#post1035010918