1 Reply Latest reply on Jul 31, 2010 11:13 AM by Curious592

    A scrambled, yet working BIOS

    mbright

      My D955Xbk has a scrambled BIOS. It boots fine and loads the OS as long as I don't change any hardware. However, I can't get into the bios with F2. Post never displays on the screen during boot. It won't boot from USB, CD or Floppy. If I try to update the bios the program says the bios is not for my system. I looked into this and I believe it is because the Manufacturer and bios version of the systemboard are set as garbage (Instead of Intel, it says u). So, I tried the BIOS recovery and it will read from the floppy but nothing is ever displayed on the screen (waited half an hour) and it doesn't fix the problem. Any suggestions? Anybody ever see ths before?

      bios.png

        • 1. Re: A scrambled, yet working BIOS
          Curious592

          Device Manager always displays Computer as (Standard Computers) and System Information lists as Intel_ so I don't think that is the problem.  While the only problem I had with Vista was figuring out how to install the first printer Vista driver, I think Windows 7 has some hardware recognition issues related to task manager.  That still should not alter BIOS and boot however.  I won't know more until I reinstall my Windows 7 since I must have incorrectly used Recovery after checking graphics with a 7600GS graphics card on a DG45ID.  Much of the problem is interpretation since the screens are loading too fast.  I tried to do a recovery from my 131 to 117 and same as you I only got periodic blinks from my DVD activity.  Otherwise issues are generally resolved by waiting a few seconds more and have no problem entering BIOS.  I don't have your utility unfortunately.