3 Replies Latest reply on Jul 29, 2010 2:27 PM by Michael1966

    Data loss in Intel X25-M G2

    koray

      I am not sure if this issue has anything to do with my Intel SSD, nevertheless I wanted to ask first here. I have a Thinkpad X61 Tablet PC with Windows 7 Pro installed on Intel X25-M G2. My system is regularly updated, with proper antivirus software  installed. It has been great for about 8 months since I installed fresh OS on my brand new SSD. Not so long, here is my horror story:

       

      Today I decided to reinstall my Bluetooth drivers since it was giving an error everytime I turned wireless switch on. Original Lenovo driver installation didn't complete, giving a strange Windows error. I tried again, same error. So I googled the problem, there were suggestions about uninstalling the original driver first. Duh, I said, and went ahead. Whoop, all Broadcom drivers are gone. Then one final driver was left, something like Lenovo Bluetooth EDR driver, I clicked uninstall. The machine stalled for a minute or two with very high SDD activity. Meanwhile, somehow I wanted to check My Documents folder, and whoa, nearly empty! I said to myself, it must be something to do with non-responding explorer.exe, so when I saw "You need to restart now" message on uninstall window, I went ahead and clicked. Oopps. Windows couldn't boot.

       

      So, I used my system rescue disk (every month I take a system image using Windows backup tool) and tried to repair. No way. It only allows me to reinstall a system image. Well, I took the SSD out, put it in an external SATA case and looked up its contents. Out of 30GB data, only 7GB was left! I used a data recovery tool and recovered some data that I didn't back up earlier (my critical work is backed up many times a day). Strangely, only about half of my data was in recoverable state. Thanks to my regular backup routines, I didn't lose anything.

       

      System recovery worked like a charm, though. I am back to July 6th 2010 on my machine.

       

      What is going on? Of my all 20 years computer experience, this is the first time I see my data is erased without my will. Do you have any ideas? Has this happened to anybody else?

       

      Thanks for listening, and thanks in advance for comments.

       

      Koray

        • 1. Re: Data loss in Intel X25-M G2
          Michael1966

          I've never experienced anything like this and am sorry to hear of your difficulties. I've lost all my data twice but that was due to me being silly and not keeping back up copies. Both were due to HDD hardware failures. I now have everything stored on folders on two separate HDD drives. The only advice I would give is try and reinstall those bluetooth drivers. Perhaps search on google or contact who you bought the hardware from and see if they have any ideas to get it back with the correct drivers. I'd never use 'My Documents' or the Macintosh equivalent whatever that is these days, to store anything. I'd advise organizing your own folders on separate hard drives from the system disk and keeping a copy also on a separate hard drive.

          • 2. Re: Data loss in Intel X25-M G2
            koray

            Thanks for your suggestions Michael. I regularly backup my disks, so thank God no data lost. I always keep a high quality SD card in the embedded reader and backup my work several times during the day. In addition, I backup to a thumb drive each night. Finally, I do system backups on 3 separate hard drives every month (today I decided to do this every week).  After restoring the system my tablet seems to works fine now, but we will see.

             

            What I am stunned with is the fact that more than 3/4th of my SSD contents were erased (and only about half recoverable). And that happened while Windows 7 was functional, I mean, try formatting your main drive when you are running an OS, isn't it odd?

             

            K.

            • 3. Re: Data loss in Intel X25-M G2
              Michael1966

              The problem is it's not always clear who is responsible for such a data loss due to the owners of the operating system being involved and also the fact hardware manufacturers tell you to make back ups in case installing a driver or update goes pear shaped.