7 Replies Latest reply on Feb 3, 2016 9:17 AM by aleki_intel

    Intel 6200 AGN problems (need help)




      I've bought one AGN 6200 (622ANHMW) and there's a quite strange thing happening.


      On Windows 7 I cannot get it to work, the drivers install and stuff but it always says "This device cannot start (Code 10)". Taking a look at the event manager, it says that it can't allocate the resources.


      What's even more strange is that I booted Ubuntu 10.04 live CD and the card works flawlessly in there.


      This is on my laptop, an Acer 4810TG. There's no boot or unsupported device error, even though I've checked the BIOS and the card doesn't seem to appear on the "whitelist".


      Does anyone have any ideia of what's up? Don't really wanna be stuck with Ubuntu for wireless networking.


      the device is a 8680_4239, SUBSYS 1311



        • 1. Re: Intel 6200 AGN problems (need help)



          it is likely that the card you purchased is not compatible to your Intel mainboard chipsets. I have an Acer 8943G and did have the same issues here.

          The solution was to purchase the AGN 6200 (622HMWWB) instead of ANHMW. This worked fine for me.


          Hope this helps.

          • 2. Re: Intel 6200 AGN problems (need help)

            Thanks for the reply, but if it were incompatible with the chipset why would it work on linux? My laptop chipset is a ICH9M-E.


            I've also tested it on my desktop, which has a ICH10R chipset and the results are exactly the same, working on linux and not on windows.


            I've already sent it back, hoping the one they'll send back to me will work.

            • 3. Re: Intel 6200 AGN problems (need help)

              I have run into the same issue with Intel 6220 AGN, bought from the eBay.


              The card worked fine under linux but failed to initialize in Windows (7), no matter which Intel driver version I tried.

              Under Win7 Device Manager it reported as PCI\VEN_8086&DEV_4239&SUBSYS_13118086 which apparently is Lenovo branded card and will not work with Windows on my laptop (ASUS). I browsed windows .inf file and found generic (unbranded) counterpart that should identify as PCI\VEN_8086&DEV_422C&SUBSYS_13018086, then booted linux with intention to edit card EEPROM (no warranty - no worries).


              Then under linux I:

              1) downloaded iwleeprom tool

              $ svn checkout http://iwleeprom.googlecode.com/svn/trunk/ iwleeprom-read-only


              2) edited iwleeprom.c to enable RW capability for writing 6200 EEPROM

              $ vi iwleeprom-read-only/iwleeprom.c

              modified line:

              { 0x8086, 0x4239, 0, EEPROM_SIZE_5K,   "Centrino Advanced-N 6200"},

              to read:

              { 0x8086, 0x4239, 1, EEPROM_SIZE_5K,   "Centrino Advanced-N 6200"},


              3) compiled iwleeprom binary

              $ cd iwleeprom-read-only && make


              4) noted down PCI bus on which WIFI card was on

              $ lspci -nv

              03:00.0 0280: 8086:422c (rev 35)

                      Subsystem: 8086:1301


              5) dumped card's EEPROM to a file

              $ ./iwleeprom -d 0000:03:00.0 -o eeprom.bak

              $ cp eeprom.bak eeprom.mod


              6) used hex editor to modify device identification from branded to generic (as per identification on top), minding this is little endian

              $ hexer eeprom.mod


              00000000:  40 5a 50 00 00 60 00 00  01 00 35 00 80 02 86 80  @ZP..`....5.....

              00000010:  39 42 86 80 11 13 01 0d  8b 03 00 05 f0 00 40 00  ,B............@.



              00000000:  40 5a 50 00 00 60 00 00  01 00 35 00 80 02 86 80  @ZP..`....5.....

              00000010:  2c 42 86 80 01 13 01 0d  8b 03 00 05 f0 00 40 00  ,B............@.



              7) saved and written the modified file into card's eeprom (root/sudo)

              (Note that following step can break your hardware. Use at your own risk)

              # ./iwleeprom -d 0000:03:00.0 -m -c -i eeprom.mod


              8) rebooted to windows


              Then I installed latest drivers that identified this card as generic Intel 6200 AGN.

              Issue has been solved - card now works both under linux and under windows.

              • 4. Re: Intel 6200 AGN problems (need help)

                Thank you very much for your post,

                On regards to your question, please note that the Intel® Centrino® Advanced-N 6200 wireless adapter is meant to be professionally installed by Original Equipment Manufacturer (OEM) technicians on certified systems only.

                Please also note that these adapters are not meant to be sold separately, your system must be compliant with the required FCC certifications in compliance with the International Special Committee for Radio Interference standards for radiated and conducted electromagnetic interference.

                In this case what we recommend and encourage you to first contact the Original Equipment Manufacturer (OEM) to determine if the product is approved for use in your computer.

                For additional information you may refer to:

                Intel® WiFi Products - Upgrade or exchange Intel® wireless adapter hardware



                Intel® WiFi Products - Why doesn't my laptop recognize my new Intel wireless adapter?





                Joe H.

                • 5. Re: Intel 6200 AGN problems (need help)



                  Thank you very much for your post, I followed your instructions and with some little tweaking on the "c file" ( basically I had to increment the "usleep" time from  50 to 10000, this for both read and write of the eeprom since I'm on a 64bit distro, just do a find/replace of :  usleep(50) for usleep(10000)  , it should do 2 replacements. )


                  After that compiled the file and dumped the eeprom, tweaked it using Okteta since I'm a KDE user , saved the eeprom.mod , loaded it to the wifi card , rebooted into windows and voila , the card was recognized instantly.


                  Kudos +1 to proteus  and also to @koct9i from: Issue 2 - iwleeprom - 64-bit issues? - EEPROM reader/writer for intel wifi cards. - Google Project Hosting

                  • 6. Re: Intel 6200 AGN problems (need help)


                    Thank you, your post was very helpful. But it doesn't seems to work in my case

                    I have Brand New HP 539525-001 Lenovo 60Y3233 Intel Centrino Ultimate-N 6300:


                    I modded and wrote EEPROM with new VEN 422B and SUBSYS 1101. After reboot it correctly recognized under linux with new values. BUT if I turn off the computer and unplug power cable and plug it in and power on then new values substitutes with an old one! So everything works before next power off! So is it possible to save new values permanently?

                    • 7. Re: Intel 6200 AGN problems (need help)



                      For support on Intel® Wireless Adapters on Linux* envoronment, please access these links: https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi and Intel® Wi Fi Adapters Linux* Support for Network and I O