2 Replies Latest reply on Jul 23, 2010 2:43 PM by mark_h_@intel

    Cannot get Gigabit CT Desktop Adapter working under Server 2008 Core R2

    Boarder2

      I recently purchased an Intel Gigabit CT Desktop Adapter hoping to install it on my Hyper-V Server 2008 R2 installation as a second NIC to alleviate stress on the onboard Realtek.

      The specific adapter is here http://www.amazon.com/gp/product/B001CXWWBE/

      Model: EXPI9301CT

      According to Intel http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18725&ProdId=3025&lang=eng it is supported in Windows Server 2008 R2.

      I've run the installer, it runs, appears to install the correct driver, but the adapter doesn't work.  Via remote device manager, it shows with the yellow exclamation point and device status of "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)"

      In the driver details under the Install inf property the value is "C:\Windows\INF\oem3.inf" ... which doesn't seem right?

      I've tried using pnputil to install the drivers via the INF extracted from the Intel installer but it errors:

       

      c:\Users\myuser\Documents\IntelDrivers\PRO1000\Winx64\NDIS62>pnputil -i -a e1q62x64.inf
      Microsoft PnP Utility
      
      Processing inf :   e1q62x64.inf
      Failed to install the driver on any of the devices on the system : No more data is available.
      
      Total attempted:    1
      Number successfully imported: 0

       

      Using the provided command line utilities in the Intel driver set, I can see the adapter and it's settings:

       

      C:\Program Files\Intel\DMIX\CL>prosetcl adapter_enumerate
      
       Number of adapters currently present: 2
      
        1) Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)
        2) Intel(R) Gigabit CT Desktop Adapter
      
      
      C:\Program Files\Intel\DMIX\CL>prosetcl adapter_enumeratesettings 2
      
       2) Intel(R) Gigabit CT Desktop Adapter
      
       Settings:
      
        *FlowControl    - Rx & Tx Enabled
        *InterruptModeration  - Enabled
        *IPChecksumOffloadIPv4 - Rx & Tx Enabled
        *JumboPacket    - Disabled
        *LsoV2IPv4    - Enabled
        *LsoV2IPv6    - Enabled
        *MaxRssProcessors  - 8
        *NumaNodeId    - System Default
        *PriorityVLANTag   - Priority & VLAN Enabled
        *RSS      - Enabled
        *SpeedDuplex    - Auto Negotiation
        *TCPChecksumOffloadIPv4 - Rx & Tx Enabled
        *TCPChecksumOffloadIPv6 - Rx & Tx Enabled
        *UDPChecksumOffloadIPv4 - Rx & Tx Enabled
        *UDPChecksumOffloadIPv6 - Rx & Tx Enabled
        *WakeOnMagicPacket  - Enabled
        *WakeOnPattern   - Enabled
        AdaptiveIFS    - Disabled
        EnablePME    - Disabled
        ITR      - Adaptive
        LogLinkStateEvent  - Enabled
        MasterSlave    - Auto Detect
        NumRssQueues    - 1 Queue
        WaitAutoNegComplete  - Auto Detect
        WakeOnLink    - Disabled
        *ReceiveBuffers   - 256
        *RssBaseProcNumber  - 0
        *TransmitBuffers   - 512
        NetworkAddress   -
        ConnectionName   - Local Area Connection 4
      
      C:\Program Files\Intel\DMIX\CL>

       

      But of course netsh doesn't show it (Local Area Connection 4)

       

      c:\>netsh interface show interface
      
      Admin State State   Type    Interface Name
      -------------------------------------------------------------------------
      Enabled  Connected  Dedicated  Local Area Connection
      Enabled  Disconnected Dedicated  Local Area Connection 2
      Enabled  Connected  Dedicated  Local Area Connection 3

       

      I'm at the end of my rope here and don't know what to try next.

      I might be willing to accept that this NIC just won't work with R2, but if that's the case, before I just go buy another card that looks like it should work.  Can anyone recommend a PCI or PCI-E gigabit adapter that WILL work with R2 for sure that is under $35?

      I'd prefer to get this thing working, though.

      Thanks!