0 Replies Latest reply on Jul 20, 2010 5:29 AM by Marina

    Cannot change resolution on my monitor

    Marina

      Well, I have a bit of a long story to tell. I'll try to be as brief as I can and would be very grateful to whoever is patient enough to read it and help me.

       

      I have an LG E500 laptop with the Mobile Intel(R) 965 Express Chipset Family display adapter.

      Operative system: Vista home basic 32 bit.

       

      It all started when I tried to play my Sims 2 game. I instaled it and when tried to run it I received this error message:

      "Failed to find DirectX 9.0c compatible graphics adapter in this system! Please make sure you have a DirectX 9.0c compatible graphics adapter and have installed the latest drivers provided by the manufacturer. This application will now terminate."

       

      I made sure I do indeed have DirectX 9.0c installed and then logged on to the intel site to download the latest drivers for my adapter. This did not solve the problem.

       

      I thought maybe this adapter does not support said game, but on the intel site it said it does.

       

      Then I read on some support site that this particular message can appear when some other program has changed the monitor's settings and that it can be solved by restoring said settings. I was not sure how to do that, so I thought I'll start with playing with the display's resolution.

       

      When I pressed the display settings button I was encountered with another error message the title of which was "Invalid Display Setting":

      "The currently selected graphics display can not be used. It was written for a previous version of windows, and is no longer compatible with this version of Windows.

       

      The system has been started using the default VGA driver.

       

      Please contact your hardware manufacturer to get an upgraded driver, or select one of the Microsoft provided drivers."

       

      In the display setting menu I discovered there were two monitor options to choose from. One is "Generic PnP monitor on Mobile Intel(R) 965 Express Chipset Family", and the other is "(Default Monitor) on Mobile Intel(R) 965 Express Chipset Family". On the Generic PnP one I could not change the resolution, whilst when I tried to change it to the default monitor, I receive the same error message and the Generic PnP is being set automatically back.

       

      Could this two problems be related, and is there a way to solve them?