0 Replies Latest reply on Jun 23, 2010 8:11 AM by michaelbruns

    Problems Compiling with Intel Fortran Compiler Professional 11.1.038

    michaelbruns

      Im having some difficulty compiling code written in fortran using the compiler from the command line. I want to take a number of modukles, and by compiling them and linking them, create a workable program. The programs were written for a earlier version of fortran, specifically I believe Lahey Fujitsu Fortran 95 v.5.7. They are all in the same folder, with modules with the suffix .for and .obj. Every .for has a corresponding .obj

       

      From the command line, I have tried compiling multiple programs using the command "ifort a.boj b.obj c.obj". it gives the error LNK1181, which is the same error it gives if there is no file with that name in the directory, which leades me to believe it is not recognizing the object files

       

      Also from the command line, trying to compile a .for will give me a multitude of error messages. most of these have to do with syntax, with these error numbers in the 6000 range. For instance, it will say ..... must be of character string or highest type allowed is integar. With some other files it will create a a.obj out of the a.for file, but will have unknown externals. This occurs trying to just compile one module alone.

       

      Im sorry for the vagueness, but it is not deliberate. I have just started on these programs and am not certain what they are all used for. My knowledge of Fortran is limited to syntax so any help at all would be appreciated

       

      Thank you