1 Reply Latest reply on Feb 7, 2008 4:54 PM by AlexPabst

    Using static IP addresses.

    rabinod@sunysuffolk.edu

       

      It comes down to this all my new computer are Gateway Model E4610 with DQ965MT chip set. The AMT version is  version: 2.1.3-build 1031 .

       

       

      From research to use static IPs , Both the OS and Intel AMT are set to use static addresses and they are different from each other, the MAC addresses are different, and the host names are also different. 

       

       

      Below I have read that there is some type of tool that will allow me to reconfigure the AMT to make two MAC addresses, or just use a different one. Where do I find this tool or am I missing something all together. When I discover the computer in LanDesk I never see the AMT MAC address, which make me think it 's the same one that Windows is using. I state it that way becuase of no other way to convey what I'm tring to say.

       

       

      Just for more information, I currently use LanDesk 8.7 SP4. I'm using small bus etc. I understand provisioning etc, but some things do not work and LanDesk is working on them, they are aware of the bug in their software, but under basic configuration I want to follow what I'm reading. If you want to laugh, it works best when the IP are the same, but the names are different, in refercne to LanDesk.

       

       

      Any helpwould be great.

       

       

       

       

       

      Here is the wording I'm reading

       

      *

      Tips for using static IP addresses

       

       

      Because Intel AMT devices have two components that are assigned an IP address - the Intel AMT chip and the device's operating system - you can potentially have two entries in your list of discovered devices for the same Intel AMT device. This happens only if you want to use a static IP address rather than using DHCP.

       

      *

       

      To use static IP addresses with Intel AMT devices, the Intel AMT firmware should be configured with its own MAC address. The Intel AMT R1.0 Aspenhill board is the only one that ships with this second MAC address already configured. For instructions on how to re-install the firmware and configure it properly, please contact Intel.

       

       

      Once configured, the Intel AMT device will have a different MAC address, IP address, and host name than the device OS. To be able to manage Intel AMT devices correctly, you need to use the following settings for DHCP and static IP addresses:

       

       

      DHCP: Both the OS and Intel AMT use DHCP and the host names are the same.

       

       

      Static IP: Both the OS and Intel AMT are set to use static addresses and they are different from each other, the MAC addresses are different, and the host names are also different.

       

       

        • 1. Re: Using static IP addresses.
          AlexPabst

          Hi there...

           

          I don't think you are missing anything, its more that the Landesk description below is not very accurate.

          As soon as you configure an AMT 2.* device to use static IP-mode it will automatically assign a second (different) MAC address to iAMT.  This is done automatically and there is nothing you can do (at least that I know of) to stop that behaviour.

           

          As soon as you switch back to DHCP mode however the OS and iAMT will share the same MAC and therefore also the same IP.

           

          You can easily check which MAC address your device has by using arp .

          Microsoft implemented this in a program called "arp" which you can run from the commandline. type "arp -a" to see a list of all IP/MAC pairs that your computer currently knows. Or use "arp -a IP_ADDRESS" to just look for one entry.

          If the list does not contain the AMT device simply ping it so windows performs an ARP lookup on it.

           

          Regarding your Landesk setup:

          I am not an expert in this, but at least according to the iAMT specs you are "not allowed" to set iAMT to static mode and then use the same IP in iAMT and on the OS. This will not do any harm, it might however lead to unpredictable results.

          I am not entirely sure how Landesk handles the name resolution of the clients. If it uses Netbios name-lookups (this is what windows uses) then it might rely on an OS running on the system (this is a guess). When using static IPs however with different ones configured for the OS and iAMT it will seem to Landesk as though it is dealing with two different systems which might make discovery more difficult.

          I suggest you work with Landesk on that issue, as they are most likely to know the answer (and can possibly even poke Intel directly for help).

           

          I hope this does help more than it confuses you!

           

          Alex