3 Replies Latest reply on Jul 15, 2013 10:50 AM by Diego_Intel

    D945PSN - 4 x 1GB Memory Installed But BIOS Showing 2GB - System Hangs

    idossa

      Hello Everybody,

       

      I have the D945PSN Motherboard and recently tried upgrading the 2GB (2 X 1GB) memory to 4GB (4 X 1GB). I have ensured that the memory was listed as tested on the Intel site before purchasing. It is the Kingston KVR667D2N5/1G (if that helps). When I try to startup the system with 4GB installed it hangs after displaying the Intel splash screen (POST). I just get a blank screen. As soon as I remove the new memory, everything boots up ok. I tried swapping the old memory with the new and again the computer will boot up as long as only two memory sticks are installed. I have also tried putting the old memory back in, in the new empty slots and again it froze.

       

      I was able to get into the BIOS. When I go to Memory Configuration I can see that all four slots are being used (each slot shows 1024MB). But just above it, it says Total Memory 2048MB.

       

      I thought that there may be some small difference between the old memory and the new memory, so I had purchased 2GB (2 X 1GB) more to test, but still the same results. The system will hang with anything more than 2 GB. I tried removing one stick for a total of 3 GB but still the same result.

       

      The only other component (card) installed is an ATI X800 PCI-E graphics card in the computer.

       

      Could the graphics card be causing this issue? The only other thing I can think of, was that I recently flashed the BIOS to the latest version. Wondering if there could be a bug with the latest BIOS. Any suggestions?

       

      Thanks.

        • 1. Re: D945PSN - 4 x 1GB Memory Installed But BIOS Showing 2GB - System Hangs
          sflesch

          Did you ever find a solution? Two years later and I am now seeing a similar issue. On the Main screen, the BIOS reports 2x1GB sticks in Channels a & b, slot 0 but reports nothing for slot 1. Total Memory = 2048. Undeer memory configuration, the BIOS shows all 4 slots with 1024 each, but Total Memory = 2048 again. Windows 7 (64-bit) reports 3.25GB to top it all off. I have BIOS 108. I also can't seem to do the Windows Experience Index either. Stuttering in Netflix. All after several scratch loads.

          • 2. Re: D945PSN - 4 x 1GB Memory Installed But BIOS Showing 2GB - System Hangs
            Jose.A.T.G

            Hi everybody!

             

            I think I have the same problem with RAM memory . The desktop board is D945PSN.

            I have installed three 1GB-module (total 3GB), but in the BIOS screen I get the following:

             

            Total Memory: 2048MB

            Memory Mode:  Single Channel

            Memory Channel A:

               Slot 0: 1024MB (DDR2 667) SPD: 5.0-5-5-15

               Slot 1: 1024MB (DDR2 667) SPD: 5.0-5-5-15

            Memory Channel B:

               Slot 0: 1024MB (DDR2 667) SPD: 5.0-5-5-15

               Slot 1: Not Installed

             

             

             

            But when I start Windows (XP), and go to System Properties, it shows me 3GB of system memory!

             

            Thank you.

            • 3. Re: D945PSN - 4 x 1GB Memory Installed But BIOS Showing 2GB - System Hangs
              Diego_Intel

              Please bear in mind that this product has reached its End of Interactive Support so Intel no longer provides interactive support for this product via telephone, chat or e-mail.

              The issue you report, seems to be a BIOS related bug, so you can try updating the system BIOS again and see if this works.

              Anyhow this seems to be cosmetic as the total amount of memory is properly reported once the operating system boots.

              The latest BIOS is posted at:

              Download Center