12 Replies Latest reply on Jun 21, 2010 3:13 PM by fgaullier

    DX58SO LAN Asleep at the Wheel

    dw1

      After installing the latest (May 2010) BIOS & driver updates for the DX58SO board, every time the computer wakes from sleep the LAN won't reconnect and reports that the "MEDIA IS DISCONNECTED"! Consequently, the only way to reconnect the NIC is to reboot the system!

      Anyone have a similar issue? Suggestions as to remedy? The new LAN driver initially downloaded as a "corrupted" file that would not unpack! After that issue was resolved, this problem started! It is I think possible that the current issue is either BIOS or chipset driver related as I was having the same issue with the old LAN driver before I was able to install the latest and greatest!

      Any assistance or suggestions will be greatly appreciated!

      Thank you

      dw witless

        • 1. Re: DX58SO LAN Asleep at the Wheel
          iobe

          I have the same problem. I just bought this board though and haven't tried with any other BIOS/drivers than the latest.

           

          I believe this question is about the same problem: http://communities.intel.com/message/94194#94194

          • 2. Re: DX58SO LAN Asleep at the Wheel
            Apota

            Well, I have the same problem.  I've had the motherboard for like 3 months and it worked fine.  I had Windows Vista Ultimate 32-bit installed for that amont of time with no problems.  I installed Windows 7 Ultimate 64-bit last week and started having this problem.  Before I installed Win7 I did update the bios to the latest version, but I'm not sure what version I had before.  It was either 5112 or 5200 I think.  Right now it's 5314.  I also had the problem with the LAN 15.3 driver where it was telling me it was currupt when I tried to install it, but eventually they fixed that issue. I also installed the latest of the INF file, but I don't think that can be the issue.  I don't see how the issue could be the INF or chipset driver.  I know the problem isn't the LAN driver, because I uninstalled the Intel LAN driver and let Windows install the default driver and I'm having the same problem and the Intel LAN driver isn't installed anymore.  I also connected a 2Wire USB wireless LAN adapter to my computer and the problem when away.  So, it seems to be an issue with the BIOS.  I've emailed Intel but they have been of no help so far, and seen to have no clue about the issue.  Maybe I'll need to call the and see what they say, but I think I'll try installing earlier BIOS and see if that fixes the problem.

            • 3. Re: DX58SO LAN Asleep at the Wheel
              Apota

              Yep, that fixed it. I installed the bios that was in my motherboard 3 months ago 5020 because I knew that worked before.  Then the problem went away.  So, it's a bug in the new 5314 firmware.  Now that I know it's a firmware issue and the earlier one works I'll install newer versions and test them.  So, I'll try 5200 and if that doesn't work I'll go down to 5112 and if that doesen't work I'll go back to 5020 until they work out the bugs and issue a new version.

              • 4. Re: DX58SO LAN Asleep at the Wheel
                iobe

                Great, I'll try downgrading the BIOS too when I get home tonight.

                 

                Would be nice if Intel could fix this or at least acknowledge the problem.

                • 5. Re: DX58SO LAN Asleep at the Wheel
                  Apota

                  Well, I just installed 5200 and it works too, so that seems to be the latest that works, so I'll just stick with that version until Intel fixes the bug in 5314 and issues a new bios update.

                  • 6. Re: DX58SO LAN Asleep at the Wheel
                    iobe

                    I tried the 5200 BIOS too now, and it works after sleep!

                     

                    Good job

                    • 7. Re: DX58SO LAN Asleep at the Wheel
                      dw1

                      Yes, as noted in the various replies, the solution to this particular bugaboo is to "downgrade" the BIOS to 5200! I discovered that after spending a frustrating day or so back and forth with Channel Tech Support who insisted that the problem could not possibly be with Intel's upgrade software as "we would have received thousands of complaints" about the issue by now! I was told that the proper resolution of the matter required re-installation of the OS (Win7 x64)! This after uninstalling and reinstalling the LAN drivers back to 14.8.

                      Recalling 1.) an earlier post (from last fall I believe) about a similar issue (no LAN after sleep) that was resolved (in that instance) by upgrading the BIOS and 2.) that reinstalling Windows is about as much fun as anticipating a frontal lobotomy, I chose to downgrade the BIOS to see what would happen! Lo and behold, will wonders never cease! It worked and the LAN (15.3) now reconnects after sleep!

                      For all you geekoids out there, I was also told by Channel Tech that unless I am trying to resolve a specific problem, if all is well with my system, there is no need to update any drivers/BIOS and it should never be done! Thanks, to all you responders!

                      ... and a well placed tip of the ole tophat to Channel Tech!

                      • 8. Re: DX58SO LAN Asleep at the Wheel
                        fgaullier

                        I have the same problem too. Went to the latest BIOS and LAN driver, and the LAN does not wake up from sleep on Win7 64bit. But now I can't even go back to an other driver as the system goes bezerk and does not allow me to change the driver, and when I check the LAN driver, I get an system error window. Help!! do you have a fix for this? do I need to go to an older BIOS, how can I install a LAN driver???

                         

                        Please help.

                         

                        Francois.

                        • 9. Re: DX58SO LAN Asleep at the Wheel
                          iobe

                          @fgaullier:

                          Yes, going back to BIOS version 5200 seems to fix the sleep problem.

                           

                          I can not help you with the LAN driver problem. All I know is that you do not need to change it - the issue is in the BIOS.

                          • 10. Re: DX58SO LAN Asleep at the Wheel
                            fgaullier

                            Thanks, going back to 5200 doe fix the problem. I was able to re-install the driver that was all screw up, and it seems to work. the only issue is that ther is a "#2" appended at the end of the description of the LAN card. There is no "#1# and before there was no thing at all.

                            Hope they will fix the BIOS issue one day. I am still fighting an other Intel bug with the RAID on an other mother board. Too many bugs in Intel software these days!!

                            Francois.

                            • 11. Re: DX58SO LAN Asleep at the Wheel
                              Apota

                              Well, that's because you probably installed the driver a few times, so there is more then one copy in there.  The other copies are probably hidden.  You can see those hidden copies and delete them and reinstall the driver if it really bugs you, but you really don't need to do it.  There is an option in Device Manager under View that allows you to see hidden devices.  Just check click on that and you can probably see them now.

                               

                              I guess there was a driver issue too for some people, but the bios fix worked for me by downgrading the bios.  Here is the email reply I got from Intel for people in the future.

                               

                              Thank you for contacting Intel Customer Support.

                               

                              I understand the LAN adapter turns off after the system comes back from sleep mode on Windows 7*.

                               

                              In this case, we will recommend you testing the system with BIOS version 5200. Please perform a BIOS recovery to do the update. The file can be found at: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18938&ProdId=3018&lang=eng

                               

                              For BIOS recovery instructions, please refer to: http://www.intel.com/support/motherboards/desktop/sb/CS-023360.htm

                               

                              If the issue persists after using BIOS version 5200, please try using the LAN driver version 14.6. You can find this driver at:

                              http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18196&ProdId=3018&lang=eng

                               

                              Message was edited by: Apota

                              • 12. Re: DX58SO LAN Asleep at the Wheel
                                fgaullier

                                Apota, thanks, it seems to be working with the 5200 BIOS.

                                 

                                Francois.