8 Replies Latest reply on Sep 23, 2011 9:08 AM by kp1572

    NIC teaming not happening on Forefront TMG server

    christopher.jrc

      I tried teaming a pair of NICs on a Forefront TMG server and was unsuccessful.

      Is there any property that I should disable to make it work. Without TMg teaming works fine.

        • 1. Re: NIC teaming not happening on Forefront TMG server
          Dan_O

          What kind of server board does it have in it, and what kind of NICs?  You have to have at least one server NIC to set up a team.

           

          Did it give you any error message when you tried to set it up?  Are you configuring it locally, or remotely?

          • 2. Re: NIC teaming not happening on Forefront TMG server
            christopher.jrc

            Creating team fails in the function Apply(). It fails while spawning IN parameters

             

             

                               'Spawn IN parameters for 'Apply'.

                                     Dim objInParams : Set objInParams = NetServiceObject.Methods_.Item("Apply").InParameters.SpawnInstance_()

                                'Handle failure to spawn in params

                                     If Not IsObject (objInParams) Then

                                          sReturn = "Unable to spawn in parameters of Apply() method"

                                          Apply = False

                                          Exit Function

             

            • 3. Re: NIC teaming not happening on Forefront TMG server
              Dan_O

              Which board and NIC are you using, and what's the failure message?  The more context you have, the easier it is to figure out where the problem might be.

              • 4. Re: NIC teaming not happening on Forefront TMG server
                christopher.jrc

                I get the error message "Applydone failed" followed by "Creatiung New Team failed".

                 

                NIC : Intel(R) 82574L Gigabit Network Connection

                 

                I guess NIC is not the issue. I am able to create a team with just Wondows Server 2008 R2 Standard alone installed. I see the issue only when If Forefront TMG is installed.

                • 5. Re: NIC teaming not happening on Forefront TMG server
                  christopher.jrc

                  Forgot to mention this. The followingerror is displayed in the Event Viewer -> Application logs.

                   

                  Faulting application name: NCS2Prov.exe, version: 14.8.30.0, time stamp: 0x4ad67752

                  Faulting module name: netcfgx.dll, version: 6.1.7600.16385, time stamp: 0x4a5bdfe5

                  Exception code: 0xc0000005

                  Fault offset: 0x0000000000025a2b

                  Faulting process id: 0xba0

                  Faulting application start time: 0x01cafc9de5f4d129

                  Faulting application path: C:\Program Files\Intel\NCS2\WMIProv\NCS2Prov.exe

                  Faulting module path: C:\Windows\system32\netcfgx.dll

                  Report Id: 3a28b571-6891-11df-a4a3-00900b14b436

                  • 6. Re: NIC teaming not happening on Forefront TMG server
                    Dan_O

                    Is Forefront TMG an application or service that runs under 2008?  If it works fine in basic 2008 R2, but fails with an additional software application, I'd double-check the compatibility list for that software application, and see which NICs it supports.

                    • 7. Re: NIC teaming not happening on Forefront TMG server
                      christopher.jrc

                      TMG is an application that has five services and as such is compatible with the NICs. Once installed, it also binds a protocol called TMG Packet Filter to all the network interfaces. So I guess, when we try to create a team, all the protocols are unbound from the respective network interfaces and this is where it fails. We CANNOT unbind the TMG Pakcet filter protocol from a network interface manually or programmatically.

                       

                      After the statement "Set OutParameterObj = IANet_TeamOfAdapters_Def.ExecMethod_("CreateTeam", InParameterObj, 0, oValueSet)"

                      the value of OutParameterObj.TeamPath is "".

                       

                      I uninstalled TMG and after that I was able to create a team without any issues at all.

                      • 8. Re: NIC teaming not happening on Forefront TMG server
                        kp1572

                        Hi,


                        I know this is late, but the reason why its almost impossible to team adapters when TMG is installed is because TMG "owns" the NIC. To get around this try unchecking the IPv4 and IPv6 protocols on the NICs you want to team and then reboot the computer. After it has come back from reboot you should be able to team NICs successfully. On the logical teamed NIC disable NLB and reboot again.


                        If the above is not clear go to: http://www.8net.co.uk/uag-tmg-and-nic-teaming/

                         

                        Kind regards,

                        Pritesh Patel