5 Replies Latest reply: May 18, 2010 10:25 PM by edwardzh RSS

Raid not visible on S3420

GerhardKreuzer Community Member
Currently Being Moderated

Hi,

Just try to bring up (my first) server and want to have 2 x 500GB Samsung SATA II drives for a Raid 1. Sounds quite simple.

Configure this as Intel Matrix ... after loading the config utility from the Intel CD, ... Config Raid button disabled ??

Configure this as ESRT2 .... after loading the config utility from the intel CD   Config Raid button disables ??

During boot, pressing Cntrl E to enter the embedded ESRT2 menu, configuring a Raid 1, works, but ...

after loading the config utility from intel CD ... Config Raid button disabled ??

Ignoring that issue and set up OS as Windows Server 2008.

Booting the Windows installation CD, Windows loads, asks something usual and tells me, there is no driver for the DVD.

But the Intel config utility former asks me to provide a USB stick, I think, for providing exactly this drivers during windows installation.

 

Now I hang.

 

Please tell me:

 

How can I make the raid visible to the intel utility and to windows

How can I provide the correct drivers for Windows Server 2008

 

Or is the on board raid cust for nothing?

 

Thanks for helping.

 

Gerhard

  • 1. Re: Raid not visible on S3420
    edwardzh Community Member
    Currently Being Moderated

    Gerhard ,

    The IDA CD doesn't support Matrix RAID, but it should support ESRT2... But anyway, since you've configured RAID in Ctrl-E already, there's no need to configure RAID in IDA.

     

    Now for Windows 2008, you'll need to load RAID driver. But the error you're getting seems relate to your DVD-ROM drive. What kind of DVD-ROM are you using?

  • 2. Re: Raid not visible on S3420
    GerhardKreuzer Community Member
    Currently Being Moderated

    Hi Edward,

     

    here the whole story:

    I also think, that configuring the raid in BIOS is ok and went on installing. But every time windows want to get something from CD it fails.

    Now I start thinking, and I guess my CD is ok, because it works on other machine. It could be the drive or something very basic.

     

    What I don't understand is, why is the CD-drive part of the raid? I get a list of raid drives and the CD drive was always in, also the BIOS Boot Option menue sees a 'Raid DVD Drive'??

     

    Now I guess, windows will be also astonished and therefore stops working.

     

    I also found out, that the BIOS detects the USB stick as a bootable device, so I go on using a externel DVD drive on a USB port holding my windows DVD.

     

    But, ...

     

    As I try to boot and this time I cant't read the original intel cd.

     

    I stopped that, went to sleep and start next day searching on Intels web site for an new image, I found 3.5.3. I made my own CD and boot up, wow, works and .... suddenly I found some raid. Intresting, isn't it? I dont't change the BIOS setup inbetween!!!

     

    I try install windows again, but using the built in DVD drive, hoping, that the new version of the Intel CD contains new driver and utilities, solving my problem.

    Indeed, the list of drivers found was double in length, containing a raid!! and something else.

     

    But ...

     

    Windows fails at the same point, but telling me, that some partitions were created... hu.

     

    Ok, plan B, external USB DVD drive holding Windows ...

     

    Heureka, that was it.

     

    Funny, that after finishing the whole installation process, the internal (raid) DVD was present again and works well for further application installations.

     

    It seems, that there is a minor issue with the drivers for the raid, so windows cant't use this DVD drive during the installation phase. Unfortunately, this is a serious point to get the machine up.

     

    Whith best regards

     

    Gerhard

  • 3. Re: Raid not visible on S3420
    edwardzh Community Member
    Currently Being Moderated

    Which RAID driver did you use?

  • 4. Re: Raid not visible on S3420
    GerhardKreuzer Community Member
    Currently Being Moderated

    Hi Edward,

    I just do it with the utility I get with the board 'Server Deployment Toolkit' but instead of version 3.5 which doesnt detect any raid and doesn't provide any driver to the OS the version 3.5.3 I downloaded from the Intel site recognizes the ESRT2 raid and provides drivers for my Server 2003 R2 (which ever).

     

    The problem with the DVD drive, appearing a part of the raid was still the same in 3.5 and 3.5.3, but with an external drive on USB it was solved.

     

    There must be something wrong with the DVD at all, because using this drive by an virtual server runs very slow, even 10 times slower than normal (in virtual systems!). This time I use some shared DVD drive from another machine over the network, works fine.

     

     

    Another question. I have solved some other issues with my installation and want to went on with Windows Server 2008 R2, so I have to start from the very beginning, but no problem. Should I use matrix raid or ESRT2 raid for the final solution?

    As I wrote the board is a S3420GP, 4GB RAM and two Samsung SpeedPoint drives for the moment which should build a raid 1.

     

    Thanks for helping

     

    Gerhard

  • 5. Re: Raid not visible on S3420
    edwardzh Community Member
    Currently Being Moderated

    I assume you were using a SATA DVD-ROM drive right? Since it's also controlled by ESRT2 when you have RAID enabled, so you'll need to load ESRT2 driver from a USB drive. I have tested the latest drive and it worked well in Windows 2008. You can find the driver here:

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18265

     

    You may also want to use a tested DVD-ROM drive to avoid compatibility issues. The list can be found here:

    http://www.intel.com/support/motherboards/server/s3420gp/sb/CS-030737.htm

     

    For Windows 2008 R2 the ESRT2 driver is already embedded so you don't need to load it during installation. But I'd still suggest you update to latest version.

     

    For the difference between Matrix RAID and ESRT2, the main advantage of Matrix RAID is that it supports RAID 5, but no Linux support for Matrix RAID. Since you're doing RAID 1 in Windows, there's not much difference in function. But personally I'd suggest ESRT2 because it uses same management UI with Intel hardware RAID controllers, and you get features like remote management, email alert, etc.

More Like This

  • Retrieving data ...