1 2 Previous Next 16 Replies Latest reply: Dec 6, 2007 1:39 PM by joelsmith RSS

Have you seen this error? - Altiris

rdettl Community Member
Currently Being Moderated

Anyone resolved this issue before?  Any ideas?

When trying to utilize OOBM component with Altiris we ran up against the below errors (screen capture below):

h6. Error connecting to the Intel AMT Setup and Configuration Server.  Verify that Intel AMT Setup and COnfiguration Server security settings are configured and AMTConfig service is running.  See documentation for details on troubleshooting the Intel Setup and Configuration Server installation.

The connection with the server database has been lost.
h6. Current user can't view this page.
h6. Current user can't change setting on this page.

 

We tried various solutions throughout the day which included:

 

https://kb.altiris.com/article.asp?article=38810&p=1 - The SQL instance is running in mixed mode - NO work

 

 

Out of Band isn't a licensed product and has no enforcement mechanism so we enabled trace logging per the instructions in this link https://kb.altiris.com/article.asp?article=34418&p=1  Details:

 

  1. Go to Start > Run, type Regedit, and click OK.

  2. Browse to HKEY_LOCAL_MACHINE > SOFTWARE > Altiris > eXpress > Notification Server > ProductInstallation > {09954bad-a09c-43ce-b8ad-407b6b93c936}.

  3. Create a DWORD value named TraceLevel.

  4. Set the value at 255 Decimal, FF hex.

  5. Download dbgview.exe (DebugView from Sysinternals/Microsoft) from http://www.sysinternals.com/ (you'll be redirected to Microsoft), click into the Miscellaneous section, and download Debugview.

  6. Execute dbgview.exe.

  7. Now walk through the function you wish to capture trace level logging on.

  8. The debug windows should fill up with entries.

  9. Use the Save command when trace logging in complete.

 

Sent the output to Altiris.  They recommend we reinstall OOBSC with the below process...didn't work.

 

 

Here is the process recommended by Altiris:

 

  • 1. From Add/Remove Programs uninstall: ‘Intel Active Management Technology Setup and Configuration Service'.

  • 2. Now on the Notification Server, log in as the user who you will set as the main account for Intel SCS.

  • 3. Browse to the following location: NS Install Path\Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\OOB\IntelSCS\

  • 4. Launch the file AMTConfServer.exe.

  • 5. Walk through the setup (During the IIS setup there is a check-box for HTTPS, uncheck this).

  • 6. When complete, restart IIS (Start > Run > type: iisreset > Click OK).

 

Between all this troubleshooting we also installed intel's SCSConfServer.exe manually.  We logged in and it works - we could provision systems, but w\o a Altiris it doesn't matter.  Any ideas?

 

 

 

 

  • 1. Re: Have you seen this error? - Altiris
    josh.hilliker Community Member
    Currently Being Moderated

    Another add is that we validated through Intel AMT SCS console that we had good connectivity to the SCS DB (i.e. IntelAMT table in SQL).

  • 2. Re: Have you seen this error? - Altiris
    wryork Community Member
    Currently Being Moderated

    I'm not familiar with Altiris but from my experience with SMS/SCS, I would start looking at the SCS User groups to see if the logged in user to Altiris (or the Altiris Service if there is one) has been added to SCS as an Enterprise Administrator.  With SMS addon, you install the addon as a service with a given service account.  You list this service account in SCS as an Enterprise Administrator and this allow the SMS addon to access SCS.

  • 3. Re: Have you seen this error? - Altiris
    slpanora Community Member
    Currently Being Moderated

     

    Have you stopped and restarted the AMTConf service to verify that it is running properly?

     

     

    Are you running the latest versions of Altiris with the Altiris SCS installer?

     

     

  • 4. Re: Have you seen this error? - Altiris
    AlexPabst Community Member
    Currently Being Moderated

     

    On that note, after you restart the service check the system eventlogs for any errors. I have found the errors in there incredibly useful whenever I had problems.

     

     

     

     

     

    Alex

     

     

  • 5. Re: Have you seen this error? - Altiris
    slpanora Community Member
    Currently Being Moderated

    Exactly.  It sounds like Altiris is not communicating with the SCS service to provision properly.  It may be something as simple as who the "log on to this service as..." is set to.

  • 6. Re: Have you seen this error? - Altiris
    rdettl Community Member
    Currently Being Moderated

    I will try and retry some of these suggestion when at the customer site Thursday\Friday...thanks.

  • 7. Re: Have you seen this error? - Altiris
    RobD. Community Member
    Currently Being Moderated

     

    We are having the exact same issue trying to get this to work with Altiris. Tried the reinstall. Getting the error below near the end of the install:

     

     

    LaunchAppAndWait failed!

    Failed to add login user

    Error code: 104

     

     

     

     

    SQL 2000 on Windows 2003 SP1.

     

     

    SQL authentication is set to mixed, using the app identity for the Altiris service to be the AMT service.

    After install the AMTConfig service is started and running.

     

     

    In the application event log, there are the following errors:

     

     

    Type: Error

    Source: AMTConfServer

    Event ID: 1001

    Event Time: 12/5/2007 12:49:12 PM

    User: n/a

    Computer: AltirisNS

    Description:

    The connection with the server database has been lost.

     

     

    AND

     

     

    Type: Error

    Source: AMTConfServer

    Event ID: 1001

    Event Time: 12/5/2007 12:58:22 PM

    User: n/a

    Computer: AltirisNS

    Description:

    User DOMAIN\AltirisService does not have the privileges required to execute the SCS Server.  Startup aborted.

     

     

    Any ideas? This seems to be a pretty simple install. No idea why it keeps bombing.

     

     

  • 8. Re: Have you seen this error? - Altiris
    AlexPabst Community Member
    Currently Being Moderated

     

    Rob, I might be stating the obvious here (as usual), but are you sure that both, the user installing the SCS addon as well as the AltirisService user have got the permissions they need?

     

     

    I think the useraccount running SCS has to be a local admin (at least). If that's the case, check whether the AltirisService user has got permissions on the SCS database. (You should be able to see this using the MSFT SQL server manager or some tool like that.)

     

     

    If that seems ok as well, check the scs-Users table and see whether  AltirisService is in there as an EnterpriseAdmin.

     

     

    I remember having the same error (with the SCS-Server for SMS) at some point, but can't remember how I solved it

     

     

     

     

     

    Alex

     

     

     

     

     

  • 9. Re: Have you seen this error? - Altiris
    RobD. Community Member
    Currently Being Moderated

     

    Alex, I don't know for sure what permissions are needed where, I agree with you that it seems some permission is wrong.

     

     

    When I check the database entries, my account and the Altiris service are both listed as CSR_SYSTEM. In the Roles table CSR_SYSTEM is listed as Enterprise Administrator. And the Altiris Service is a local admin on the machine and I even set it to be the dbo on the IntelAMT database but that didn' t work either.

     

     

    Maybe you could submit to hypnosis and we could recall that memory of how you fixed it? ?:|

     

     

     

     

     

  • 10. Re: Have you seen this error? - Altiris
    rdettl Community Member
    Currently Being Moderated

     

    Today we spent some time with Altiris 3rd level support.  Tomorrow we are resuming the installation with the below resolution attempts.  We also go the 104 error when trying to complete the manual SCS install under the Altiris Service account shown above.  I will update again tomorrow.

     

     

    .Troubleshooting with Altiris:

     

    • Deleted the Intel AMT Database

    • Deleted the Altiris Components needed for AMT hosts.

    • Reinstalled under Altiris Service account instead of user admin account.

     

    After 10 minutes the Altiris silent install fails showing the SCS installed failed.  Inside the _scsinstall.log file the contents show...

     

     

    Re: Have you seen this error? - Altiris

     

     

    Version=v7.00

     

     

    File=Log File

     

     

    Re: Have you seen this error? - Altiris

     

     

    ResultCode=-3

     

     

    Re: Have you seen this error? - Altiris

     

     

    Name=Intel® Active Management Technology Setup and Configuration Service

     

     

    Version=3.0.2.6.1

     

     

    Company=Intel

     

     

    Lang=0009

     

     

    The following message may be seen in the Setup.log file when installing a package silently using an .ISS file and a locked file is encountered:

     

     

    ResultCode -3

     

     

    Meaning, 'Required data not found in Setup.iss file.'

     

     

    Altiris support confirmed previous case opened with this problem.  Tomorrow morning we are going to try the below resolutions with Altiris.

     

    • Stop IIS service during the Altiris install

    • Close all SQL enterprise console. Customer confirmed he had SQL console during installation.

     

     

     

     

  • 11. Re: Have you seen this error? - Altiris
    josh.hilliker Community Member
    Currently Being Moderated

    Rob.  check out the info from the last post from ryan..  if this works please let us know.

  • 12. Re: Have you seen this error? - Altiris
    cmpierce1 Community Member
    Currently Being Moderated

     

    Seems like I had this problem when I setup this config earlier this year.  I had 3rd level Altiris working with me and it turned out to be a corrupted DB.  We removed and readded and we were able to provision.

     

     

    CMP

     

     

  • 13. Re: Have you seen this error? - Altiris
    AlexPabst Community Member
    Currently Being Moderated

     

    I have got one more idea....

     

     

    How large is the active directory that your are trying to install SCS in?  I have seen the SMS-SCS installer hang for up to half an hour when validating users in large (1Million objects+) ADs. This would in turn lead to a timeout of the Altiris installer script.

     

     

    However the last version I used was SCS 3.0 so I am not sure this problem still exists in the current version.

     

     

     

     

     

    Alex

     

     

  • 14. Re: Have you seen this error? - Altiris
    rdettl Community Member
    Currently Being Moderated

     

    All problem was solved this morning with Altiris 3rd Level support.

     

     

    In short: Altiris SCS Silent install does not work with SQL Server 2000.  Problem was identified using a script called AddLogontoDB.bat script sent by Altiris.  Solution was deleting a registry key HKEY_LOCAL_MACHINE>SOFTWARE>INTEL-->AMTCONFSERVER then reinstalling SCS manually using the Altiris service account.  Apparently, after performing an SCS uninstall w\Reboot, it doesn't remove every associated key in the registry.

     

     

    I will post the official fix from Altiris and full details later today.  Thanks for all your ideas and help.

     

     

1 2 Previous Next

More Like This

  • Retrieving data ...