3 Replies Latest reply on Oct 5, 2018 12:09 PM by mike2021

    Intel ME Firmware Downgrade attempt resulted in EndUpdate Error 0x00002225

    mike2021

      What happens if a downgrade of Intel ME firmware is attempted?    Shouldn't  it refuse or skip the Intel ME downgrade part  (instead of seeming to downgrade, and then just erroring out)?

      I had a Dell bios that I attempted to downgrade,  and along with it came a Intel ME firmware packaged inside.

       

      Does that error just mean it "skipped it"?

       

      I got the following displayed on the screen:

      A)    Sending Intel(R) Management Engine Firmware Update    [0 **********  100% finished]         <--- This part took like 20 or 30 seconds

      B)    Waiting for the Intel(R) ME FW Update to complete    [0 ********* 100% finished]        <---  This part took another 20 or 30 seconds

      C)    ME Firmware EndUpdate failed Error: 0x00002225     (progress bar made it to 100% then displayed this error)         <---  This was the result of the update

      [then it proceeded to finish updating my Dell Laptop with Dell specific firmware, unrelated to Intel ME]

       

      (I mention 20 or 30 seconds to indicate it was actually "doing some sort of writing / saving")

       

      Upon completion,  the INTEL ME firmware STILL seemed to have the unintended NEWER firmware version instead of the intended older firmware.    That somewhat makes sense if it refuses to downgrade, but why did it even attempt to do Step A and Step B above   (it could just inspect version numbers like it does when trying to over-write the latest on top of the latest)?

       

      So, if it has the "ability" to recognize that it's already on one that is already equal to the one attempting to be loaded (which it does seem to be able to do),      shouldn't it be able to detect that it's already on a version number that's greater and not even try to do Step A & B above as well?   

       

      Originally I thought it failed with the Endupdate Failed Error: 0x00002225 because it prevents a downgrade,  but again if it spent about a minute with step A&B above it seemed to have been doing something.

      Whereas when I tried to load the already existing firmware overtop of itself (on purpose) earlier,  it spent 0 seconds doing so;  clearly indicating it had no need to and skipped it.

       

      IMPORTANT QUESTION:

      Is there anyway to ensure the Firmware can be loaded with the latest (same version it already seems to have since my downgrade failed ) without errors to ensure there are no latent problems with my failed downgrade attempt?

      If I try to load the latest,  it just skips the Intel ME firmware portion because I guess it thinks it already is on the latest Intel ME firmware (which I'm wondering if it actually is since it seemed to have sent and "saved" data when I tried to downgrade;  so I'm wondering if the version label is incorrectly stating it's on the latest, but the actual contents of the bios might be partially the older firmware).

       

      I would assume even though you can't "downgrade"....  wouldn't there be a way to just load the current newest on top of the current newest (to ensure a good error free copy of the already newest it thinks it's on but might be corrupted) ?

      One thought I had was perhaps if I attempt to install the same latest Dell firmware package twice in a row and it's not a "downgrade" per se,  then that would trigger a reasonable logic of "it's not technically a downgrade, and the two times trigger has been hit, therefore "refresh" the latest) --- something like that.

       

      Thanks for responses in advance..

       

      N.Scott.Pearson    (mentioned this username because of his response in this thread:  How can i downgrade my intel ME firmware version?  )

       

      Edit:  At all times, I'm only using Dell Bios .exe download files to upgrade and downgrade anything in my firmware (the Intel ME Firmware is part of a sequence of a Dell Firmware file when that runs in sequence).

        • 1. Re: Intel ME Firmware Downgrade attempt resulted in EndUpdate Error 0x00002225
          mike2021

          One more thing....

           

          My system does seem to boot, and function properly so far.     Not sure if that might be because I'm not using aspects that would be affected by a corrupted ME or if indeed the downgrade never even occurred;    or if it's because I'm booting in Legacy mode or something..    Also,  Not using Windows, just Linux;  never really used any ME functionality.

          I've just somewhat understood that ME is important to be able to boot, etc..

           

          Essentially, I'm just worried about some latent problems from the EndUpdate failed error: 0x00002225

          • 2. Re: Intel ME Firmware Downgrade attempt resulted in EndUpdate Error 0x00002225
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hello mike2021,

            Thank you for joining this Intel Community.

            Unless your system/motherboard manufacturer provides a way to downgrade the Intel® Management Engine firmware on your system, you should not attempt to downgrade it.

            To get more information about downgrading/updating the Intel® Management Engine firmware, please contact your system/motherboard manufacturer since performing these steps may cause system instability. 

            Wanner G.
            Intel Customer Support Technician
            Under Contract to Intel Corporation

            • 3. Re: Intel ME Firmware Downgrade attempt resulted in EndUpdate Error 0x00002225
              mike2021

              Thanks for your reply.

               

              I should have mentioned,

               

              I'm using the Dell bios download .exe files.

               

              I called Dell and asked them if you can downgrade and upgrade my bios bios, and they (supervisor level) said yes.    I've also found numerous comments on forums discussing testing or reverting a previous bios if there is a problem with a newest one.

               

              I should define a "Dell Bios .exe" file to seem to be a "package" of 3 sections  that automatically run in a sequence :

                   * "System Bios", 

                   * "Intel ME Firmware"     <=== This section worked to upgrade,   Gave a failure mentioned in my first post when downgrading,   then seems to "skip" this section entirely when trying to ensure I'm on the latest version

                   *  "EC Bios"

               

              At all times, I'm only using Dell Bios .exe download files