8 Replies Latest reply on Oct 1, 2018 12:00 PM by Intel Corporation

    No compatible disk for Intel Optane

    ARANDIR

      Hi

       

      My specs:

                    i5-7400

                    MSI B250 PRO-VD

                    SSD boot drive - GPT

                    Set to UEFI in BIOS

                    CSM disabled

                    RST enabled

       

      All drivers are updated. Over 50MB unallocated space on every drive. Intel Optane aplication said: "No compatible disk for Intel Optane". Intel Rapid said that optane module was not found. But System Support Utility can see Optane. Please help me. I've checked every single topic for Intel Optane. It supposed to be: insert, instal app, reset PC twice and done.....and i'm struggling with this for days....

        • 1. Re: No compatible disk for Intel Optane
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi ARANDIR,

          Thank you for posting in the Intel® communities.

          I can see from the report file attached that indeed, the Intel® Optane™ Memory is recognized by the system, however it’s not recognized as an NVMe* device. I have seen this behavior when either the module is not connected in the correct M.2 slot or the remapping setting in BIOS has not been enabled.

          According to your motherboard’s specifications available here: https://www.msi.com/Motherboard/B250M-PRO-VH/Specification, there is only one M.2 slot available so there is no other option here. Just an important note that this slot shares bandwidth with the SATA2 port, so make sure you don’t have anything connected in the SATA2 port.

          Let try the other possible root cause which is the remapping setting in BIOS, hopefully this is what you are missing in the settings. In BIOS, make sure you have configured the following settings:

          1. SATA Mode: RAID/Optane Mode
          2. M2_1 – RST PCIe Storage Remapping: Enabled
          3. Use RST Legacy OROM: Disabled
          4. M.2/Optane Genie: Enabled
          Please check and confirm all these settings are properly set, especially the remapping setting.

          I’ll be waiting for your response.

          Have a nice day.

          Regards,
          Diego V.
          • 2. Re: No compatible disk for Intel Optane
            ARANDIR
            1. SATA2 port is free
            2. SATA Mode: RAID/Optane Mode
            3. M2_1 – RST PCIe Storage Remapping: Enabled
            4. M.2/Optane Genie: Enabled

             

            But i can't find this option in BIOS :Use RST Legacy OROM

            • 3. Re: No compatible disk for Intel Optane
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi ARANDIR,

              Thank you for the information.

              Did you change something or everything was already set correctly?

              Regarding to the option that you cannot find in BIOS, unfortunately I cannot tell you where it is as I don’t have access to any MSI* motherboard. I shared this information with you based on the information available in this MSI* site: https://www.msi.com/news/detail/nO7jPBLuMlxeTNdkq_uGG2SPwkOtmwFrCt6f4DnHvMjX3p-tXjidN2MypSxxYPpHyrWNILgIHsyesyCxaYxrAQ~~

              I recommend you to contact MSI* to get help on where this setting is located.

              On the other hand, we can also try to clean the Intel® Optane™ Memory from the Diskpart tool in order to delete any possible metadata in the module that is preventing you from seeing properly in the OS.

              In order to clean the module’s data please follow these steps:

              1. Open the command prompt as Administrator.
              2. Run the command diskpart.
              3. Run the command list disk. This will show all disks in your system. Take note of the ID that appears next to the Intel® Optane™ Memory.
              4. Run the command select disk <disk_ID>. Use the ID associated to the Intel® Optane™ Memory.
              5. Run the command clean all. This will start the cleaning process. Make sure you selected the module and not other drive because this process will delete all data.
              After this, try to enable the module from the application again. If you are still not able to do so, I recommend you to perform a BIOS update and contact your motherboard’s manufacturer in order to get help finding the BIOS option you are not able to find. It may be possible that this setting is still missing to complete the configuration.

              Additionally, please take a screenshot of the Disk Management window just to check if everything is fine. Also, please right click on the boot drive in Disk Management and select Properties and then go to the Volumes tab. Here you can confirm if the partition style is GPT. I know you mentioned it is, but this is just to confirm.

              To open Disk Management, press the Windows* key + x and then select the Disk Management option from the menu that will appear.

              I’ll be waiting for your response.

              Have a nice day.

              Regards,
              Diego V.
              • 4. Re: No compatible disk for Intel Optane
                ARANDIR

                I'm gonna contact MSI. My BIOS don't have that button to enable optane like They are showing in manual. But it's updated to latest version on their website.....

                 

                Clean all didn't worked

                 

                Przechwytywanie.PNG

                • 5. Re: No compatible disk for Intel Optane
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  That’s perfect. Please let me know what response you get from them.

                  I'll keep investigating from my side to see if I'm able to find anything else about this.

                  Regards,
                  Diego V.

                  • 6. Re: No compatible disk for Intel Optane
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hi ARANDIR,

                     

                    After double checking the Disk Management screenshot, I noticed that you have another partition mounted besides the C: partition in the boot drive. That’s not common and it may be causing issues with the Intel® Optane™ Memory installation.

                     

                    The booting drive should be look like the one below (with the additional unallocated space at the end). However, you can see that there is only one partition mounted in the drive. You have 2 partitions mounted in yours.

                     

                    bootdrive.JPG

                    I’d recommend you to re-install the OS making sure only the C: partition is mounted. Please remove the other 2 drives and the Intel® Optane™ Memory from the system before doing the re-installation.

                     

                    Regards,
                    Diego V.

                    • 7. Re: No compatible disk for Intel Optane
                      ARANDIR

                      Optane is working now. All i was needed to do was clearing CMOS in BIOS. It's still weird because i've never made any changes to BIOS but who cares....it's working now.

                       

                      Thank You very much for Your help.

                      • 8. Re: No compatible disk for Intel Optane
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hi ARANDIR,

                        That’s perfect. Thanks for sharing the solution.

                        If you ever have any additional question about the Intel® Optane™ Memory, feel free to open a new thread. We’ll try to help you in any way we can.

                        Regards,
                        Diego V.