13 Replies Latest reply on Oct 10, 2018 9:50 AM by Intel Corporation

    No compatible disk for Intel Optane memory

    JesseB

      My specs:

                    i5-7500

                    16 GB ram

                    Gigabyte B250M-DS3H

                    300 GB boot drive - GPT

                    1 TB game drive - MBR

                    Set to UEFI in BIOS

                    CSM disabled

                    RST enabled

       

       

      I'm at my wits end with this. I bought a 32 GB Optane module about a week ago and have been battling it since. I just can't get it to work. I've probably installed Windows 15 times. I have all the settings (that I can change) set in my BIOS. UEFI, CSM disabled, RST enabled. Boot drive is set to GPT with about 50 MB of unallocated space at the end. And my BIOS is up to date. Please help! Thanks in advance!

        • 1. Re: No compatible disk for Intel Optane memory
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi JesseB,

           

          Thank you for posting in the Intel® communities.

           

          I understand that you are having issues installing the Intel® Optane™ Memory. I’ll try to help you with the process.

           

          After checking the log file attached, I noticed that your system is in Legacy mode. The Intel® Optane™ Memory won’t work in Legacy mode. It should be in UEFI mode instead.

           

           

          Legacy.jpg

           

           

          You mentioned that you changed in BIOS from Legacy to UEFI mode, however could you please tell me which settings you changed exactly? If possible please take screenshots of the BIOS settings that you modified, that way I will be able to better understand what you have done so far.

           

          To take screenshots, you need a USB flash drive. Insert it in your computer and when you are in the BIOS, press the print screen button to take the screenshot. The file will be saved in the USB flash drive. You can check this guide for better information about this: http://www.unboxingtreatment.com/2018/04/howto-take-screenshot-motherboard-bios.html

          Additionally, could you please take a screenshot of the Disk Management window to check the partitions you have in your drives? To open Disk Management, press the Windows* key + x and then select the Disk Management option from the menu that will appear.

           

          Once in Disk Management, if you right click on each Disk and select Properties>Volumes, we can confirm if the drives are using MBR or GPT partition style. Please check this too and take a screenshot for each drive so that I can check it as well.

           

          Another thing that I’d like to know is which drive you are trying to accelerate: the primary (boot drive) or the secondary disk. I’m asking because you have the secondary drive with MBR partition style, but if you want to accelerate it, it must use GPT.

           

          Please check this and collect the information so that I can help you in a better way.

           

          I’ll be waiting for your response.

           

          Have a nice day.

           

          Regards,
          Diego V.

          • 2. Re: No compatible disk for Intel Optane memory
            JesseB

            That's one thing that's driving me crazy! I had it sed to UEFI, and it showed correctly in System Info. But I am trying to accelerate Disk 0, my boot drive. But here is what you requested. Thanks for the help!

            • 3. Re: No compatible disk for Intel Optane memory
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi JesseB,

              Thank you for the information.

              According to the screenshot of the Disk Management window, I was referring to the Volumes tab. You took the screenshot showing the General tab instead. Please check it again and provide me with a screenshot showing the Volumes tab.

              Additionally, I was checking for information in the motherboard’s manual and I found that the M.2 slot shared bandwidth with the SATA3 5 connector, so my recommendation is to disable that SATA port even though you don’t have anything connected there.

              Here is the motherboard's manual in case you want to check it too: https://www.gigabyte.com/us/Motherboard/GA-B250M-DS3H-rev-10#support-manual

              Besides that, I don’t see anything else that may be wrong. You have set the SATA Mode Selection to “Intel RST with Intel Optane…” and have disabled the setting Use RST Legacy OROM. However, the Intel® Optane™ Memory is not recognized by the OS. This may be due to the fact that the OS is in Legacy mode. Please take a screenshot of the Volumes tab as I explained above just to confirm the partition style is actually GPT or MBR in the boot drive.

              Another detail I’m thinking of is that your second drive is using MBR partition style according to your original description. I’m not sure as I haven’t test it before, but it may be possible that your OS changes to Legacy mode in order to detect properly the secondary drive. As I said, I’m not sure about this as I’m just thinking in possible root causes of the issue. You can try to disconnect the secondary drive just to be sure this is not the case. Anyhow, our main goal now is to change the boot drive to UEFI mode, so you can keep the secondary drive disconnected for the moment.

              I’ll be waiting for your response.

              Have a nice day.

              Regards,
              Diego V.

              • 4. Re: No compatible disk for Intel Optane memory
                JesseB

                Sorry about that. I didn't catch that I was on the General tab. I will try that with the secondary drive. Thanks Diego!

                • 5. Re: No compatible disk for Intel Optane memory
                  JesseB

                  I just converted the secondary drive to GPT and it is currently not installed in the system. The SSU is finally showing the BIOS mode as UEFI, but the Optane module still is not detected in BIOS or Windows 10.

                  • 6. Re: No compatible disk for Intel Optane memory
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hi JesseB,

                    That’s weird. Could you please confirm if the option PCIe Storage Dev On Port 21 is still available in BIOS after you remove the Intel® Optane™ Memory from the system? I’m asking because according to this guide from Gigabyte* site, the ports should be port 9 or port 17, so I’m not sure if in your case this port is the 21: https://www.gigabyte.com/MicroSite/454/intel-optane-ready.html

                    Maybe you should contact Gigabyte* directly to clear out this question.

                    Additionally, have you installed the Intel® Optane™ Application to see what message you get? Please download it from the following site: https://downloadcenter.intel.com/download/28072/Intel-Optane-Memory-User-Interface-and-Driver-for-System-Acceleration?product=99745. Please provide a screenshot of the message in the application.

                    I’ll be waiting for your response.

                    Have a nice day.

                    Regards,
                    Diego V.

                    • 7. Re: No compatible disk for Intel Optane memory
                      JesseB

                      So the Optane application is still saying that the is no compatible disk. I will attach a screenshot from the RST application and the Optane application. I have contacted Gigabyte but am still waiting for a response. But I did see a difference in the BIOS when I removed the Optane module. I will even attach some logs from the SSU to hopefully help!

                      • 8. Re: No compatible disk for Intel Optane memory
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hi JesseB,

                        Thank you for the information.

                        According to the screenshots, it looks like the module is indeed recognized by the BIOS as the Port 21 is not available when it’s not connected. However, for some reason it’s not recognized in the OS.

                        I have seen this behavior when the Intel® Optane™ Memory has metadata stored in it. This metadata prevents the module from being recognized properly. When this happens, it’s recommendable to reset the Intel® Optane™ Memory so that it can go back to factory settings. However, this is usually seen after the module has been paired with a drive before.

                        Anyhow, we can try this as it may fix the issue. Let’s first check if your BIOS is indeed recognizing the module. Please follow these steps in BIOS:
                         

                        1. Connect the Intel® Optane™ Memory again in the system.
                        2. Go to the Peripherals tab.
                        3. Search for the option Intel(R) Rapid Storage Technology and enter.
                        4. You will see here a list of the drives in your system. The Intel® Optane™ Memory should be included in the list and it may appear like INTEL MEMPEK…
                        5. The module should be visible as a single drive which is the expected result, but if it appears like Optane Volume, you can enter into this option and you should see another option to deconcatenate the module. Click on it to reset it.

                        Please try this and let me know if you have success or not. If possible please take screenshots as you have been doing so far.

                        You will also see after entering in the Intel(R) Rapid Storage Technology option, the RST driver in your system. Please take a screenshot of this screen so that we can confirm the RST driver is installed correctly.

                        I’ll be writing for your response.

                        Have a nice day.

                        Regards,
                        Diego V.
                        • 9. Re: No compatible disk for Intel Optane memory
                          JesseB

                          Here is the information you asked for. Hopefully this helps! I was not able to locate the Optane Memory under RST in the BIOS.

                          • 10. Re: No compatible disk for Intel Optane memory
                            Intel Corporation
                            This message was posted on behalf of Intel Corporation

                            Hi JesseB,

                            Thank you for the screenshot.

                            It’s weird that the module doesn’t appear there. That would mean the following:
                             

                            1. There is something at BIOS/motherboard configuration level that is preventing the M.2 device to be read properly. This may be possible when SATA devices are also connected in ports that share bandwidth with the M.2 slot. We already checked this before but just to be 100% sure, please disconnect the drives from the motherboard and keep the Intel® Optane™ Memory connected. You won’t be able to boot, but it is not necessary as you only have to go to BIOS and confirm if the Intel® Optane™ Memory is still not visible in the Peripherals tab (same location as in last screenshot).
                            2. The module is damaged. If the module is still not visible after disconnecting all drives and making sure nothing else could be causing interference with the M.2 slot, then the only thing I can think of is that there is something wrong with the module itself. If this is the case and considering the fact that you bought the module a couple of weeks ago, according to your original post, I recommend you to contact the place of purchase and explain this issue to them. They should help you with a replacement as the module should still be under the warranty period.

                            Please try the option 1 first, but if there is no change, then go with option 2.

                            The thread will keep open so you can still posting here. I’ll continue helping you, however if the module is damaged it’s always recommended to contact the place of purchase for warranty.

                            Have a nice day.

                            Regards,
                            Diego V.
                            • 11. Re: No compatible disk for Intel Optane memory
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              Hi JesseB,

                              I was wondering if you have any updates about this, regarding to my previous post.

                              Regards,
                              Diego V.
                               

                              • 12. Re: No compatible disk for Intel Optane memory
                                JesseB

                                Sorry about the long break. I finally received a new Optane module from Amazon. I plugged it in, searched my BIOS for the drive AND FOUND IT!!! Turns out the module was defective and now I'm enabling as we speak! Thanks a ton for your help, Diego! I greatly appreciate it!

                                • 13. Re: No compatible disk for Intel Optane memory
                                  Intel Corporation
                                  This message was posted on behalf of Intel Corporation

                                  Hi JesseB,

                                  That’s great!

                                  Thank you for confirming that the issue was solved by replacing the module.

                                  If you ever have another issue or any question about the Intel® Optane™ Memory, please don’t hesitate to open a new thread. We’ll try to help you in any way we can.

                                  Have a nice day.

                                  Regards,
                                  Diego V.