5 Replies Latest reply on Oct 9, 2018 5:36 AM by Intel Corporation

    F200 install workaround

    raulito1989

      So for over a year I've been without a webcam on my Lenovo Thinkpad Yoga 15 laptop. The Laptop came with an Intel Realsense F200 camera. As it was not a hardware issue but a software incompatibility issues between the developer software and Windows 10 updates they only offered to take back my laptop for a full refund. As it was one of the last models that had all the specs I wanted so I kept it. I was a bit surprised that they let a camera with so much issues go on sale especially a developer kit camera. I'm by no means a developer, just a guy trying to run a business and go to college.

       

      I wiped out and reinstalled my drivers over and over again, both from Lenovo and here. I downloaded the old SDK, couldn't get it to detect the camera. Camera app tells me the camera is in use. Play with the device manager and it'll tell me no camera is attached. I figured the update just came out, I'll give it a while.

       

      So after a year I now need my webcam. Since last year the F200 which was already basically unsupported is now a legacy model. Basically, I've never had a working webcam and the community tells me I never will, tough luck. But right before I give up a month ago someone posted a workaround

       

      Windows® 10 Issues with Intel® RealSense™ Cameras SR300 and F200

       

      Step 7 asks me to run this in the command prompt

       

      intel_rs_dcm_sr300_3.3.27.5718.exe --ignore-fw-update --silent --no-progress --acceptlicense=yes

       

      in my case it's

       

      intel_rs_dcm_f200_1.4.27.52404.exe --ignore-fw-update --silent --no-progress --acceptlicense=yes

       

      When I run it nothing opens

       

      When I use the DCM directly it asks me do I agree to update the firmware during installation, if I say no do not update the camera firmware, it will not let me press next.

       

      I've tried every tutorial, how to, and troubleshooting step there is. The threads never get resolved. I wish lenovo would answer for this product or at least Intel product support. But this is my only option. If anything can someone help me with this workaround, I had to teach myself to use command prompt to try this and I get nothing.

       

      Thank you

        • 1. Re: F200 install workaround
          MartyG

          Some Lenovo laptops have a recovery system called OneKey pre-installed.  It is a hidden section on the hard drive that can restore the laptop to factory condition.  If your model came with OneKey installed, it should still be there if you haven't wiped your hard disk since you purchased the laptop.

           

          Introduction to Lenovo OneKey Recovery 8.0 for Notebooks - US

           

          Regarding the Device Manager: RealSense drivers may appear in either the 'Imaging Devices' category or the 'Cameras' category depending on the particular PC  

           

          If you do locate an active camera, this post about privacy settings may be helpful.

           

          https://forums.lenovo.com/t5/Lenovo-P-Y-and-Z-series/SOLVED-Built-in-Camera-not-working/m-p/3353372/highlight/true#M1452…

           

          Ultimately if all else fails, it may be easier just to buy a small USB webcam that can clip to the top of your screen.

          • 2. Re: F200 install workaround
            raulito1989

            It’s not an issue with Lenovo, for my camera to work I’ll have to roll back my windows 10 version. And yes I’ve wiped that partition out. I have to access sensitive networks with my laptops so rolling with an outdated windows version is a no go.

             

            We can see the camera in the device manager but the error is when you try to use the camera app. Many people have posted on this issue going back a few years. I’ve been searching for a fix but nothing new aside from this workaround.

             

            What I’m trying to see if whoever designed this workaround knows how we can get it to work on the F200. I’ve read this forum up and down and adjusted my privacy settings. The issue is how windows 10 recognizes my camera.

             

            I can pickup an external camera but it’s upsetting to have to clip on a camera on a 1100 dollar laptop. Thanks for the reply

            • 3. Re: F200 install workaround
              MartyG

              This is probably not the cause as your problem dates back so long, but some RealSense cameras had problems after May when the Windows 10 April Update (build 17134) was released.  It was found that Windows 10 has some hardware access permissions that were changed by Windows on some machines, disabling the camera.

               

              The user who found the fix said: "Go to Privacy Settings.  Select the tab "Camera" and turn on "Allow apps to access your camera".   None of the apps below need to be given permission, however now you should be able to find and access your Realsense camera again".

              • 4. Re: F200 install workaround
                raulito1989

                I read that post, camera access for the device is on, the individual apps have access. It was never off. I’ve restarted many times.

                 

                I know this is a developer page so I tried reading all I could before asking. I saw that post as well.

                 

                Again I can see the camera in devices. The drivers do get installed. But when you open any camera app it will say camera not installed.

                 

                The SDK gave a little more information but I can’t find the SDK for my model on this page anymore. I could dig through github but at this point it’s getting overwhelming.

                 

                I just want to see if I’m doing something wrong with the workaround. I don’t use command prompt but I think I did it right but nothing launches

                • 5. Re: F200 install workaround
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hello raulito1989,

                  Thank you for your interest in the Intel RealSense Technology. 

                  We wanted to step in and inform you that the reason you did not see anything happen when you installed the DCM from the command prompt is because the command line used the flags "--silent --no-progress" which means that it installs silently in the background without a GUI.

                  Unfortunately, based on the description of your problems, there is nothing more we can do to get the camera working.

                   Please let me know if you have any questions or queries we can answer. 

                  Best regards, 
                  Casandra