11 Replies Latest reply on Sep 19, 2018 2:32 PM by Intel Corporation

    Intel Optane: When I disable CSM Support my pc won't open windows

    Fl0ris

      I have been trying to get my Intel Optane to work for a while now but whenever I disable CSM Support my pc won't open windows anymore. This also seems to disable the option to turn UEFI on. My  motherboard is the GA-H270-HD3. Here is the piece of error code I get when opening the optane installer, but I don't know if this is helpfull.

       

       

       

        === UefiManager: Checking is UEFI mode on

        === UefiManager: GetFirmareEnvironmentVariable ended with error: 1

         === UefiManager: UEFI mode is off

      E Win32 exception occurred!!

          Error code: 0x520E (21006)

          Error text: ''

          Extended error text: 'Your BIOS is set in Legacy Mode'

          Debug info: 'SourceFiles\Optane.cpp (248)'

         Node is not valid. Failed to resolved error string from config file error: 21006

       

      Thanks for taking the time to read this/ help me, have a great day!

        • 1. Re: Intel Optane: When I disable CSM Support my pc won't open windows
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Fl0ris,

           

          Thank you for posting in the Intel communities.

           

          According to the information you have provided, your OS doesn’t boot after disabling CSM or turning on the UEFI setting because your BIOS is set in Legacy mode. In order to successfully setup the Intel® Optane™ Memory, you should set the BIOS in UEFI mode. See the error below:

           

          Extended error text: 'Your BIOS is set in Legacy Mode'

           

          I’ve found an installation guide in your motherboard’s manufacturer that explains how the module should be set up. Please take a look at it in the following site: Intel® Optane™ Memory Ready - GIGABYTE

           

          There is a section where it’s explained which setting should be disabled in order to disable the Legacy mode. Hopefully that’s the only setting you are missing.

           

          The instructions in that site are very well explained. I recommend you to follow them carefully from the beginning in case you are missing any other configuration step.

           

          I hope you find this information useful.

           

          Have a nice day.

           

          Regards,
          Diego V.

          1 of 1 people found this helpful
          • 2. Re: Intel Optane: When I disable CSM Support my pc won't open windows
            Fl0ris

            Thank you Diego, this already is very valuable information but I still seem to have a few problems. Do you have to run the optane installer when downloading windows? And my Optane is installed On the M2A_32G but I don't have a PCIe Storage Dev on Part 9 or 17 ( I even don't have any PCIe Storage Dev Option)

            I hope you/anyone can help me with this

             

            Have a good day!

            • 3. Re: Intel Optane: When I disable CSM Support my pc won't open windows
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Fl0ris,

               

              Thank you for the information.

               

              The Intel® Optane™ Memory application has to be run after you have installed Windows*, but don’t focus on this yet

               

              It looks like there should be something else missing so let’s check the system configuration from the OS* first.

               

              Please download the Intel® System Support Utility (SSU) from the following site and run the report. This tool will scan your system and generate a file with the system details. Please attach that file in your next response and make sure you run the full report: Download Intel® System Support Utility for Windows*

               

              Additionally, please go to your Disk Management and take a screenshot of the window. You can open the Disk Management by pressing the Windows* key + x and then select the Disk Management option from the menu that will appear.

               

              Let’s first check this as it might be possible that you OS* is not configured correctly.

               

              I’ll be waiting for your response.

               

              Have a nice day.

               

              Regards,
              Diego V.

              1 of 1 people found this helpful
              • 4. Re: Intel Optane: When I disable CSM Support my pc won't open windows
                Fl0ris

                Hi Diego,

                 

                Here are the files you asked me to send. (If you need anything translated please let me know) Thanks for the assistance

                 

                A nice day to you too,

                Floris

                • 5. Re: Intel Optane: When I disable CSM Support my pc won't open windows
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi Fl0ris,

                   

                  Thank you for the information.

                   

                  From the SSU report I can see the Intel® Optane™ Memory is recognized, but the system is still configured in Legacy mode.

                   

                  I can see from the screenshot that your OS is in GPT which is fine, but to be sure please right-click on the Disk 0, select Properties and then check the Volumes tab. It should appear GPT in the partition style. The names will be different probably as your OS is in another language.

                   

                  Additionally, the system requires an unallocated space of at least 5MB at the end of the drive for the module to work properly as it’s described in the following guide (page 5): https://www.intel.com/content/dam/support/us/en/documents/memory-and-storage/optane-memory/intel-optane-memory-user-installation.pdf

                   

                  This means that you would have to re-install the OS and reserve that unallocated space at the end of the drive when installing the OS.

                   

                  Before re-installing the OS, please go to your BIOS, in the Peripherals tab, set the SATA Mode Selection to Intel RST Premium With Intel Optane and set the Use RST Legacy OROM to Disabled. This should be set the system in UEFI mode instead of Legacy mode. Make sure to disable the CSM setting too.

                   

                  I hope this works for you. Once the process is complete, please take another screenshot of the Disk Management for confirmation and provide the SSU report again.

                   

                  Make sure to back up any data on the drive before re-installing the OS because the process will delete everything.

                   

                  I’ll be waiting for your response. If you have any questions, feel free to ask.

                   

                  Have a nice day.

                   

                  Regards,
                  Diego V.

                  1 of 1 people found this helpful
                  • 6. Re: Intel Optane: When I disable CSM Support my pc won't open windows
                    Fl0ris

                    Thanks for the answer I'm going to try to reinstall windows next week. For now thanks for helping and I hope you will have a nice weekend!

                     

                    Regards,

                    Floris

                    • 7. Re: Intel Optane: When I disable CSM Support my pc won't open windows
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Thank you Floris, I hope you have a nice weekend too.

                      I’ll be waiting for your response.

                      Regards,
                      Diego V.

                      • 8. Re: Intel Optane: When I disable CSM Support my pc won't open windows
                        Fl0ris

                        Hey Diego,

                         

                        So I am about to reinstall windows but Disk 0's partition style seems to be Master Boot Record (MBR), and I am unable to click the option to change it to GPT

                         

                        Hope you can help.

                         

                        Regards,

                        Floris

                        • 9. Re: Intel Optane: When I disable CSM Support my pc won't open windows
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          Hi Fl0ris,

                           

                          Thank you for the information. I thought your disk was using GPT but thank you for confirming it’s using MBR.

                           

                          MBR is not compatible with the Intel® Optane™ Memory and that explains why your system is in Legacy mode and cannot be changed to UEFI.

                           

                          The only way to change the partition style is to re-install the OS as I explained you before, however let’s try the following alternative approach. Windows* includes since build 1703, a tool to convert the partition style without the need of formatting and reinstalling the OS.

                           

                          From the SSU report that you shared previously, I can see that you have the build 17134, which should include the tool called MBR2GPT.EXE. This process is described in the following Microsoft* article: https://docs.microsoft.com/en-us/windows/deployment/mbr-to-gpt

                           

                          There are some examples at the end of the article but basically, the command that you have to run from the Command Prompt as Administrator is the following:

                           

                          mbr2gpt.exe /convert /disk:0 /allowfullOS

                           

                          Please try this and let me know if it works.

                           

                          After the conversion, you have to shut down the computer, enter in BIOS and change the settings to UEFI mode as I mentioned before:

                           

                          Before re-installing the OS, please go to your BIOS, in the Peripherals tab, set the SATA Mode Selection to Intel RST Premium With Intel Optane and set the Use RST Legacy OROM to Disabled. This should be set the system in UEFI mode instead of Legacy mode. Make sure to disable the CSM setting too.

                           

                          Hopefully this will work and the partition style will be set to GPT.

                           

                          On the other hand, you will still have to create an unallocated space at the end of the disk as it’s needed for the module to work properly. This can be done by re-installing the OS. However, another community user have shared an alternative way to create this space in the disk that you may want to try, so you can avoid going through the re-installation process. Please check the following thread for details: https://communities.intel.com/thread/128802

                           

                          These would be the alternative options to change what it’s required in your system without an OS re-installation, however if you don’t have any important data or have backed up the data, and you can perform the re-installation, please do it as it’s easier than going through the settings I mentioned above.

                           

                          During the OS re-installation, the drive will be formatted, so the MBR partition style will be deleted. If you change the system to UEFI in BIOS before re-installing the OS, it should be installed using GPT instead of MBR, and the reserved space will be reserved correctly. Please make sure to do this in the installation wizard or we will be facing the same issue again.

                           

                          I hope this information clarifies your concern. If you have additional questions, let me know.

                           

                          Have a nice day.

                           

                          Regards,
                          Diego V.

                          • 10. Re: Intel Optane: When I disable CSM Support my pc won't open windows
                            Fl0ris

                            Hi

                            Thanks a lot for the help Diego,

                             

                            My Optane is working correctly now all thanks to you,

                            Have a great day


                            Regards, Floris

                            • 11. Re: Intel Optane: When I disable CSM Support my pc won't open windows
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              Hi Floris,

                              That’s great!

                              I’m glad to know that you have the system and the module up and running.

                              If you have future issues or questions, please don’t hesitate to open a new thread. We’ll be more than glad to help you.

                              Have a nice day.

                              Regards,
                              Diego V.