14 Replies Latest reply on Sep 14, 2018 10:05 AM by Intel Corporation

    trying to get optane memory to work

    jordanj

      I setup and turned on my computer. Installed windows 10. Went into bios and turned on the optane acceleration option. I was not sure if it was working at that point and checked online for drivers. When I went to install intel’s optane software it told me I had to uninstall the Intel rapid software before installing so I did. On computer restart I got a blue screen. This continued until I turned off the optane setting in bios. I am not sure how to undo what I did, and also get my optane memory to work with my 2tb hdd as expected. Are my components all compatible? When I turn off the optane setting in bios, it starts up correctly. Note I bought 16gb ram, and one stick is not being detected so I took it out.

      Attempted fixes: - I tried to reinstall the Intel rapid storage technology software - I deleted everything on the SSD, formatted, and reinstalled windows

      Is it safe / should I reformat the optane memory?

       

       

      Overall, I have no idea what to do next. I am seeing really odd behavior all over now. Is it safe for me to boot from windows disc and delete and format all of my drives that I have?

        • 1. Re: trying to get optane memory to work
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi jordanj,

          Thank you for posting in the Intel communities.

          I understand that you are having issues setting up the Intel® Optane™ Memory. According to the report attached, your system seems to be compatible with the module. Actually, the module is being recognized by the system.

          Let’s first check the BIOS settings. Could you please tell me which exactly settings you modified in BIOS?

          Additionally, regarding to the Windows* OS, could you please take a screenshot of the Disk Management window? In order to open the Disk Management press the Windows key + x and then select the tool from the menu that will appear.

          Windows* must be installed using a GPT partition style, could you please confirm it was installed like that?

          I was also checking the motherboard’s specifications and apparently there is a specific slot for the module. Please make sure you have connected the module in the correct slot: https://www.asus.com/us/Motherboards/ROG-STRIX-Z370-E-GAMING/specifications/

          Additionally, make sure you have updated the BIOS of your motherboard. If you are not sure about the BIOS version, I recommend you to contact ASUS* directly to make sure the BIOS is up to date: https://www.asus.com/us/Motherboards/ROG-STRIX-Z370-E-GAMING/HelpDesk/

          I’ll be waiting for your response.

          Have a nice day.

          Regards,
          Diego V.

          • 2. Re: trying to get optane memory to work
            jordanj

            Diego,

             

            The optane module is in the M.2_2 slot, is this correct? I do not see on that page which slot it is required to be in. My Western Digital NVMe SSD is in the M.2_1 slot. I will get the rest of the information when I get home later today.

             

            Regards

            • 3. Re: trying to get optane memory to work
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi jordanj,

              I’m not sure either which the correct slot is. I didn’t find any specific reference in the specifications, so let’s keep using the module in that slot. I just wanted to tell you that the manufacturer has a note about that in its website.

              However, there is an additional note in the specifications site about the M.2 slots. The M.2_1 slot shares the SATA_1 port while the M.2_2 slot shares the SATA_5 and SATA_6 ports so make sure your SATA drive is not connected in these ports. If it does, there would be conflicts between the drives and they won’t work properly.

              For the rest, I’ll wait for you to have the information I asked above and see if we can set the module up in your system.

              Have a nice day.

              Regards,
              Diego V.

              • 4. Re: trying to get optane memory to work
                jordanj

                Diego,

                 

                • I changed one SATA connection, now I have connections on 2/4 so there is no interference
                • I upgraded BIOS to latest version 1002
                • In terms of my first post, the setting I referenced was "Intel Rapid Storage Technology" where turning it on caused windows to blue screen on boot (all settings are default now).

                 

                attached are screenshots of my disk management screen, and proof of disk partitions.

                • 5. Re: trying to get optane memory to work
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi jordanj,

                  Thank you for the information.

                  The Windows OS* looks fine although there is one missing detail. At the end of the drive partitions, there must be an unallocated space of at least 5MB. This space is reserved for the Intel® Optane™ Memory to work properly. Some days ago another user got this issue and posted how he fixed it, please check the thread as you may find it useful too in order to create this unallocated space in the disk: Re: Freezes just after login, 32GB Optane, Win 10, 12GB RAM, HP 590-p0066 . If that approach doesn’t work, then you would have to re-install Windows* making sure you reserve the required space during the installation.

                  You can also check the flowing guide to setup the module which includes additional details about this reserved space (page 5): https://www.intel.com/content/dam/support/us/en/documents/memory-and-storage/optane-memory/intel-optane-memory-user-inst…

                  On the other hand, I’d like to confirm that you have the BIOS settings properly set. ASUS* has a well explained guide to setup the Intel® Optane™ Memory. Please check it here: http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf

                  The settings you should check are the following:

                  1. The SATA Mode Selection which should be set as Intel RST Premium with Intel Optane.
                  2. Once you set this setting, a new sub-setting should appear just below that one if the module is connected. This sub-setting is the M.2_X PCIE Storage RAID Support which should be enabled.
                  3. Make sure the CSM setting is disabled.


                  These settings are explained in the guide above. If there is something different please take a screenshot of the BIOS so I can take a look at it too.

                   

                  You can take screenshots of the BIOS by pressing F12 or the Print Screen button. You will require a USB Flash memory connected because the images are saved there automatically. Please refer to this site for additional details about this: How to Take A Screenshot in Your Motherboard BIOS | Unboxing Treatment

                   

                  I’ll be waiting for your response.

                   

                  Have a nice day.

                   

                  Regards,
                  Diego V.

                  • 6. Re: trying to get optane memory to work
                    jordanj

                    Diego,

                     

                    Thanks for the reply I will follow those directions and attach more screenshots when I get home later today. I have two questions:

                     

                    1. Do I follow the directions in Optane-Memory-SOP.pdf for AHCI mode or RAID mode?

                    2. After I follow all of the directions you gave, do I expected the memory to work? Previously, when I turned on the optane setting in BIOS my windows blue-screened. If not, what are my next steps?

                    • 7. Re: trying to get optane memory to work
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Hi jordanj,

                       

                      Thank you for the response. I’ll wait for your results.

                       

                      Regarding to your questions, please follow the process for RAID mode. However, if you get again the blue screen after changing the SATA mode to Intel RST Premium…, follow the process for AHCI. The AHCI process will change the system to RAID mode either way.

                       

                      As far as I could see from the information you provided everything is fine, just the detail I mentioned about the reserved space and the BIOS configuration that we have to confirm.

                       

                      The purpose of my message above is to check the BIOS configuration. The module won’t be ready to work yet as we need first to install the RST driver (unless you had already installed it).

                       

                      The RST driver can be installed whether by installing the Intel® Optane™ application or the Intel® RST application. Both applications can be downloaded from the following site: Downloads for Intel® Optane™ Memory

                       

                      These tools are used to enable the module which would be the last step, but this will work only if the BIOS is setup correctly. That’s why we have to check the BIOS configuration first. Probably if you run one of these tools now, you won’t be able to enable the module as there is something missing that we have to confirm from BIOS. Besides, your module even though is recognized by the system, it’s not recognized as an NVMe* device yet, and that’s most likely because the remapping setting is not enabled yet (SATA mode selection).

                       

                      I also recommend you to check the following thread: problem with intel optane memory .  That is a thread where the user went through all the configuration on a ASUS* system to have the module working. At the end the issue was fixed by just changing the port where the module was connected to, but it also includes information that you may find useful when setting up your system.

                       

                      I hope you find this information useful. If you notice something different in BIOS or have additional concerns during the setup process, please take the necessary screenshots. They will help us to better understand the current status of the system.

                       

                      I’ll be waiting for your response.

                       

                      Have a nice day.

                       

                      Regards,
                      Diego V.

                      • 8. Re: trying to get optane memory to work
                        jordanj

                        Diego,

                         

                        My computer turned on after changing the different BIOS settings. I am attaching a screenshot of each step.

                         

                         

                        1. Partitioned 1000MB at the end of my boot drive

                        2. Disabled CSM

                        3. Changed SATA mode selection to Intel RST Premium With Intel Optane

                             3.1. Changed M.2_2 PCIE Storage RAID Support to RST Controlled*

                             3.2. Change M.2_1 PCIE Storage RAID Support to Not RST Controlled**

                        4. Downloaded drivers from the page you linked

                             4.1. Download Intel® Optane™ Memory User Interface and Driver for System Acceleration failed as I already have RST

                             4.2. Download Intel® Rapid Storage Technology (Intel® RST) User Interface and Driver succeeded

                         

                        *M2_2 is my Optane module

                        **M2_1 is my 500gb SSD

                        • 9. Re: trying to get optane memory to work
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          Hi jordanj,

                           

                          Thank you for the screenshots and the explanation.

                           

                          Everything looks fine, however I’m wondering if you tried to enable the module from the RST application as it’s explained in this article: Secondary/Data SATA Drive Acceleration with Intel® Optane™ Memory

                           

                          Did you get any error message in the application, or you were able to enable the module?

                           

                          Regards,
                          Diego V

                          • 10. Re: trying to get optane memory to work
                            jordanj

                            Diego,

                             

                            I did not try to enable the module from the RST application, I was not sure the exact steps to follow. I will try to do that when I get home later today. Could you link me to the steps of using the application correctly so I make sure to do it right the first time?

                            • 11. Re: trying to get optane memory to work
                              Intel Corporation
                              This message was posted on behalf of Intel Corporation

                              Hi jordanj,

                               

                              The steps are shown in the article I just shared in my previous post.

                               

                              When you open the application, you should find a tab for the Intel® Optane™ Memory or a section for the module as it’s shown in the article above. The only option is the enable button. If everything is correctly configured as it seems to be, you should be able to click on the enable button and then select the drive you want to accelerate, which I supposed from the information you have shared that it’s the secondary drive.

                               

                              If you cannot do this, take a screenshot to see the error message.

                               

                              Having said this, you may not see the secondary drive in the application because it’s currently as unallocated according to what I can see form the Disk Management screenshot. You will need to format the drive first and create a volume. The instructions to perform this from the Disk Management are listed in this site: https://support.microsoft.com/en-us/help/17418/windows-7-create-format-hard-disk-partition

                               

                              Please follow the steps under “To create and format a new partition (volume)". Make sure GPT partition style is used if you are asked for it and NTFS is selected to format the drive.

                               

                              Let me know if you have additional doubts.

                               

                              I’ll be waiting for your response.

                               

                              Have a nice day.

                               

                              Regards,
                              Diego V.

                              • 12. Re: trying to get optane memory to work
                                jordanj

                                Diego,

                                 

                                I think that may have been it:

                                 

                                1. Formatted the unallocated drive

                                2. Ran RST and enabled optane memory

                                 

                                Attached are screenshots for you to confirm I am done. Is there a way for me to test the increased speeds?

                                 

                                Edit: My motherboard disk says there is an intel RST driver update, should I install it?

                                • 13. Re: trying to get optane memory to work
                                  Intel Corporation
                                  This message was posted on behalf of Intel Corporation

                                  Hi jordanj,

                                   

                                  That’s right, the Intel® Optane™ Memory is enabled and working with your secondary drive!

                                   

                                  There isn’t a way to test the new performance, the Intel® Optane™ Memory improves the launch time of applications and files that you use most often. Exactly how much improvement varies with each application.

                                   

                                  I'm glad to know that you were able to setup the module.

                                   

                                  Regarding to the RST driver update, which version are you currently using? The latest one is the 16.5.1.1030 version. You can download the latest one from the following site: Download Intel® Rapid Storage Technology (Intel® RST) User Interface and Driver

                                   

                                  Before doing any change, I recommend you to disable the module first, install the latest version of the application and then enable again the module.

                                   

                                  Have a nice day.

                                   

                                  Regards,
                                  Diego V.

                                  • 14. Re: trying to get optane memory to work
                                    Intel Corporation
                                    This message was posted on behalf of Intel Corporation

                                    Hi jordanj,

                                    I’d like to know if everything is working fine, or if there is something else I can help you with.

                                    I’ll be waiting for your response.

                                    Have a nice day.

                                    Regards,
                                    Diego V.