8 Replies Latest reply on Sep 19, 2018 6:13 PM by McClane.MX

    Intel Driver for I219V for use on WinPE

    McClane.MX

      Hello

       

      I have a NUC7i3BNK that is used mostly to host a Quickbooks database, and we want to use it as a sort of backup server. This machine would access the backup files stored in a NAS and would send a boot image to the clients (the clients are the same model as the server) to PXE boot and image or restore their drives. Light work.

       

      The problem is the driver support. Since I have a lot of time, I tested as many solutions as I could to get the driver to install:

       

      For Windows 8, 8.1, 10, 2012, 2012 r2 and 2016, I tried installing driver version 23.2 after fresh installs and after fully updating.

      I tried that also with version 21, which, as I understand, was the first version to offer support for this particular card.

       

      All fails with the message about "No Intel adapters are present on this computer". If I try to have Windows look for the driver in a folder, it will say no driver was found, and if I try to pick a driver from a list loaded from e1d64x64.inf, only the LM variants of the card are listed, none of the V.

       

      By now it's known that a workaround is to manually install the driver for the LM variant of the card. I don't know if there are any differences, but it's functional. If after this I run the driver installer again, sometimes it will install the right driver, and sometimes it won't.

       

      However, when I have my backup software inject this driver (e1d64x64.inf) in my boot image, or the whole set of drivers, no network driver is loaded when the client boots up.

       

      I read in the forums that you get that error message when the hardware ID doesn't match the descriptions in the driver file, so I checked what it was. In my specific machine, the network card is listed as Intel Ethernet Connection (4) I219-V. The hardware ID's from Windows Device Manager are these:

       

      PCI\VEN_8086&DEV_15D8&SUBSYS_20688086

       

      When I looked at the INF file from the NDIS64 folder in the Intel bundle, it shows these values for this device:

       

      [Intel.NTamd64.6.3.1]

      ; DisplayName                   Section              DeviceID

      ; -----------                   -------              --------

      %E15D8NC.DeviceDesc%            = E15D8.6.3.1,       PCI\VEN_8086&DEV_15D8

      %E15D8NC.DeviceDesc%            = E15D8.6.3.1,       PCI\VEN_8086&DEV_15D8&SUBSYS_00008086

       

      I decided to add a line with the information from the Windows Device Manager and tried to install the driver from the Device Manager to no effect, but then I noticed another area with a slightly different header that didn't have any references to this hardware id, and where the "Section" values didn't have suffixes. So, for that area, I added the line:

       

      [Intel.NTamd64.6.3]

      ; DisplayName                   Section        DeviceID

      ; -----------                   -------        --------

      %E15D8NC.DeviceDesc%            = E15D8,       PCI\VEN_8086&DEV_15D8&SUBSYS_20688086

       

      If I have Windows look into the folder where this driver is, it detects it correctly and attempts to install it, but it will complain that the string for this hardware is not present in the security catalog (e1d64x64.cat) of the driver, which makes sense, given the modifications I made to the INF file. So, I deleted the CAT file reference in the INF, disabled the signature enforcement, and lo and behold, I was able to install the driver by pointing Windows to it. It also worked on the other versions of Windows, after disabling the driver signature enforcement. I haven't noticed any problems in its functioning so far.

       

      Which brings me back to my original problem. Although I could make the driver work in a full windows environment by disabling signature enforcement, I found out that you can't disable the thing on WinPE. So, I'm back to square 1. I have a functional but unsigned driver that I can't use for PXE booting our client computers to run our backup software. I can't modify the software's image, it will just inject the drivers I provide it with, and crash if they're not signed. But the signed driver doesn't work.

       

      Is there any way to get a third party signed driver for this specific VEN/DEV/SUBSYS combination? Is anyone at Intel willing to look into it?

       

      Thanks for your help.