6 Replies Latest reply on Sep 6, 2018 6:10 PM by maryt_intel

    How to disable INTEL OPTANE memory

    gjanu

      I use INTEL OPTANE 32 Gb memory to accelerate my data disk - a Western Digital 2gb drive. Installation of the OPTANE was relatively easy and everything worked well. I wanted to back up the data disk with Macrium Reflect software and I was not sure if the data disk backup image can be properly done with the OPTANE memory enabled. So I used the INTEL OPTANE memory application to disable the OPTANE memory. The disable process started (the rotating dots) and showed "step 1 or 3" etc. Eventually, the disabling process got stuck on "step 3". After about 1 hour of the "step 3", I decided not to wait any longer and restarted the computer. The data disk no longer appears in the File Explorer and the Disk Management shows only the OPTANE memory as 7,2 Gb "unallocated" and requiring initialization as GPT. I went into BIOS, Advanced mode and disabled the OPTANE memory in BIOS. As a result, the Disk Management now again shows my data disk as 2 Tb, but "unallocated", and separately shows the OPTANE memory as 32 Gb.

      So, as a final result, my attempt to disable the OPTANE memory ended up in wiping out all data on my data disk.

      Can you give me any idea of what went wrong and how I can restore my data disk and what am I supposed to do next time if I need to properly disable OPTANE memory?

      My system uses ASUS ROG STRIX Z370-E motherboard, INTEL i7-8700K CPU, Samsung 970 PRO M.2 NVME SSD as a boot disk and a Western Digital 2 Tb drive as a data disk, formatted as a GPT disk.

      Thank you

       

      A  day later: Many thanks to Al Hill for researching this and giving valuable answers!

      After unsuccessfully trying to disable OPTANE memory and then disabling it in BIOS, the Disk Management as well as my Paragon Partition Manager both showed the data disk as "2 Tb, Unallocated". Strangely enough, though, the Macrium Reflect showed the data disk as normal, active and with data. With an increasing hope, I used Macrium to create a backup image of the Data disk and after about 1 1/2 hour when it finished, I could explore the image and saw that all data was there and in perfect shape. So I restored the image back to the Data disk. As Macrium did not discover any changes, the restore took only about 1 minute and now my Data disk was again on line and functioning perfectly. Hooray for Macrium Reflect!

      At this point, I am thinking of re-enabling the OPTANE memory.

      In respose to Al Hill's last message, about the scenario 3 - when HDD paired with OPTANE memory is backed up with the OPTANE enabled and then it fails - I think that in that case, as a last resort, one could right click on the existing image and use the "Explore" option available in Macrium Reflect and simply copy all needed files to the new HDD. This would not work for a boot disk, but probably would work OK for a Data disk.

       

      I still have a general question - how long is disabling of the OPTANE memory supposed to take? In my case, I waited 1 1/2 hour before I gave up and rebooted the computer. The INTEL instruction video on disabling OPTANE memory makes it look like it should take only a few seconds (and Al Hil'sl description is similar). The video also shows that during the disabling process, a number showing percent finished should show inside the rotating circle of dots. In my case, it did not show...

       

      Message was edited by: George Janu

        • 1. Re: How to disable INTEL OPTANE memory
          Al Hill

          While I cannot answer what went wrong, I can tell you this - I have a 16GB module on a NUC, and I have Macrium as a backup.  Worried about the same thing as you, I contacted Macrium and asked specifically about their backup and the use of Optane.  I have been assured that you do not have disable Optane, and the backup will work (and restore) without issues. 

           

          However, I am skeptical.   I have done the backup, but I have not tested the restore.  Macrium says that the Optane+HDD are treated as a logical drive, and are even able to be restored to another HDD that does not have Optane paired with it.    "When restoring your image of the NUC, your Optane memory and HDD will be treated as one logical drive (the same as restoring one physical drive)."

           

          This is a good topic for discussion, as there are other backup solutions out there that are likely to be as concerning to others.

           

          I have no information on how long the disable of Optane should take.  But, the problem was likely made worse by your restart of the computer.

           

          Doc

          • 2. Re: How to disable INTEL OPTANE memory
            Al Hill

            Ok, I did some testing.

             

            I have a 16gb Optane and 750gb WD HDD.

            I disabled Optane, expecting a long process.  It actually took 12 seconds, if that much.

            The restart was longer than usual.  My power button, which doubles as a disk activity indicator, went off.  I was thinking something was wrong but, as always, patience is key.

            The system restarted, I logged in, and all was as it should be.  The only odd thing, which is not really so odd knowing the application<G>, is the IDSA tray icon was gone.

             

            I re-enabled Optane.  The total time for enabling Optane was about 8 seconds.

            I restarted.  It took slightly longer than normal, the disk activity went completely dark.

            Once the restart was done, I logged in, and all was fine, including the return of the IDSA tray icon.

             

            I may do a restore of my Macrium backup tonight.

             

            Now, on my NUC7i7DNHE, everything, including bios, is updated, and the latest rev of the  Download Intel® Optane™ Memory User Interface and Driver for System Acceleration     is installed.

             

            More as I test.

             

            Doc

            • 3. Re: How to disable INTEL OPTANE memory
              Al Hill

              I spent about 5 hours on this.  Here is the scoop.

               

              Scenario 1.  You have Optane paired with your HDD.  You take an image backup with Macrium Reflect..  You can restore this image to the Optane/HDD pair very easily.  So, if you screw up your files, or delete files, or whatever that causes you to need to restore, there is no problem restoring to the Optane/HDD pair.

               

              Scenario 2:  You have an Optane/HDD Pair.  You want to change your HDD, perhaps to a larger HDD.  Disable the pairing, take a Macrium backup of the HDD, replace  the HDD with your new HDD, restore the backup to the new HDD, and re-pair Optane with your new HDD.

               

              Scenario 3:  This is the nightmare scenario.  If you make a backup of the Optane/HDD pair, and remove the HDD and replace it with another HDD, you will have one heck of a time restoring the backup.  The Optane module is somehow marked as being paired with another HDD.  Running the Optane software is [currently] of no help in releasing this pair.  If you wipe out all partitions the HDD and try to restore the backup, you will still fail.  And, you will likely not see the Optane module in the BIOS, nor in the Optane software.  On my NUC, no combination of efforts caused it to reappear - until (in the bios) I went to Add-in config, Intel Rapid Storage Tech, and fiddled with the settings to make it a non-raid disk and destroy the pairing.  Do not ask me the steps, but this is where I finally had success.  Once this was done, Optane was seen in the bios, with my RST setting, and I was able to boot my restored backup.  Then, I was able to run the Optane software and re-establish the pair.

               

              So, to be safe with the backups, and not have to do the nightmare scenario #3, take two Macriium backups - one with the Optane/HDD pair, and one with Optane un-paired from the HDD.  That way, if the Optane module fails, or the HDD fails, you can easily recover using a new module or HDD.

               

              The good news is that I know the backup can be restored, which is what I always preach to users.

               

              Doc

              1 of 1 people found this helpful
              • 4. Re: How to disable INTEL OPTANE memory
                Al Hill

                After a couple of hours sleep, I have decided that scenario 2 is probably the one that should be done, given that it only takes a seconds before and after the backup to disable and re-enable Optane.

                 

                Doc

                • 5. Re: How to disable INTEL OPTANE memory
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi gjanu,

                  Thank you for posting in the Intel communities.

                  It’s great to know that you were able to recover your data.

                  Regarding to your last question about the disable process. It shouldn’t take that long to complete it. It depends on the data that has been stored in the module through the time it has been used with your HDD, but normally it should take that much.

                  I found a community thread where a customer faced a similar issue during the disabling process and the root cause was the SATA cable or the drive where the OS was installed. You can check the thread here: https://communities.intel.com/message/561945#561945

                  I hope you find this information useful.

                  Have a nice day.

                  Regards,
                  Diego V.

                  • 6. Re: How to disable INTEL OPTANE memory
                    maryt_intel

                    Wow, I'm impressed, Doc! Thanks for stepping in and doing that!!

                     

                    Mary T.

                    Community Manager