1 2 Previous Next 16 Replies Latest reply on Jun 27, 2010 5:08 PM by tsevan

    HELP !! X25-M - Corrupt Master Boot Record ?

    EVGABuzzer

      Hi

       

      I bought an X-25M a few weeks ago for a new build. The rest of the new hardware was not here yet so I installed it in my old machine running XP, formatted it for NTFS with 4K clusters which I read was the best size for speed. That worked fine so I copied one little text file to it as a test. Fine.

       

      Since then its been sitting waiting for its new host machine. Now the new build is done so I connected the X-25M and tried to update the firmware. The new BIOS recognized it fine. I downloaded the firmware, burned an ISO image. Booted from that disc. The utility ran but would not complete the update. It kept saying Updated not completed - either enable Legacy [it was], set to AHCI [I tried that - same thing] or disable disk passwork [I never set one].\

       

      So, I decided to remove it and re-connect it to my old machine so I could try running Intel Tool Box to do the firmware update. I connected it and booted. When XP came up, the SSD was not listed in My Computer but Disk Manager opended. The SSD showed up as Disc 0 - not initialized. I initialized it and rebooted. Then it showed up as Disc 0, unallocated. So I tried to format it [again]. Now it says there is only 8Meg total space !!! This is an 80G SSD!!.

       

      I looked at it with Intel Toolbox - it sees it fine. The Toolbox wanted the disc formatted so I formatted it - all 8M of it as NTFS. The Optimizer said that was not enough space to do anything with.

       

      Where did my 80G go? Why when I put it back in the old machine did it show up as not formatted? I did format it - even copied one litle file to it just to test.

       

      HELP !!

       

      Thanks

       

      Message was edited by: EVGABuzzer

        • 1. Re: X25-M - Shows up as 8 Meg Total Size!!
          EVGABuzzer

          Update - From reading on the net, it seems that other have had this problem. The Master Boot Record gets screwed up [by attempting the firmware update]. If I run Intel Toolbox, the serial number of the SSD reads No Context, which is a symptom of the problem. I THINK all I am seeing is the MBR sector - 8Meg. When I first ran Toobox it said it needed the SSD to be partitioned first so I partitioned it and formatted the 8Meg as NTFS. I think that may have hosed it even further.

           

          The fix [if its not a hardware failure] is to restore it to factory condition by using HDDerase or DBan. I have tried to use both. HDDErase runs, but it does not see the SSD [the BIOS does] so I can't select it, so HDDErease can't erase it. DBan is supposed to make a bootable disc. I used a USB Thumb drive. It formats the drive but if I try to boot from it, I get No Boot Disc. If I look at the contents, I don't see any boot files, system files etc. or any .exe files that I could run if it did boot. So I guess I don't understand what DBan is doing.

           

          I tried to run DBan and then copy boot files that I made with drdos.bin but it would not boot from that either. So I can't get either total erase utility to work. Please HELP !!

           

          Thanks in advance.

          • 2. Re: X25-M - Shows up as 8 Meg Total Size!!
            NandFlashGuy

            Your best bet is to find a piece of software that can issue a "secure erase" command to the drive.  This will erase every single logical block address (LBA) and restore the drive to the factory state.

            https://ata.wiki.kernel.org/index.php/ATA_Secure_Erase

            • 3. Re: X25-M - Shows up as 8 Meg Total Size!!
              EVGABuzzer

              Thanks.

               

              I tried to use HDDErase but when it runs, it does not see the SSD so it can't erase it. I suspect this probem is related to the main problem. I will try this other utility and see what happens.

              • 4. Re: X25-M - Shows up as 8 Meg Total Size!!
                mistermokkori

                hdderase can be picky about how the drive is connected.  for best results, connect it to the first sata port (sata0/port0), then go into the bios and set the sata controller to ide mode.  if there is an additional 'enhanced/compatible' setting, set it to compatible.

                 

                configured in this manner, i have never had any problems running hdderase on any intel ssd connected to ich9/10 southbridges, with the exception of some prebuilt systems whose bios's blocked the ata secure erase command.  you did not mention what motherboard/chipset you're using, so be aware that other chipsets may have issues with hdderase.

                • 6. Re: X25-M - Shows up as 8 Meg Total Size!!
                  EVGABuzzer

                  Thanks

                   

                  When it first arrived, the other parts for my new build were not here yet. So I installed it in my old machine. It worked fine. I formatted it NTFS, 4K Clusters and copied one little test file to it. Then I put it away. When I connected it to the new machine, I did use SATA port 0. The MOBO is an EVGA 147-BL-E760 w/ X58 Chipset.  The first 6 ports are controlled by the Intel chipset. There are 2 more controlled by a JMicron controller [also handles the USB ports].

                   

                  In troubleshooting, I tried both but when I attempted the firmware update, the SSD was connected to Intel port 0. The update never completed but it obviously did something. I tried to update 3 or 4 times. All SATA ports were set to IDE wtih Legacy Mode enabled. After those attempts, I decided to try it on the old host. I installed it and booted to XP just to check it. That's when Disk Manager opened and showed the drive as not initialized, not formatted and with 8Meg total space. I tried using Intel Toolbox on it. Serial number was NO-CONTEXT. Toolbox wanted it partitioned so I did. I then formatted that 8Meg partition NTFS.

                   

                  I think that may have screwed it up even more. After that format, I put it back in the new host. That's when I tried to run HDDErase and it could not even see the drive, though the BIOS did.

                  • 7. Re: X25-M - Shows up as 8 Meg Total Size!!
                    mistermokkori

                    if you now plug the ssd back into the old system and boot into xp, will it see the ssd?  if so, run the hdd capacity restore tool on it and see if it fixes it.  i would actually do a hard cmos clear on the system first (i've seen this resolve weird issues).

                     

                    other things to try:  running hdderase on the ssd connected to the old system, and a different version of hdderase (iirc 4.0 had problems with previous x25 firmware versions).

                    • 8. Re: X25-M - Shows up as 8 Meg Total Size!!
                      w00thisButtonDo

                      In my case (same situation), hdd capacity restore tool  nothing fixed.

                      • 9. Re: X25-M - Shows up as 8 Meg Total Size!!
                        w00thisButtonDo

                        RMA drive, that's the solution.

                        • 10. Re: HELP !! X25-M - Corrupt Master Boot Record ?
                          pierry8

                          I do have the same problem, but I never did the firmware upgrade, it just loose the MBR by itself.

                          Now I can't format it as 80gb. And everything I'll try, it shows just 8gb.

                          So, be aware everyone, your Intel can just turn to this situation even if you never did any firmware upgrade or something.

                          Any help will be appreciated.

                          Pierry

                          • 11. Re: HELP !! X25-M - Corrupt Master Boot Record ?
                            EVGABuzzer

                            The new SSD is working fine. I have been loading apps on it all day. Its FAST !! As for the old one, I am half tempted to work on it some more. I still have it. I don't have to return it to Amazon for 30 days. They ship the replacement first and give you 30 days to send whatever back. Beats an Intel cross ship for $25. I was lucky I had bought it recently. If I do start fooling with it again, and fix it, I'll post what I did - maybe it will help out Pierry8 or someone else.     Thanks to all who responded.     EVGABuzzer

                            • 12. Re: HELP !! X25-M - Corrupt Master Boot Record ?
                              DukeP

                              Actually I think this was what happend to my SSD - while I was using it.

                               

                              Its clear to me, that this fault has got nothing to do with firmware updates or whatever.

                               

                              It simply seems like Intels X25-M models (perhaps only the G2 ones) are prone to dying; loosing their master partition and only having the small "hidden" error correction partition visible.

                               

                              This destroys ones data, obviously. The question is, wheter it also destroys ones confidence to the drive in question (requiring a RMA) or worse - to the product line.

                               

                              Im split here. I simply cannot afford to have my machine go dead for weeks at a time (Intels return policy is.. Dodgy).

                               

                              On the other hand, I really do like the speed, when its working.

                               

                              Hmm.

                               

                              ~~DukeP~~

                              • 13. Re: HELP !! X25-M - Corrupt Master Boot Record ?
                                EVGABuzzer

                                My new X-25M SSD is cranking along fine. I am sending the other back to Amazon tomorrow. I have read a lot about these drives, and SSDs in general - before and since buying one. I never heard of losing or corrupting the MBR until it happened to me. I don't know if it was the firmware update or not. The update process never completed for reasons unknown to me. The new one came with the latest firmware so I had no reason to attempt an update.

                                 

                                I sure hope this is not a recurring or common issue with X-25Ms - they are considered the benchmark for other SSDs. I will, however, be diligently doing full backups of it. Geez - one buys an SSD to get faster speeds [which I am getting] and higher reliability as there are no moving parts. I thought of the thing as darn near indestructible. Now I am not so sure...

                                 

                                EVGABuzzer

                                • 14. Re: HELP !! X25-M - Corrupt Master Boot Record (MBR) ?
                                  tsevan

                                  Hey Everyone,

                                   

                                  I just had a similar corrupt master boot record (MBR) issue with only 8gb available to access. I purchased it from Amazon about 60 days ago or less and 30 days later after installing it into my dell xps m1210 laptop, it crashed on me. I have been trying everything I can to trouble shoot with no luck. It looks like if I cant get secure erase to work, I am going to have to go through the RMA process inorder to get a refurbished one. Has anyone on this thread been able to resolve the corrupt MBR issue?

                                   

                                  -Tara

                                   

                                  Message was edited by: tsevan

                                  1 2 Previous Next