1 Reply Latest reply on Aug 15, 2018 6:49 PM by Al Hill

    Intel(R) Thunderbolt not visible in BIOS anymore?

    Shadi.hammoudeh

      Hi Guys,

       

      Basically I built a custom PC with the following specifications:

       

      1. Intel CPU 8700K.

      2. Gigabyte Aorus Gaming 7 Rev. 1.0.

      3. ASUS ThunderboltEX 3 card.

      4. 32GB DDR4 RAM corsair vengeance.

      5. Nvidia Quadro P4000.

       

      The reason I bought the Asus ThunderboltEX 3 card is to be able to connect my Apple Display to my PC. And for the past few months everything worked perfectly. However, recently for some weird reason things are no longer working and the Asus card can no longer serve the Apple Display. I tried all sort of things to fix the issue, I resent the CMOS, updated the BIOS to the latest version from Gigabyte website, removed the Asus card, plugged back in again, reinstalled the needed driver. However, so far no luck.

       

      I noticed something weird is that I can no longer see Intel(R) Thunderbolt in the BIOS nor ink the Device Manager, any reason why this is happening and anyone aware of a fix to this issue?

       

      Thanks,

      Shadi.