3 Replies Latest reply on Feb 18, 2011 6:48 AM by

    X25-M in Macbook Pro hanging on boot

    ceptorial

      Hello,

       

      I just purchased an Intel X25-M SSD 160GB Gen2 and installed it in my new Mid-2010 i7 15-inch Macbook Pro. When I boot up with the Snow Leopard install disc and holding C, the computer hangs on the Apple logo after accessing the CD drive for a bit. If I start up the computer without a disc, a folder with a question mark flashes. I don't know what firmware I have so I burned the firmware updater to a CD (http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18363) and put in that CD then loaded the computer both with and without holding down C, and I get the same problem with the flashing question mark. I held option down to select a volume and started the computer and the cursor appeared but then it hung. When I hold option down with the Snow Leopard install disc and select to boot from it, it shows the Apple logo and then hangs.

       

      Anyone have any ideas on how I can either update the firmware or what's going on? Any help would be much appreciated.

        • 1. Re: X25-M in Macbook Pro hanging on boot
          sjprg

          I updated my firmware in my X25-V by creating the update boot CD in a PC motherboard on the test bench. With only the CD drive and the X25 connected the update boot found the X25 and proceded from there. My Vertex Turbo required the same procedure, only much more complex requireing a jumper and jumping through hoops.

          My macBookPro took minutes, and minutes to find and start the load procedure from the Snow Leopard install CD. Go get a cup of coffee and relax while the Mac thinks.

          1 of 1 people found this helpful
          • 2. Re: X25-M in Macbook Pro hanging on boot
            ceptorial

            Okay I figured it out -- turns out the new mid 2010 Unibody Macbook Pro won't boot up properly with the original 10.6.0 Snow Leopard DVD -- you need the original 10.6.3+ installation DVD that came with the computer. Booting up with this DVD worked properly.

             

            Also make sure to use a Mac OS X utility like Burn to burn the firmware ISO, if you mount it in OS X and try to burn it from there it won't work.

            • 3. Re: X25-M in Macbook Pro hanging on boot

              Hi ceptorial,

               

              I have the exact same issue & the exact same model of Macbook Pro (mid-2010, Core i7). I too am unable to boot from this firmware CD directly. I have to admit tho I'm trying this from an external CD/DVD drive connected through USB. I replaced the internal SuperDrive for a 2nd harddrive. However, I'm sure that has nothing to do with it; with the SuperDrive still in place I would expect the same result.

               

              You're telling to boot of the original Leopard DVD. I can do that, I have it with me, but once you've booted into that DVD, how do you load up the Intel firmware CD? I'm little confused. Any help appreciated.