1 Reply Latest reply on Jul 30, 2018 1:20 AM by MartyG

    Noise of the depth image by the beam projector

    LKDH

      Hello.

      I am using the D435 with a beam projector.

      But there is one problem.

       

      When the beam is projected onto the wall and the camera is looking at the wall, there is severe noise in the depth image.

      Is there a workaround?

       

      here image.

       

      realsense viewer.PNG

      realsense viewer beam.PNG

       

      Thanks.

        • 1. Re: Noise of the depth image by the beam projector
          MartyG

          After analyzing the images very carefully, I notice a few things:

           

          1.  The room is using turned-on ceiling strip lights on the left and right sides of the room.  Strip lights are a type of lighting called fluorescent., which has a gas inside them that flickers at a rate hard to see with the human eye.  This can cause noise in the image.  That could account more for the disruption at the far left and right of the image though rather than the center, where the middle strip-light is turned off.

           

          2.  There is only a projection on the wall in the second image, not the first.  So the two pictures are 'before and after' - when the projector is off and when it is on?  If so, then since the wall disruption is present in both images, that would seem to eliminate the projector as the cause of the disruption if it is turned off in the first image.

           

          3.  If you look carefully at the IR image, you can see a pattern of dots on the surfaces in the room.  This is generated by a component in the camera called the IR Projector.  It is designed to provide the camera with texture to analyze on surfaces such as walls that do not contain much texture detail.  Combined with the intensity of the light illumination on the walls compared to other surfaces in the room, I wonder if this is contributing to the strong noise in that area.

           

          If you expand open the Stereo Module options in the Viewer's side panel by clicking on the small arrow beside 'Stereo Module' , you will see an option called 'Emitter Enabled' that is enabled by default, shown by a blue square next to it.  Could you try clicking on it to deselect it please and see if that improves your image?  If the image goes dark, you may also need to de-select the 'Enable Auto Exposure' option on the next row beneath the 'Emitter Enabled' option.